Is my LMDE system hosed?

Questions about other topics & discussing non-support related topics related to LMDE 2.
Forum rules
Before you post please read how to get help
mfreeman
Level 3
Level 3
Posts: 154
Joined: Thu Jan 21, 2010 3:11 am

Is my LMDE system hosed?

Postby mfreeman » Wed Jul 05, 2017 7:57 pm

I installed a Linux server where I work, and I decided to use LMDE, as I'm an avid Mint user (although I normally use the standard edition). Everything went fine, and we've been using it for a while with no problems. Today I realized we hadn't done an update on it in quite a while, so I went to do that through the terminal (sudo apt-get update, followed by sudo apt-get dist-upgrade). Well, I guess I wasn't paying attention and didn't realize that at the top of the enormous list of updates that had drifted off the top of the terminal was a huge list of software to be uninstalled. It wasn't until the process was well underway that I realized it was uninstalling a whole chunk of the system, including Cinnamon and loads of other software. I let the process finish, then went back trying to reinstall what had been uninstalled, and I ended up in dependency hell.

I'm not using anything but the repositories that came with LMDE 2. However, after trying to trace the dependencies down to the apparent root causes of the uninstallable ones, it appears that some of the libraries (such as libgtk3-0) in Mint's Betsy repo are preventing some of the dependencies that Cinnamon relies on from upgrading. It seems that some of the software require a higher version than Betsy provides. I tried forcing the Debian versions instead of the Betsy version on each of them, since those were higher, but that made things worse. So I put those back down to their original Betsy versions. But I'm still left with a system in dependency hell.

Is there any hope for a resolution for this? Or am I going to have to reinstall everything and hope this doesn't happen again when I try to update the system after install?

User avatar
killer de bug
Level 14
Level 14
Posts: 5313
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Is my LMDE system hosed?

Postby killer de bug » Thu Jul 06, 2017 3:47 am

Are you sure you have only the normal repo?
Are you sure you didn't install anything manually? Or did not add any repo manually?

Anyway, if you want us to help you:
1) Post the log of the apt update and apt dist-upgrade if you still have them in your terminal.
2) post the "dependency hell" that you see. Show us which package is blocking everything.

if you want to take the fatest road:
1) reinstall the system

for the future:
1) Always use the update manager in order to keep your system up to date. Don't do it manually in the terminal and especially if you don't read carefully what you are going to do.
Image
If it ain't broke, fix it until it is.


Return to “Other Topics & Open Discussion”