Can I use "Debian Testing/Bullseye" with LMDE4 Debbie?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
koesherbacon
Level 1
Level 1
Posts: 5
Joined: Tue Mar 18, 2014 6:39 am

Can I use "Debian Testing/Bullseye" with LMDE4 Debbie?

Post by koesherbacon »

I really like LMDE4. The the combination of Linux Mint plus Debian instead of Ubuntu is a great combination. I also really like Sparky Linux, which uses the Testing/Bullseye branch of Debian.

Is there a way I could get the best of both worlds by using the Debian-based LMDE4 Debbie, and switching from the Debian Stable/Buster branch that comes with LMDE4 over to the Debian Testing/Bullseye branch that comes with Sparky Linux?

Would enabling Testing in the repos completely screw everything up? I'd like to hear what all your thoughts are about this idea.

Thanks a lot!
superlinuxero
Level 1
Level 1
Posts: 10
Joined: Sat Apr 18, 2020 6:45 am

Re: Can I use "Debian Testing/Bullseye" with LMDE4 Debbie?

Post by superlinuxero »

Yes, you can, at least under Cinnamon. I have a testing machine with it and, as of now, it works perfectly. After installing LMDE4 just update your debian sources accordingly and upgrade. No need to change any apt-pinning settings.

It might happen in the future that things break. However, checking cinnamon under Debian Bullseye I realized its packages almost match the ones in LMDE4. That's why I decided to give it a try.

You could even use plain Debian Testing and install Cinnamon (no Mint here). Cinnamon under Debian is quite ugly and doesn't include all the goddies from Mint, like language installation checking, mintupdate, themes and icons, but those could be installed manually, even compiled if you wanted to.

I also have another machine to experiment with Debian Sid, Cinnamon and some mint packages. It works beautifully.

Cheers,

Ignacio
koesherbacon
Level 1
Level 1
Posts: 5
Joined: Tue Mar 18, 2014 6:39 am

Re: Can I use "Debian Testing/Bullseye" with LMDE4 Debbie?

Post by koesherbacon »

Yeah, I really like the Cinnamon customization made by the Mint team, and want to use this version of Debian since Mint is the developer of Cinnamon in the first place. I really like the combination of Mint + Debian, and being able to use Mint + Debian (Testing) makes it even more appealing! Thanks for the advice, I'm off to partition and install! Wish me luck :)
t42
Level 5
Level 5
Posts: 723
Joined: Mon Jan 20, 2014 6:48 pm

Re: Can I use "Debian Testing/Bullseye" with LMDE4 Debbie?

Post by t42 »

Can I use "Debian Testing/Bullseye" with LMDE4 Debbie?
To install Bullseye Cinnamon you can use the latest Debian Cinnamon Testing iso:
https://cdimage.debian.org/cdimage/unof ... onfree.iso
found in this directory
https://cdimage.debian.org/cdimage/unof ... so-hybrid/
here is my Debian Testing with Cinnamon 4.4.8
2020-05-12.png
Compared to LMDE, this system has a newer package base and lacks the Mint Update module. In the long run its Cinnamon version will be the same or newer then that of the LMDE version. Debian Testing is fairly stable. The absence of Mint update module is negligible for a person who is good enough to mess up with software sources :), such person should be very comfortable to update his OS a Debian way with terminal.
So, there is no practical reason to move LMDE4 to Debian Testing base except a love to experiment. If you need latest software, boot your Debian Cinnamon Testing, if you need as stable as Debian Buster and as comfortable as Mint OS, boot LMDE4.
The very first LMDE editions were based on Debian testing and were (semi-)rolling releases. Clem explained more than once why it was not practical and why LMDE moved to the Debian stable base. Here is one of his recent comments on the subject:
https://blog.linuxmint.com/?p=3860#comment-153629
-=t42=-
Karibou1312
Level 1
Level 1
Posts: 23
Joined: Thu Nov 28, 2019 9:31 am

Re: Can I use "Debian Testing/Bullseye" with LMDE4 Debbie?

Post by Karibou1312 »

Hello,
It will be fantastic if I can have LMDE4 based on Debian Sid !
Please, I am beginner, and I don't want to have Linux Minty based on Ubntu.
So, please, how can do to have a LMDE4 base on Debian Sid ?
1) If I go from LMDE4 , which file I have to modify ? what are the different steps to do that ? How update the Debian sources ?
2) If I install Debian testing, and I transform it to Debian Sid, how can I installed manually (even compiled) goddies from Mint, like language installation checking, mintupdate, themes and icons.... ? What is the procedure to do that ?
3) For superlinuxero, is your experiment machine with Debian Sid, Cinnamon and some mint packages works beautifully untl now ? or you have problems ?
Many thanks for your help !
Karibou1312
Post Reply

Return to “Newbie Questions”