software and apt behind authenticated proxy

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Thu Jul 16, 2020 3:07 pm

software and apt behind authenticated proxy

Post by tetsuo »

Well started trying to use linux about 2 months ago and at home no problem but at work I cant get software center to work behind authenticated proxy. I managed to get it working in fedora 32 about a month ago, but tried mint debbie at home and really liked it so tried at work, but couldn't get it working.
I can browse no problem just setting proxy to manual in GUI network settings but software center and apt wont work properly.
This is what I tried so far:

set proxy in /etc/apt/apt.conf

Acquire::http::Proxy "http://abcd.efg:abcd@";
Acquire::http::Proxy "https://abcd.efg:abcd@";

didn't work then I tried using this tutorial: ... edora.html
no success

set proxy in /etc/apt/apt.conf.d/02proxy

Acquire::http::Proxy "http://abcd.efg:abcd@";
Acquire::https::Proxy "https://abcd.efg:abcd@";
Acquire::ftp::Proxy "ftp://abcd.efg:abcd@";

didn't work

created a file in /etc/profile.d

export http_proxy='http://abcd.efg:abcd@';
export https_proxy='https://abcd.efg:abcd@';
export ftp_proxy='ftp://abcd.efg:abcd@';

then made it executable
sudo chmod +x /etc/profile.d/

then source
source /etc/profile.d/


when I
env | grep -i proxy

I get this


when I try to update get these kind of errors:

Err:5 debbie Release
Could not handshake: An unexpected TLS packet was received. [IP: 8080]
Ign:6 buster-backports InRelease
Err:7 buster/updates Release
Could not handshake: An unexpected TLS packet was received. [IP: 8080]

and when using software center I get a couldnt download message

I formatted and fresh installed 3 days ago and been trying since, thinking in starting a fresh install although I timeshifted and did all the above 2 or 3 times.

Any help would be immensely appreciated.
Post Reply

Return to “Newbie Questions”