Page 1 of 1

Trivial bugs on XFCE/LMDE custom install.

Posted: Tue Sep 15, 2020 9:18 pm
by joesnameisgreg
Hi folks,

I have a few odd bugs (unrelated to each other) I have found on LMDE4, and I have absolutely no idea how to submit these to the LMDE devs (Github is fairly confusing to this some-what simpleton when it comes to computers) Can somebody please help me get these bugs to the correct devs or show me the easiest way to submit them?

There is kind of an important catch..
*** All of these errors are happening on LMDE4, but with the Cinnamon desktop purged completely and replaced with XFCE desktop. All errors are reproducible with this custom modified LMDE4, however none of the errors occur in standard Linux Mint XFCE v20 distro. ***

1) CLOCK ISSUE
Right-click "Clock" > Properties > Appearance
Right-click "Clock" > Properties > Clock Options
Under this format there are four default "Custom Formats" however whenever I try to select any of them, the time disappears from the panel, and when I go back into the properties none of the settings are saved in either Appearance or Clock Options and are reverted to "Custom Format." In other words, none of the "Formatting" is saved. The only way to save this formatting is if I use the percentage custom codes (example: %r works fine, however selecting "01:22:09 AM" creates a blank clock in the panel.

2) SEPARATOR ISSUE
Right-click on Separator > Properties > Style > Transparent/Separator/Handle/Dots
When trying to add a separator in the panel, the "Separator" and "Handle" styles show up as transparent, only the "Dots" style works.

3) WEATHER UPDATE ISSUE
Under Panel Items > Weather Update, the "weather update" panel app shows "No Data."

The reason I am confused is because I am not sure if these should be submitted to XFCE devs or LMDE devs or both and also not sure of the easiest way to submit them.

Any thoughts?

Re: Trivial bugs on XFCE/LMDE custom install.

Posted: Tue Sep 15, 2020 10:11 pm
by MrEen
Hi joesnameisgreg, and welcome to the forum.

For the clock issue, see if this works; Make your changes, and while leaving the window still open, log out/in. I know that has worked for others.

The separator issue is the same as I experience on my 18.3 Mint install. I honestly didn't know I should see something, and prefer the Transparent I have always had set.

The weather info has always been on again/off again since the dawn of time. I gave up on that doohickie for that reason.

If I had to guess, I'd say the first 2 are Xfce issues, and the last is really a plugin issue due to met.no (or whatever addy it uses) keeps changing their interface. For the Xfce stuff, these are long standing issues, as my version is from 2016.

Re: Trivial bugs on XFCE/LMDE custom install.

Posted: Tue Sep 15, 2020 10:16 pm
by ajgringo619
joesnameisgreg wrote:
Tue Sep 15, 2020 9:18 pm
1) CLOCK ISSUE
Right-click "Clock" > Properties > Appearance
Right-click "Clock" > Properties > Clock Options
Under this format there are four default "Custom Formats" however whenever I try to select any of them, the time disappears from the panel, and when I go back into the properties none of the settings are saved in either Appearance or Clock Options and are reverted to "Custom Format." In other words, none of the "Formatting" is saved. The only way to save this formatting is if I use the percentage custom codes (example: %r works fine, however selecting "01:22:09 AM" creates a blank clock in the panel.
I've run into this as well. But since it can handle all sorts of custom formatting, including colors, I'll take it over the Cinnamon clock any day.

Re: Trivial bugs on XFCE/LMDE custom install.

Posted: Wed Sep 16, 2020 10:44 am
by joesnameisgreg
MrEen wrote:
Tue Sep 15, 2020 10:11 pm
If I had to guess, I'd say the first 2 are Xfce issues, and the last is really a plugin issue due to met.no (or whatever addy it uses) keeps changing their interface. For the Xfce stuff, these are long standing issues, as my version is from 2016.
Yeah still having the same troubles after the suggestions. Bummer, other than these little bugs LMDE works great, even feels a little faster than standard Mint!

Re: Trivial bugs on XFCE/LMDE custom install.

Posted: Wed Sep 16, 2020 11:27 am
by MrEen
There's also a DateTime plugin instead of the Clock plugin. You could try it and see if it meets your needs.

It's also possible the config file for the Clock plugin could be altered manually. I would guess it to be in /home/YourUserName/.config/xfce4/panel/ with a file name such as clock-#.rc. Scratch that. Just added the Clock to my panel, and it did not create a .rc file. The only things I could find were a useless .desktop file in /usr/share/xfce4/panel/plugins, and an addition to ~/.config/xfce4/xfconf/xfce-pershannel-xml/xfce4-panel.xml of the following:

Code: Select all

    <property name="plugin-19" type="string" value="clock">
      <property name="digital-format" type="string" value=""/>
      <property name="tooltip-format" type="string" value=""/>
      <property name="mode" type="uint" value="2"/>
    </property>
No idea what is safe to try adding/changing there.

Re: Trivial bugs on XFCE/LMDE custom install.

Posted: Wed Sep 16, 2020 6:39 pm
by antikythera
joesnameisgreg wrote:
Tue Sep 15, 2020 9:18 pm

There is kind of an important catch..
*** All of these errors are happening on LMDE4, but with the Cinnamon desktop purged completely and replaced with XFCE desktop. All errors are reproducible with this custom modified LMDE4, however none of the errors occur in standard Linux Mint XFCE v20 distro. ***

Any thoughts?
Yes, XFCE for LMDE4 comes straight from Debian repositories and is version 4.12.5. Since it is not officially a Mint maintained desktop environment for LMDE4 you are responsible for any problems you encounter when using it as a "custom modified LMDE4" instead of Cinnamon.

Mint 20 has a much newer version (4.14.x) which is configured by the Linux Mint team. Please do not report any of the issues in this thread as bugs to the Mint LMDE devs, they will just close them even if you did so it's best not to try.

Re: Trivial bugs on XFCE/LMDE custom install.

Posted: Wed Sep 16, 2020 6:52 pm
by MrEen
antikythera wrote:
Wed Sep 16, 2020 6:39 pm
Yes, XFCE for LMDE4 comes straight from Debian repositories and is version 4.12.5.
I hadn't even thought about that! Thanks for "reminding" me. :D

That means we're using a very similar version of Xfce (except yours doesn't have the Mint added goodies) so I can't even say if any of things have been fixed for certain, although based on history I'd guess they haven't been. But there is a chance the weather plugin has been updated to something that worked at one time, and has probably since failed. :lol: