Error performing upgrade to LDME 4

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
STI
Level 1
Level 1
Posts: 3
Joined: Thu Sep 24, 2020 10:25 am

Error performing upgrade to LDME 4

Post by STI »

Hello,

I'm trying to upgrade from LMD3 to LMDE 4. I've followed the steps in the blog post, "How to upgrade to LMDE 4" https://community.linuxmint.com/tutorial/view/2475

However, when I get to Step D2 and run "mintupgrade check" the process fails with the following error:
!! ERROR: Performing the upgrade would remove the following important packages: mintsystem.
Now as far as I can tell mintsystem is required by mintupgrade itself. The version of mintupgrade I have installed is 2020.03.19.1

Help :-)
STI
Level 1
Level 1
Posts: 3
Joined: Thu Sep 24, 2020 10:25 am

Re: Error performing upgrade to LDME 4

Post by STI »

To clarify my questions:

Does this matter? If I continue with the upgrade will it be successful?

mintsystem was installed as a dependency for mintupgrade. It isn't used by anything else I have installed.

Another question is:

Why does this seemingly not affect everyone? If mintsystem is required by mintupgrade then why is mintsystem upgradable for some people and not others?
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: Error performing upgrade to LDME 4

Post by Monsta »

Never seen that... Probably the upgrade would remove some package(s) that mintsystem depends on.
Can you please post the full output where apt shows all the packages that would be upgraded/removed?

(use the "code" tag for it, that output is usually quite big)

mintsystem was installed as a dependency for mintupgrade
This doesn't look right... mintsystem should be there from the beginning in every installation.
STI
Level 1
Level 1
Posts: 3
Joined: Thu Sep 24, 2020 10:25 am

Re: Error performing upgrade to LDME 4

Post by STI »

Thanks for the reply. In the end I decided just to do a clean install before I saw your message.

Looking at my new system, I think what's happened is that I'd uninstalled Cinnamon at some point and then added it back, but probably not using the meta package. At some point, apt decided that mintsystem was no longer needed and it was auto-removed.

Why that would cause mintupgrade to balk I don't know. But it's interesting.
Post Reply

Return to “Newbie Questions”