Problem printing to Win-7 shared printer LMDE4, works LMDE3

Questions about networking
Forum rules
Before you post please read this
Post Reply
ron_h
Level 4
Level 4
Posts: 303
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Problem printing to Win-7 shared printer LMDE4, works LMDE3

Post by ron_h »

LMDE4 64-bit Cinnamon

I upgraded my PC from LMDE3 to LMDE4 today using mintupgrade. All went well. I then started using LMDE4.

No problem till I tried to print to a shared printer on a Win-7 system. No password is required for shared print jobs on the Win-7 system and with LMDE3 I just authenticated with the Win-7 username and a blank password field on the Authentication window. It always worked fine.

On LMDE4, however, when I try to do the same, the Authenticate window just re-appears and the print job is held on the LMDE4 system. How do I get LMDE4 to send a print job to the shared Win-7 printer using the Win-7 username but blank password ? If I can't do that, what do I need to do on the LMDE4 system to print to a Win-7 shared printer ?

Ron
Last edited by karlchen on Fri Nov 06, 2020 7:16 pm, edited 3 times in total.
Reason: Moved from LMDE Hardware to LMDE Networking
jwiz
Level 3
Level 3
Posts: 150
Joined: Tue Dec 20, 2016 6:59 am

Re: Problem printing to Win-7 shared printer LMDE4

Post by jwiz »

Maybe you are not a member of the lpadmin group?
ron_h
Level 4
Level 4
Posts: 303
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Problem printing to Win-7 shared printer LMDE4

Post by ron_h »

I don't understand the question as I have no idea what 'lpadmin group' means.

I have updated printers.conf so it no longer calls for username and password. However print jobs now fail with
"Processing - unable to connect to CIFS host"
I get the same problem when trying to print to either printer on the Win-7 system.

The Win-7 system and its printers are unchanged. The LMDE3 system on this PC was able to print to both printers, the LMDE4 system on this PC can't print to either.

My wife reminded me I had a similar problem when upgrading from LMDE2 to LMDE3 on this PC :-(. In that case, it appears switching the firewall on solved the problem. This time it doesn't solve the problem.

Ron

Update : had another look at the forums. One problem in there is if printer name contains spaces. The printer name on the Win-7 machine does not contain any spaces, nor does the name on the LMDE3/LMDE4 machine. So that is not the problem.
ron_h
Level 4
Level 4
Posts: 303
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Problem printing to Win-7 shared printer LMDE4

Post by ron_h »

I used Timeshift to restore the last LMDE3 status. I am able to print (again !) to shared printer on Win-7 system, so something in the LMDE4 upgrade breaks that capability on this system. I'll have a really good look at the LMDE3 smb.conf and printers.conf before trying again to install LMDE4.

If and when I am able to print to shared printer on Win-7 system from LMDE4, I'll post again to this thread with info on what I found.

Ron
ron_h
Level 4
Level 4
Posts: 303
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Problem printing to Win-7 shared printer LMDE4 [NOT SOLVED]

Post by ron_h »

I looked at my laptop running LMDE4, which was 'mintupgrade'd from LMDE3 to LMDE4 a few months ago. As it is used primarily when travelling, and in today's crazy world I'm not doing any travelling, it's not used much (and I'd forgotten it was running LMDE4). It seems when I 'mintupgrade'd to LMDE4, I neglected to see if I could print to the shared printer on the Win-7 system. And I now find I can't, same symptom as I got with my desktop when I 'mintupgrade'd to LMDE4 the other day.

As best I can see 'active lines' in smb.conf on the LMDE4 laptop are the same as in smb.conf on the LMDE3 desktop. And the printer definition lines in printers.conf for the shared printer on the Win-7 system are the same on the LMDE4 laptop and the LMDE3 desktop. However I can print to the shared printer from the LMDE3 desktop but not from the LMDE4 laptop.

Did any SAMBA functionality change between LMDE3 and LMDE4 ?

Where do I look for settings to tweak (or indeed whatever else I need to do) to restore the functionality I have with LMDE3 (that is, print to a shared printer on Win-7) when using LMDE4 ? I will do the tweaking/whatever on the laptop, and get that printing, before again upgrading to LMDE4 on the desktop.

Ron
ron_h
Level 4
Level 4
Posts: 303
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Problem printing to Win-7 shared printer LMDE4 [NOT SOLVED]

Post by ron_h »

I have looked in Synaptic Package Manager at what packages are installed for SAMBA, CUPS and CIFS on the LMDE3 system and and the LMDE4 system. The only differences seem to be printer driver packages. So the problem does not seem to be there.

No idea where to look next.

Ron
ron_h
Level 4
Level 4
Posts: 303
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Problem printing to Win-7 shared printer LMDE4, works LMDE3 [NOT SOLVED]

Post by ron_h »

Now I'm really confused.

LMDE4 laptop : submit print job to shared printer on Win-7 PC, "Processing - unable to connect to CIFS host".

LMDE4 laptop : submit print job to a "network printer (discovered)" which is actually the network printer on the LMDE3 system which is really the shared printer on the Win-7 system - and the bloody thing prints !!!!!! I have never seen any "network printer (discovered)" on my LMDE3 systems, it's new to me with LMDE4 (correction). And I didn't realise that a network printer on System-A could be a network printer on system-B that is really a shared printer on System-C.

Ron
ron_h
Level 4
Level 4
Posts: 303
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Problem printing to Win-7 shared printer LMDE4, works LMDE3 [NOT SOLVED]

Post by ron_h »

More evidence of something differenly set up with respect to the local network :

If on the LMDE3 desktop, I open Nemo and click on Network, I see a list of all the machines on the local network, including the LMDE3 machine itself. Oddly, though, the LMDE4 laptop appears twice, the other machines appear only once,

On the LMDE4 laptop, Nemo-Network does not list any of the other machines on the local network, just the LMDE4 machine.

Ron
ron_h
Level 4
Level 4
Posts: 303
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Problem printing to Win-7 shared printer LMDE4, works LMDE3 [NOT SOLVED]

Post by ron_h »

In /var/log/cups/error.log on the LMDE4 machine, as well as the "Processing - unable to connect to CIFS host" message there are 2 lines

Code: Select all

Connection failed: NT_STATUS_UNSUCCESSFUL

Code: Select all

Connection failed: NT_STATUS_CONNECTION_REFUSED
Any ideas where I look next ?

Ron
ron_h
Level 4
Level 4
Posts: 303
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Problem printing to Win-7 shared printer LMDE4, works LMDE3 [NOT SOLVED]

Post by ron_h »

I wiped the LMDE4 system on my laptop that had been created by mintupgrade. I then did a new install of LMDE4 64 bit from the iso.

I am horrified that this LMDE4 system has exactly the same problem. I cannot print to the shared printer on the Win-7 system, same errors.

Ron
ron_h
Level 4
Level 4
Posts: 303
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Problem printing to Win-7 shared printer LMDE4, works LMDE3 [NOT SOLVED]

Post by ron_h »

Now I have found a new install LMDE4 system has the same problem as a mintupgraded LMDE4 system, I agree this thread does not belong in Installation and Boot. But I don't see the rationale for moving it to Hardware Support.

ETA I have attempted to summarise the problem in a new post to Networking.

Ron
ron_h
Level 4
Level 4
Posts: 303
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Unable to print on Win-7 shared printer from LMDE4

Post by ron_h »

I have a home network connected via an ADSL modem/router. There are Win-7, Win-10, LMDE3 and LMDE4 PCs. Shared printers are USB attached to a Win-7 PC. Win-7, Win-10 and LMDE3 PCs can print to the shared printers. The problem is with LMDE4.

A LMDE3 desktop could print to the shared printers, when I mintupgraded to LMDE4, it couldn't with "Processing - unable to connect to CIFS host" . I Timeshifted back to LMDE3, it can print again to the shared printers. The printer definitions in printers.conf, including the smb:// address, are the same in the LMDE3 system and the LMDE4 system.

A LMDE3 laptop could print to the shared printers, when I mintupgraded to LMDE4, it couldn't. I then did a new install of LMDE4 from the ISO, added one of the shared printers, and it still can't. The printer definitions in printers.conf are the same in the LMDE3 and LMDE4 systems.

Every time I submit a print job from LMDE4, In /var/log/cups/error.log on the LMDE4 machine, as well as the "Processing - unable to connect to CIFS host" message there are 2 lines

Code: Select all

Connection failed: NT_STATUS_UNSUCCESSFUL

Connection failed: NT_STATUS_CONNECTION_REFUSED
I have looked at various tutorials and posts relating to Samba and sharing, made changes to smb.conf, and nothing has made any difference.

It now looks to me like a networking issue possibly with the higher level of Samba in LMDE4. Can anyone help ?

Ron
Last edited by karlchen on Fri Nov 06, 2020 7:17 pm, edited 1 time in total.
Reason: Merged into existing thread "Problem printing to Win-7 shared printer LMDE4, works LMDE3"
User avatar
AndyMH
Level 14
Level 14
Posts: 5015
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Unable to print on Win-7 shared printer from LMDE4

Post by AndyMH »

ron_h wrote:
Fri Nov 06, 2020 5:30 pm
made changes to smb.conf, and nothing has made any difference.
How about telling us what changes you made?

Did you read this viewtopic.php?f=42&t=322404&p=1831297&h ... 0#p1831297?
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
User avatar
karlchen
Level 21
Level 21
Posts: 13536
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Problem printing to Win-7 shared printer LMDE4, works LMDE3

Post by karlchen »

The linked thread, viewtopic.php?f=42&t=322404&p=1831297&h ... 0#p1831297, is about Mint 20, not about LMDE 4. Does it apply to LMDE 4 as in the same way?
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)
Post Reply

Return to “Networking”