Page 1 of 1

[SOLVED] Unable to enter encryption passkey in plymouth...

Posted: Sat Sep 08, 2018 9:53 pm
by rudepeople
I just finished a new install of LMDE3 (First time in a long time), and I've hit a bit of a snag.

I have a trivially custom setup (LVM on Luks with EFI/grub2 and a separate /home drive), but I believe I have everything set correctly, but when I reboot I get a nice plymouth splash screen with a prompt to enter my password... however, the field is dead. there is instead a blinking cursor in the top left and everything I type is entered in clear text and plymouth seems to be ignoring any text entered...

This is a fairly familiar issue to me as I'm coming from Arch Linux and the same thing happens if you miss a hook. checking for the "Debian way" I have found I am supposed to add three lines to /etc/initramfs-tools/modules:

Code: Select all

intel_agp
drm
i915 modeset=1
I've done this, and then ran update-initramfs and update-grub... still no joy. I get a lovely splash screen, but I still can't actually enter my password...

To be clear, root is located on an NVME drive, so booting with text only (removing "splash" from /etc/default/grub) isn't all that bad, but I want all the pretties!

Any ideas?

[SOLVED] Unable to enter encryption passkey in plymouth...

Posted: Tue Sep 11, 2018 7:06 pm
by rudepeople
I resolved my own issue... turns out this is a thing with Debian, specifically running Debian in a virtual machine. there isn't a virtualbox guest kernel module for initramfs... at least not one I've found that works just yet.

Even so, for anyone testing LMDE3 in VirtualBox, kill "splash" in /etc/default/grub...

change this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet"
LMDE works fine in VM without it (though you wont get the pretties).

Reading material for anyone wanting to check my sources!