Cant boot with LMDE install HP Laptop

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
banshee28
Level 1
Level 1
Posts: 3
Joined: Fri Apr 12, 2019 4:49 pm

Cant boot with LMDE install HP Laptop

Post by banshee28 » Fri Apr 12, 2019 4:58 pm

Hello, new here to Mint, but have been running Linux Debian and a few other distros before.

I installed LMDE fine on a standalone PC, liked it alot and decided to install on a HP laptop. It currently has Windows so I installed on a USB SSD and thought it was not dual-boot but maybe it was technically dual boot? Anyways it worked great, no issues.

I decided to remove the Windows HD and move the SSD from the USB port to internal. Well once I did that, it no longer seen any OS image to boot from. I thought since I installed it and formatted it ONLY on the SSD it should not have anything to do with Windows?

I went into the BIOS and disabled any UEFI options and used Legacy. I also changed the AHCI to IDE for the HD, but no combination worked!

Using EFI, I tried to set the /boot partition to boot-efi but it did not make a diff. I booted Mint (Live USB) and modified grub on the disk "sda" but it did not help.

I booted Mint (Live USB Ubuntu vers) and installed it, and sure enough NO issues, it installed and booted.

However I much prefer the LMDE instead.

Any suggestions here?

hwalinga
Level 1
Level 1
Posts: 24
Joined: Wed Oct 11, 2017 6:52 pm

Re: Cant boot with LMDE install HP Laptop

Post by hwalinga » Sat Apr 20, 2019 12:58 pm

You probably need to reinstall grub. I think grub was installed on the HDD of Windows and since that is gone now there is no bootloader anymore. Look up boot-repair-disk to create a USB from which you can recover your linux by reinstalling grub.

banshee28
Level 1
Level 1
Posts: 3
Joined: Fri Apr 12, 2019 4:49 pm

Re: Cant boot with LMDE install HP Laptop

Post by banshee28 » Sun Apr 21, 2019 11:36 pm

Thanks.... I was thinking that at some point and tried that too, but eventually it failed. I then totally removed the Windows HD, installed again (from USB live disk) on the ONLY HD in the laptop and same issue on reboot. Weird.
** I think I will also put back in the Windows HDD and make sure it still works and see what is going on there. **

DanielR
Level 4
Level 4
Posts: 241
Joined: Mon Sep 23, 2013 1:22 pm

Re: Cant boot with LMDE install HP Laptop

Post by DanielR » Tue Apr 23, 2019 4:05 am

I think I had a similar issue with my HP laptop. However, it wasn't dual boot but a fresh standalone install. LMDE3 installed just fine but the system couldn't find a boot device when booting from the HDD. Booting from the live cd and then selecting my HDD installation worked. It finally turned out I didn't set the labels for the partitions right during installation.

First I disabled UEFI and all Windows related boot options in BIOS. During the installation in the partition setup you have to assign the label boot/efi to your boot partition. In my case it worked on an ext4 formatted root partition (sda1), I didn't had to set up a separate FAT32 EFI partition. Depending on your laptop your mileage may vary.

Here is guide on the LMDE3 installation process. Unfortunately it's in German but from the pictures of the partitioning process you should get the right clues to set up your system: https://www.linuxmintusers.de/index.php ... _von_LMDE3

banshee28
Level 1
Level 1
Posts: 3
Joined: Fri Apr 12, 2019 4:49 pm

Re: Cant boot with LMDE install HP Laptop

Post by banshee28 » Tue Apr 23, 2019 1:49 pm

Thanks DanielR... Sounds like this may be the issue. I will try to find some time and try this again.

Post Reply

Return to “Installation & Boot”