Page 1 of 1

Grub Rescue when installing LMDE 3

Posted: Thu Apr 18, 2019 1:32 pm
by kay-tee
I was installing LMDE 3 from a live stick and canceled partway through. Now when I boot the computer I get “error: file `/boot/grub/i386-pc/normal.mod' not found. Entering rescue mode... grub rescue>”
It is looking for a command to enter grub rescue. Please, what is the command? And what should I be looking for once in grub rescue? Holding down the left shift key does not bring up grub.
Much thanks,
Katie

Re: Grub Rescue when installing LMDE 3

Posted: Thu Apr 18, 2019 7:20 pm
by bodhin
did you do updates today? i updated my debian and was trying to boot a live cd of another distro and do not remeber exactly the specific situation now but i too had the same thing happen. i thought it was rather weird. foced quite with power button and started up again and no issue. i will tri the debain laptop again in a while and let you know what happened this time around. as i said i did do the updates on all my linux laptops this AM.


edit. i may be wrong now that i think of it - it was a dell my wife has running bodhi that hadd issues - it was fixed by doing the updates. my 2 bodhi machines have no issues re: this grub error. try doing an update... may fix it.

Re: Grub Rescue when installing LMDE 3

Posted: Fri Apr 19, 2019 1:42 pm
by kay-tee
Thanks Bodhin, but no. Was installing the OS. Didn't get as far as updates.
Katie

Re: Grub Rescue when installing LMDE 3

Posted: Fri Apr 19, 2019 3:50 pm
by bodhin
hmmm. just weird that i ran across this at boot on my wife's at the same time you had it too.... so did you get it installed? if you did - then do sudo apt-get update and then sudo apt-get dist-upgrade. it fixed mine for whatever reason. in 15 years i never saw that error before.

Re: Grub Rescue when installing LMDE 3

Posted: Fri Apr 19, 2019 4:42 pm
by KBD47
You said you cancelled halfway through. Can't you just start the installation over again?
Or are you saying the installation cancelled itself?

Re: Grub Rescue when installing LMDE 3

Posted: Sat Apr 20, 2019 2:30 pm
by kay-tee
Thanks for helping.
I attempted the install from a live stick and the OS ran fine from the stick. But when I clicked on "Install" it seemed to hang up after a couple of minutes. I let it sit for a few more minutes but ran out of time and had to poweroff thinking I'd just start over the next day using the Calamares Installer. On booting the next day, I got the 'Entering Rescue Mode, Grub Rescue." It is asking me to enter a command. If I could enter Grub Rescue, maybe I can fix it.
And also, I just wanted to experiment with LMDE 3 and wasn't installing it on my main machine (Mint 19). So no files on the experimental machine, nothing to be lost.
Thanks,
Katie

Re: Grub Rescue when installing LMDE 3

Posted: Tue Apr 23, 2019 1:49 pm
by kay-tee
I looked around for more information on my problem and learned that typing the command ls in Grub Rescue brings up the Partitions. My partition (hd0,msdos1) displays: ./ ../ lost+found/ initrd.img initrd.img.old vmlinuz vmlinuz.old bin/ boot/ dev/ etc/ home/ lib/ lib64/ media/ mnt/ opt/ proc/ root/ run/ sbin/ srv/ sus/ tmp/usr/ var/
Not sure if this is a problem or where to go from here. Anyone?
Katie