LMDE 3 and Buster [SOLVED]

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Monsieurzik
Level 1
Level 1
Posts: 9
Joined: Wed Sep 24, 2008 3:55 pm

LMDE 3 and Buster [SOLVED]

Post by Monsieurzik » Thu Jul 04, 2019 6:00 am

I would like to know if it would be possible to update to Buster by changing the sources list of a LMDE 3 (only the official debian repos).
What problems could occured ?
Last edited by Monsieurzik on Sat Jul 06, 2019 1:36 am, edited 1 time in total.
LMDE 3 - Mate 1.20

User avatar
Pierre
Level 19
Level 19
Posts: 9173
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: LMDE 3 and Buster

Post by Pierre » Thu Jul 04, 2019 9:10 am

you would risk breaking the LMDE system, more than anything:
- so be prepared for annother re-install of your LMDE system.

NB: if your machine has enough RAM / memory - - at least 8Gb anyway:
- you could install an VirtualBox and then install LMDE3 into that & then try out your idea(s).
that way, if anything does break - you can recover, much more easily, from that.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

axisofevil
Level 3
Level 3
Posts: 111
Joined: Mon Nov 14, 2011 12:22 pm

Re: LMDE 3 and Buster

Post by axisofevil » Thu Jul 04, 2019 11:13 am

You could just load Debian Buster to see what you think of vanilla Debian.

User avatar
Monsieurzik
Level 1
Level 1
Posts: 9
Joined: Wed Sep 24, 2008 3:55 pm

Re: LMDE 3 and Buster

Post by Monsieurzik » Thu Jul 04, 2019 12:23 pm

Just install Vanilla Debian and it seems to be a good compromise.
I miss the update icon in the systray but it works so good.
Thanks for the tips

And my computer doesn't allow me to run a virtual machine.
LMDE 3 - Mate 1.20

ddurdle
Level 3
Level 3
Posts: 146
Joined: Sat Dec 17, 2011 10:03 am

Re: LMDE 3 and Buster [SOLVED]

Post by ddurdle » Mon Sep 02, 2019 12:04 pm

No issues with "upgrading" to Buster on LMDE 3.0 here.

I use BTRFS, so I have a snapshot of LMDE 3.0 pre-upgrade-to-buster, so whenever LMDE 4.0 comes out, I'll just upgrade from the snapshot rather then this Frankenstein upgrade.

I had no issues. Everything works nicely. A few Stretch-based issues that were resolved in Buster are working nicely. I'm using MATE with Compiz+Fusion. Buster has official Compiz support, so all I had to do was remove the Compiz-reloaded during the upgrade so I can replace it with the official and newer Compiz.

Obviously the LMDE 3 update tools and manager don't work (crash on running). But I won't need them until it is LMDE 4.0 time -- at such time I'll upgrade from my snapshot. Until then, I''ll use "sudo apt update;sudo apt dist-upgrade"

Post Reply

Return to “Installation & Boot”