Page 1 of 1

Mint Update no longer showing in task bar

Posted: Mon Aug 12, 2019 7:05 am
by Zweitaktmotor
I think I'd better make this a separate thread:

After the latest update to Mint Update, it no longer shows in the task bar. This happens on all machines where I performed the update.

Of course, you can call the application from the menu, but I am maintaining a few machines for less savvy computer users and used to tell them to watch whether the symbol is green or blue. Now they will no longer be alerted when new updates are waiting.

Can someone look into this, please?

Many thanks.

Re: Mint Update no longer showing in task bar

Posted: Mon Aug 12, 2019 7:17 am
by Pjotr
There seems to be a bug in Cinnamon (at least in the Cinnamon of Mint 19.2) which can cause this in certain circumstances. As a workaround, you might do this:
https://easylinuxtipsproject.blogspot.c ... html#ID3.7
(item 3.7)

Wenn's nicht geht so wie es muss, dann muss es mal so wie es geht. :mrgreen:

Re: Mint Update no longer showing in task bar

Posted: Mon Aug 12, 2019 7:23 am
by gm10
Pjotr wrote:
Mon Aug 12, 2019 7:17 am
There seems to be a bug in Cinnamon which causes this in certain circumstances. As a workaround, you might do this:
https://easylinuxtipsproject.blogspot.c ... html#ID3.7
(item 3.7)
So is it the delay or starting it twice that does it? Because if it's just the delay that should be the only thing you change.

Re: Mint Update no longer showing in task bar

Posted: Mon Aug 12, 2019 1:04 pm
by HAWR
I experience the same behaviour with the not displayed icon and my workaround is restarting cinnamon in the panel and the icon immediately appears.

Re: Mint Update no longer showing in task bar

Posted: Mon Aug 12, 2019 5:44 pm
by stephanieswitzer
While waiting for a fix, After booting I simply start Update Manager from the Menu then after checking for updates I close Update Manager and the icon and stays in the panel

Re: Mint Update no longer showing in task bar

Posted: Mon Aug 12, 2019 7:03 pm
by carum carvi
Zweitaktmotor wrote:
Mon Aug 12, 2019 7:05 am
After the latest update to Mint Update, it no longer shows in the task bar. This happens on all machines where I performed the update.

Of course, you can call the application from the menu, but I am maintaining a few machines for less savvy computer users and used to tell them to watch whether the symbol is green or blue. Now they will no longer be alerted when new updates are waiting.
In LM 19 / 19.1 / 19.2 you can choose to AUTOMATE the updates. Less experienced computer users never have to think about it any more. :D

For somewhat more experienced users the answers given above would help perfectly for the time being.

I like to add that my own solution was simple and almost 100% effetive as well:

Right click on the desktop panel. Select Panel Settings. And change the icons to a different size back and forth. No guarantees, but I had only 1 time that my update icon got broken ever since...

Re: Mint Update no longer showing in task bar

Posted: Tue Aug 13, 2019 1:10 am
by Zweitaktmotor
OK, the icon seems to reappear with the above. Many thanks.

But I am still puzzled why I sometimes am not able to log in with my root password. I am absolutely sure to type in the right one, no caps lock is on etc. but the log in window just gives me a shake. This panicks me a bit.

Then, after a couple of restarts, it suddenly works again.

Still experimenting trying to reproduce this behaviour...

Re: Mint Update no longer showing in task bar

Posted: Wed Aug 14, 2019 6:03 am
by tito2013
On my system Mint Update does show in the task bar when there is an update available. Otherwise not.

Re: Mint Update no longer showing in task bar

Posted: Wed Aug 14, 2019 11:55 am
by carum carvi
Zweitaktmotor wrote:
Tue Aug 13, 2019 1:10 am
.But I am still puzzled why I sometimes am not able to log in with my root password. I am absolutely sure to type in the right one, no caps lock is on etc. but the log in window just gives me a shake. This panicks me a bit.
Login can be automated as well of course. During install one can choose to automatically login. After install it WAS possible to change the automated login as well, but I cant find the right place to change it afterwards, although System Settings / Administration / User groups seems to be the most logical place to change it.

A last tip for your login problem:
In the system settings you can select to SHOW your password while you enter it. Perhaps this setting can help you discover WHICH keyboard button is failing on you WHILE you type in your password, because I have never heard on this forum about the login not working properly. Last time someone had this complaint a paperclip part had gotten stuck between the keyboard keys. Perhaps there is another reason why 1 keyboard key fails on you...

Re: Mint Update no longer showing in task bar

Posted: Wed Aug 14, 2019 12:07 pm
by Zweitaktmotor
Hi Carum,

Many thanks, but it doesn't seem to be something as trivial as that. It happens when I am asked for my root password (e.g. when changing a printer setting or applying updates). I am 100% sure I type the correct password, but the system refuses me.

Holger

Re: Mint Update no longer showing in task bar

Posted: Wed Aug 14, 2019 12:38 pm
by gm10
Zweitaktmotor wrote:
Wed Aug 14, 2019 12:07 pm
Many thanks, but it doesn't seem to be something as trivial as that. It happens when I am asked for my root password (e.g. when changing a printer setting or applying updates). I am 100% sure I type the correct password, but the system refuses me.
Just in case: That isn't asking for the root password but for your login password.

Re: Mint Update no longer showing in task bar

Posted: Wed Aug 14, 2019 4:52 pm
by cgagnor
Hello, I have made some test, if you would find it useful, clean install 19.2 cinnamon nothing installed more than standard and default start-up settings and I still I have the display icon missing, probably in some configuration did not work in any case. In the second machine I have is still ok. So I am not sure anymore it will depends on other programs at startup. Bye :wink: