Problem getting Timeshift installed

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
c++
Level 1
Level 1
Posts: 27
Joined: Thu Nov 02, 2017 10:45 pm

Problem getting Timeshift installed

Post by c++ » Sat Sep 01, 2018 12:27 pm

hi there !

WHY so complicated , tedious the upgrade ?

:x

edit : according to this site : https://itsfoss.com/backup-restore-linux-timeshift/ , some users say timeshift is not trustworthy !

recommendation for something better ?

c++
Level 1
Level 1
Posts: 27
Joined: Thu Nov 02, 2017 10:45 pm

Re: LMDE 3 “Cindy” Cinnamon released!

Post by c++ » Sun Sep 02, 2018 7:58 am

^

Code: Select all

Think this post is asked and answered
nope , in this case !
:?:
Last edited by c++ on Sun Sep 02, 2018 8:06 am, edited 1 time in total.

gm10
Level 18
Level 18
Posts: 8684
Joined: Thu Jun 21, 2018 5:11 pm

Re: LMDE 3 “Cindy” Cinnamon released!

Post by gm10 » Sun Sep 02, 2018 8:06 am

Timeshift works fine in principle. There are some known bugs that will hopefully get fixed in the repo version eventually.
Last edited by gm10 on Sun Sep 02, 2018 4:09 pm, edited 4 times in total.

c++
Level 1
Level 1
Posts: 27
Joined: Thu Nov 02, 2017 10:45 pm

Re: LMDE 3 “Cindy” Cinnamon released!

Post by c++ » Sun Sep 02, 2018 8:42 am

^
thx dude !

c++
Level 1
Level 1
Posts: 27
Joined: Thu Nov 02, 2017 10:45 pm

Re: LMDE 3 “Cindy” Cinnamon released!

Post by c++ » Sun Sep 02, 2018 3:24 pm

gm10 wrote:
Sun Sep 02, 2018 8:06 am
Timeshift works fine in principle, but I suggest you get it directly from the developer's PPA rather than from the Mint repo, see here:
https://github.com/linuxmint/mintsystem ... -417861703
thx for the help , but :

Code: Select all

# add-apt-repository -y ppa:teejee2008/ppa
Adding PPAs is not supported
runnin LMDE !

:roll:

gm10
Level 18
Level 18
Posts: 8684
Joined: Thu Jun 21, 2018 5:11 pm

Re: LMDE 3 “Cindy” Cinnamon released!

Post by gm10 » Sun Sep 02, 2018 3:55 pm

c++ wrote:
Sun Sep 02, 2018 3:24 pm
runnin LMDE !
Yeah, brain fart, of course LMDE does not support PPAs (at least not easily), those are for Ubuntu. Get the .deb from https://github.com/teejee2008/timeshift/releases (edited my post above).

c++
Level 1
Level 1
Posts: 27
Joined: Thu Nov 02, 2017 10:45 pm

Re: LMDE 3 “Cindy” Cinnamon released!

Post by c++ » Sun Sep 02, 2018 4:07 pm

i'm out of luck pal :
http://oi68.tinypic.com/2jaeutc.jpg
: |

gm10
Level 18
Level 18
Posts: 8684
Joined: Thu Jun 21, 2018 5:11 pm

Re: LMDE 3 “Cindy” Cinnamon released!

Post by gm10 » Sun Sep 02, 2018 4:09 pm

My browser doesn't load that link but I assume the .deb doesn't work. In that case best just stick to the repo version or give compiling from source a shot. ;)

c++
Level 1
Level 1
Posts: 27
Joined: Thu Nov 02, 2017 10:45 pm

Re: LMDE 3 “Cindy” Cinnamon released!

Post by c++ » Sun Sep 02, 2018 4:12 pm

^
Error: dependency is not satisfiable : libgtk-3-0 (>=3.16.2 )
:P

what a ordeal , man . . .
:x

gm10
Level 18
Level 18
Posts: 8684
Joined: Thu Jun 21, 2018 5:11 pm

Re: LMDE 3 “Cindy” Cinnamon released!

Post by gm10 » Sun Sep 02, 2018 4:47 pm

c++ wrote:
Sun Sep 02, 2018 4:12 pm
^
Error: dependency is not satisfiable : libgtk-3-0 (>=3.16.2 )
Really? That should be fine though, LMDE3 comes with libgtk-3-0 v3.22.11-1

c++
Level 1
Level 1
Posts: 27
Joined: Thu Nov 02, 2017 10:45 pm

Re: LMDE 3 “Cindy” Cinnamon released!

Post by c++ » Sun Sep 02, 2018 6:40 pm

Code: Select all

~ $ mintupgrade check
[3;J






  + Checking your Linux Mint codename...

  + Checking your Linux Mint edition...

  + Checking your Timeshift configuration...

  + Checking your Display Manager...

  + Checking packages...

------------------------------------------------
!!  ERROR: Please remove gnome-media. It is known to create issues with this upgrade.
!!  Exiting.
Wow folks ... this is amazing . . .

User avatar
MrEen
Level 13
Level 13
Posts: 4521
Joined: Mon Jun 12, 2017 8:39 pm

Re: LMDE 3 “Cindy” Cinnamon released!

Post by MrEen » Sun Sep 02, 2018 7:01 pm

gm10 wrote:
Sun Sep 02, 2018 4:47 pm
c++ wrote:
Sun Sep 02, 2018 4:12 pm
^
Error: dependency is not satisfiable : libgtk-3-0 (>=3.16.2 )
Really? That should be fine though, LMDE3 comes with libgtk-3-0 v3.22.11-1
Looks like the error was from trying to use Timeshift before upgrading to LMDE3 which based on posting history is probably the deb version from github and not from the repos.

User avatar
Moem
Level 19
Level 19
Posts: 9162
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Problem getting Timeshift installed

Post by Moem » Mon Sep 03, 2018 2:51 am

Mod note:
Split off from viewtopic.php?f=143&t=276672
Please do not ask support questions in the Releases and Announcements section of the forum. Thanks!
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

Post Reply

Return to “Software & Applications”