Set Mate as default Desktop?

Questions about applications and software
Forum rules
Before you post please read how to get help
cb474
Level 3
Level 3
Posts: 125
Joined: Thu Dec 11, 2008 9:01 am

Set Mate as default Desktop?

Post by cb474 » Wed Sep 05, 2018 7:50 am

I did the upgrade to LMDE3 from LMDE2 Mate, which required installing Cinammon to make things work. But I still have Mate also.

In the new LightDM display manager Cinammon is set as the default desktop and I can't figure out how to get that to change. I tried editing /etc/lightdm/lightdm.conf.d/70-linuxmint.conf and changed it to "user-session=mate." But that didn't make any difference.

Anyone have an idea how to do this?

User avatar
Pierre
Level 17
Level 17
Posts: 7405
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Set Mate as default Desktop?

Post by Pierre » Wed Sep 05, 2018 7:57 am

do you have both Mate & Cinnamon installed ?
then, if you just log-out, select Mate from the log-in screen,
then that should stay with that setting, until you change it back to Cinnamon again.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
administrollaattori
Level 14
Level 14
Posts: 5311
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Set Mate as default Desktop?

Post by administrollaattori » Wed Sep 05, 2018 3:31 pm

Open Terminal and run:

Code: Select all

sudo update-alternatives --config x-session-manager

User avatar
Flemur
Level 16
Level 16
Posts: 6107
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Set Mate as default Desktop?

Post by Flemur » Wed Sep 05, 2018 3:34 pm

If none of the better answers work, try re-installing mate.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

User avatar
trytip
Level 8
Level 8
Posts: 2137
Joined: Tue Jul 05, 2016 1:20 pm

Re: Set Mate as default Desktop?

Post by trytip » Wed Sep 05, 2018 3:45 pm

i installed XFCE on top of Cinnamon. i logged off changed the session to XFCE and that became my default. why would you need special commands or altering files? does LMDE not act the same?
Image

cb474
Level 3
Level 3
Posts: 125
Joined: Thu Dec 11, 2008 9:01 am

Re: Set Mate as default Desktop?

Post by cb474 » Wed Sep 05, 2018 4:39 pm

Thanks for the replies.

Selecting Mate from the log-in screen is not remembered. When I logout and back in, it always goes back to Cinammon.

I did see when I restrated my system today that editing /etc/lightdm/lightdm.conf.d/70-linuxmint.conf, as I mentioned in the OP, caused Mate to be labeled the default session in the list on the log-in screen. But LightDM still actually defaulted to Cinammon. Perhaps just because it is the top entry in the list?

"sudo update-alternatives --config x-session-manager" did not help, because when I ran that Mate was already set as the default (probably because of 70-linuxmint.conf).

Are there really no other options than reinstalling Mate?

gm10
Level 10
Level 10
Posts: 3425
Joined: Thu Jun 21, 2018 5:11 pm

Re: Set Mate as default Desktop?

Post by gm10 » Wed Sep 05, 2018 5:47 pm

cb474 wrote:
Wed Sep 05, 2018 4:39 pm
Are there really no other options than reinstalling Mate?
Run this in a terminal and post the output please:

Code: Select all

F=/var/cache/lightdm/dmrc/$USER.dmrc;sudo ls -l $F;sudo cat $F

cb474
Level 3
Level 3
Posts: 125
Joined: Thu Dec 11, 2008 9:01 am

Re: Set Mate as default Desktop?

Post by cb474 » Wed Sep 05, 2018 9:35 pm

I get:

Code: Select all

-rw-r--r-- 1 root root 25 Sep  5 13:21 /var/cache/lightdm/dmrc/username.dmrc


[Desktop]
Session=mate

gm10
Level 10
Level 10
Posts: 3425
Joined: Thu Jun 21, 2018 5:11 pm

Re: Set Mate as default Desktop?

Post by gm10 » Thu Sep 06, 2018 12:07 am

Thanks. Please run these commands and hopefully your DE-selection "sticks" after your next login:

Code: Select all

sudo chown 644 ~/.dmrc
and

Code: Select all

sudo chown -Rc $USER:$USER $HOME

User avatar
administrollaattori
Level 14
Level 14
Posts: 5311
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Set Mate as default Desktop?

Post by administrollaattori » Thu Sep 06, 2018 2:21 am

cb474 wrote:
Wed Sep 05, 2018 4:39 pm
"sudo update-alternatives --config x-session-manager" did not help, because when I ran that Mate was already set as the default (probably because of 70-linuxmint.conf).

Are there really no other options than reinstalling Mate?
Reinstall mate-desktop

Code: Select all

apt install --reinstall mate-desktop-environment mate-applets mate-system-monitor mate-utils 

cb474
Level 3
Level 3
Posts: 125
Joined: Thu Dec 11, 2008 9:01 am

Re: Set Mate as default Desktop?

Post by cb474 » Thu Sep 06, 2018 2:32 am

Thanks for the suggestions gm10 and administrollaattori. Unfortunately neither of those suggestions worked. Any more ideas?

gm10
Level 10
Level 10
Posts: 3425
Joined: Thu Jun 21, 2018 5:11 pm

Re: Set Mate as default Desktop?

Post by gm10 » Thu Sep 06, 2018 2:34 am

cb474 wrote:
Thu Sep 06, 2018 2:32 am
Thanks for the suggestions gm10 and administrollaattori. Unfortunately neither of those suggestions worked. Any more ideas?
Nope, sorry, that was my only one. I'm not aware of anything else that controls the default DE selection unfortunately. I'd be interested to learn should you figure it out.

cb474
Level 3
Level 3
Posts: 125
Joined: Thu Dec 11, 2008 9:01 am

Re: Set Mate as default Desktop?

Post by cb474 » Thu Sep 06, 2018 2:38 am

The weird thing is, as I said above, that after I changed the setting to Mate being the default desktop, it in fact is labeled as the default in the drop down menu on the login screen. The login manager just doesn't actually default to Mate.

Anyway, thanks for your help. I'll post here if I figure anything out.

User avatar
administrollaattori
Level 14
Level 14
Posts: 5311
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Set Mate as default Desktop?

Post by administrollaattori » Thu Sep 06, 2018 2:41 am

cb474 wrote:
Thu Sep 06, 2018 2:38 am
The weird thing is, as I said above, that after I changed the setting to Mate being the default desktop, it in fact is labeled as the default in the drop down menu on the login screen. The login manager just doesn't actually default to Mate.

Anyway, thanks for your help. I'll post here if I figure anything out.
You can test if LightDM is the problem. Press Ctrl Alt F2 and login via tty and run startx -- :2

Note caps between x -- and -- :

gm10
Level 10
Level 10
Posts: 3425
Joined: Thu Jun 21, 2018 5:11 pm

Re: Set Mate as default Desktop?

Post by gm10 » Thu Sep 06, 2018 3:05 am

Maybe a simple

Code: Select all

sudo dpkg-reconfigure lightdm
helps. And/or

Code: Select all

apt install --reinstall slick-greeter
sudo dpkg-reconfigure slick-greeter
But I'm throwing stuff at the wall now, hoping something will stick.

cb474
Level 3
Level 3
Posts: 125
Joined: Thu Dec 11, 2008 9:01 am

Re: Set Mate as default Desktop?

Post by cb474 » Mon Sep 10, 2018 1:53 am

administrollaattori wrote:
Thu Sep 06, 2018 2:41 am
You can test if LightDM is the problem. Press Ctrl Alt F2 and login via tty and run startx -- :2

Note caps between x -- and -- :
Thanks.

When I did that my system loaded Cinnamon. So if that means LightDM is not the issue, then where should I be looking for the issue?
Last edited by cb474 on Mon Sep 10, 2018 1:54 am, edited 2 times in total.

cb474
Level 3
Level 3
Posts: 125
Joined: Thu Dec 11, 2008 9:01 am

Re: Set Mate as default Desktop?

Post by cb474 » Mon Sep 10, 2018 1:53 am

gm10 wrote:
Thu Sep 06, 2018 3:05 am
Maybe a simple

Code: Select all

sudo dpkg-reconfigure lightdm
helps. And/or

Code: Select all

apt install --reinstall slick-greeter
sudo dpkg-reconfigure slick-greeter
But I'm throwing stuff at the wall now, hoping something will stick.
Thanks for the ideas. Sadly that did not fix it either.

User avatar
administrollaattori
Level 14
Level 14
Posts: 5311
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Set Mate as default Desktop?

Post by administrollaattori » Mon Sep 10, 2018 8:35 am

Code: Select all

sudo apt-get purge mate-desktop-environment mate-applets mate-system-monitor mate-utils 

apt install mate-desktop-environment mate-applets mate-system-monitor mate-utils 

sudo update-alternatives --config x-session-manager

cb474
Level 3
Level 3
Posts: 125
Joined: Thu Dec 11, 2008 9:01 am

Re: Set Mate as default Desktop?

Post by cb474 » Sun Sep 16, 2018 3:58 am

Thanks. Still the same result. Mate is labeled as the default in the drop down menu in LightDM. But it in fact defaults to Cinnamon.

User avatar
administrollaattori
Level 14
Level 14
Posts: 5311
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Set Mate as default Desktop?

Post by administrollaattori » Sun Sep 16, 2018 11:28 am

cb474 wrote:
Sun Sep 16, 2018 3:58 am
Thanks. Still the same result. Mate is labeled as the default in the drop down menu in LightDM. But it in fact defaults to Cinnamon.
How about if you start mate-session via tty? Press Ctrl Alt F2, login and run

Code: Select all

startx mate-session -- :2
You get back pressing Ctrl Alt F8 or Ctrl Alt F7

Post Reply

Return to “Software & Applications”