[Solved] Video is [not] less fluid in LMDE3 than in LMDE2

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Pio2001
Level 1
Level 1
Posts: 12
Joined: Sun Aug 30, 2015 1:16 pm

[Solved] Video is [not] less fluid in LMDE3 than in LMDE2

Post by Pio2001 » Sun Sep 16, 2018 12:19 pm

Hi,
I have just upgraded LMDE2 to LMDE3 thanks to the tutorial.

Several things improved, but here is something that worked better in LMDE2 : full screen videos or games (youtube, VLC, emulator in dosbox...) are juddering in LDME3 while they were fluid under LMDE2.

Hardware :
Laptop MSI
Intel Core i7-4710HQ CPU @ 2.50GHz × 4
RAM 8GB
Intel Corporation 4th Gen Core Processor Integrated Graphics Controller
Default Mint display driver

Configuration :
HDMI output, 1920x1080 (60 Hz, full chroma, PC scale, progressive scan).
Laptop display OFF

The symptom :
Full screen animations are not fluid. Visually, one frame is missing about every second. Sometimes the video is fluid for 5 seconds. Sometimes it freezes completely for a fraction of a second.
I've seen it in
-Firefox playing full screen Youtube videos
-XPlayer playing video files in full screen
-Dosbox running an old game in Mame emulator

Tests:
Reducing the size of the video window in Youtube improves the fluidity, but occasional freezes still occur. Reducing further the size of the window in XPlayer, playing a 720p video file, makes juddering disappear, but the picture still freezes for a very short time (roughly 200 ms, I'd say) from time to time.

Setting "Deasctiver la composition pour les fenêtres en plein écran" (disable composition for full-screen windows) in Preferences / general seemed to help a bit during some tests. Today it doesn't sem to have any effect, even after Forefox restarting.

Turning off hardware acceleration in Firefox doesn't help.

I wanted to install the nvidia drivers, since the laptop also has a Geforce GTX 860M, but Linux doesn't boot after the installation of the nvidia drivers, in spite of the various workarounds that I tried in the rc.local and the nvidia-common-kernel.conf files, as advised in the Debian wiki. So I reverted to the standard drivers on the Intel Graphics Controller.

I've pasted a long text in gedit, went to the end of the text a pressed down the left arrow of my keyboard.
The cursor runs smoothly from right to left. No judder. But from time to time (every 10 seconds or so) I can see the same short freeze as in the videos.

It seems that the solution would be to switch to the nvidia controller. But this is another story...
Last edited by Pio2001 on Sun Sep 16, 2018 2:51 pm, edited 2 times in total.

User avatar
tdockery97
Level 14
Level 14
Posts: 5058
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon
Contact:

Re: Video is less fluid in LMDE3 than in LMDE2

Post by tdockery97 » Sun Sep 16, 2018 12:35 pm

Hello Pio2001. You say that you upgraded to LMDE 3 from LMDE 2. If you are saying you did an in-place upgrade rather than a new install, I suspect some of your problem could lie there. I have almost exactly the same computer specs as yours and watching Youtube videos or video files in VLC is always smooth and flawless. My LMDE 3 is a fresh install. You may have to try that to make sure there are no lingering bits from LMDE 2 that are causing problems.
Mint 19.1 MATE

Pio2001
Level 1
Level 1
Posts: 12
Joined: Sun Aug 30, 2015 1:16 pm

Re: Video is less fluid in LMDE3 than in LMDE2

Post by Pio2001 » Sun Sep 16, 2018 1:28 pm

Thank you for the quick answer.

First, I think that I've got two completely different problems in one :
-the "judder", that drops some frames here and there and depends on the size of the video window, and doesn't affect the cursor of the text editor.
-the "freeze", that occurs only every 15 seconds or so, including on the cursor of a text editor.

I tested the same thing with a live session of LMDE3, booting on a live USB device.
-the freeze is not present
-the judder is present
But without the freeze, the judder looks weak, and the difference with LMDE2 is negligible, as far as I remember how it was. For example I know that LMDE2 was already unable, on my hardware, to display properly a video in a 3840 x 2160 desktop. 1920 x 1080 was borderline. So I don't think that the judder is an issue.
What changed is the new appearance of these freezes.

I see that some options are different between the live session and the regular session, and that some options might have been reset by the upgrade (I'm pretty sure that the touchpad was disabled before the upgrade).
I'm going to look at the Mint preferences and see if something is causing this. I'll post the result here.

axisofevil
Level 2
Level 2
Posts: 85
Joined: Mon Nov 14, 2011 12:22 pm

Re: Video is less fluid in LMDE3 than in LMDE2

Post by axisofevil » Sun Sep 16, 2018 1:43 pm

Have you installed the mint-meta-codecs package?

Pio2001
Level 1
Level 1
Posts: 12
Joined: Sun Aug 30, 2015 1:16 pm

Re: Video is less fluid in LMDE3 than in LMDE2

Post by Pio2001 » Sun Sep 16, 2018 1:45 pm

I did not install it myself (or it was years ago), but I see in the software manager that it is currently installed.

Pio2001
Level 1
Level 1
Posts: 12
Joined: Sun Aug 30, 2015 1:16 pm

Re: Video is less fluid in LMDE3 than in LMDE2

Post by Pio2001 » Sun Sep 16, 2018 1:54 pm

New observation : the freeze occurs every 30 seconds exactly.

User avatar
MrEen
Level 7
Level 7
Posts: 1964
Joined: Mon Jun 12, 2017 8:39 pm

Re: Video is less fluid in LMDE3 than in LMDE2

Post by MrEen » Sun Sep 16, 2018 2:09 pm

I know that over on the Ubuntu side of Mint, regular freezes like that have been caused by applets/desktop extensions. An as yet unresolved example here: viewtopic.php?f=208&t=276690&p=1519966& ... t#p1519933 (see Midnighter's reply.)

No idea if that would apply here.

Good luck.

Pio2001
Level 1
Level 1
Posts: 12
Joined: Sun Aug 30, 2015 1:16 pm

Re: Video is less fluid in LMDE3 than in LMDE2

Post by Pio2001 » Sun Sep 16, 2018 2:49 pm

Solved !

The culprit was the Intel SpeedStep setting in the setup of the motherboard, that was enabled instead of disabled.

Of course it has nothing to do with the LMDE upgrade. It just turns out that it's been a while that my laptop has got no more battery inside, and the little permanent battery of the mobo died two days before I started the Mint upgrade ! Causing the motherboard to loose all its setup every time the laptop is disconnected from the mains.
I didn't play any video during these two days and only saw the problem once Mint was upgraded !

Besides, judder in Youtube videos is a bit more visible in LMDE3 because in LMDE2, it was concealed by the constant tearing of the picture. In LMDE3, Youtube videos has no more tearing at all, just a bit of micro-judder, which is a progress :idea: :wink:

Thanks to the people who have answered and gave me the idea to try a live session (thus separating the judder problem from the freezing problem), and who posted a link speaking about a "CPU monitor" applet (which made me think about a possible motherboard setting that would have been lost).

Post Reply

Return to “Software & Applications”