Page 1 of 1

Video glitch every 30 seconds on HDMI output

Posted: Sun Sep 16, 2018 12:19 pm
by Pio2001
I have just upgraded LMDE2 to LMDE3 thanks to the tutorial.

Several things improved, but here is something that worked better in LMDE2 : full screen videos or games (youtube, VLC, emulator in dosbox...) are juddering in LDME3 while they were fluid under LMDE2.

Hardware :
Laptop MSI
Intel Core i7-4710HQ CPU @ 2.50GHz × 4
Intel Corporation 4th Gen Core Processor Integrated Graphics Controller
Default Mint display driver

Configuration :
HDMI output, 1920x1080 (60 Hz, full chroma, PC scale, progressive scan).
Laptop display OFF

The symptom :
Full screen animations are not fluid. Visually, one frame is missing about every second. Sometimes the video is fluid for 5 seconds. Sometimes it freezes completely for a fraction of a second.
I've seen it in
-Firefox playing full screen Youtube videos
-XPlayer playing video files in full screen
-Dosbox running an old game in Mame emulator

Reducing the size of the video window in Youtube improves the fluidity, but occasional freezes still occur. Reducing further the size of the window in XPlayer, playing a 720p video file, makes juddering disappear, but the picture still freezes for a very short time (roughly 200 ms, I'd say) from time to time.

Setting "Deasctiver la composition pour les fenêtres en plein écran" (disable composition for full-screen windows) in Preferences / general seemed to help a bit during some tests. Today it doesn't sem to have any effect, even after Forefox restarting.

Turning off hardware acceleration in Firefox doesn't help.

I wanted to install the nvidia drivers, since the laptop also has a Geforce GTX 860M, but Linux doesn't boot after the installation of the nvidia drivers, in spite of the various workarounds that I tried in the rc.local and the nvidia-common-kernel.conf files, as advised in the Debian wiki. So I reverted to the standard drivers on the Intel Graphics Controller.

I've pasted a long text in gedit, went to the end of the text a pressed down the left arrow of my keyboard.
The cursor runs smoothly from right to left. No judder. But from time to time (every 10 seconds or so) I can see the same short freeze as in the videos.

It seems that the solution would be to switch to the nvidia controller. But this is another story...

Re: Video is less fluid in LMDE3 than in LMDE2

Posted: Sun Sep 16, 2018 12:35 pm
by tdockery97
Hello Pio2001. You say that you upgraded to LMDE 3 from LMDE 2. If you are saying you did an in-place upgrade rather than a new install, I suspect some of your problem could lie there. I have almost exactly the same computer specs as yours and watching Youtube videos or video files in VLC is always smooth and flawless. My LMDE 3 is a fresh install. You may have to try that to make sure there are no lingering bits from LMDE 2 that are causing problems.

Re: Video is less fluid in LMDE3 than in LMDE2

Posted: Sun Sep 16, 2018 1:28 pm
by Pio2001
Thank you for the quick answer.

First, I think that I've got two completely different problems in one :
-the "judder", that drops some frames here and there and depends on the size of the video window, and doesn't affect the cursor of the text editor.
-the "freeze", that occurs only every 15 seconds or so, including on the cursor of a text editor.

I tested the same thing with a live session of LMDE3, booting on a live USB device.
-the freeze is not present
-the judder is present
But without the freeze, the judder looks weak, and the difference with LMDE2 is negligible, as far as I remember how it was. For example I know that LMDE2 was already unable, on my hardware, to display properly a video in a 3840 x 2160 desktop. 1920 x 1080 was borderline. So I don't think that the judder is an issue.
What changed is the new appearance of these freezes.

I see that some options are different between the live session and the regular session, and that some options might have been reset by the upgrade (I'm pretty sure that the touchpad was disabled before the upgrade).
I'm going to look at the Mint preferences and see if something is causing this. I'll post the result here.

Re: Video is less fluid in LMDE3 than in LMDE2

Posted: Sun Sep 16, 2018 1:43 pm
by axisofevil
Have you installed the mint-meta-codecs package?

Re: Video is less fluid in LMDE3 than in LMDE2

Posted: Sun Sep 16, 2018 1:45 pm
by Pio2001
I did not install it myself (or it was years ago), but I see in the software manager that it is currently installed.

Re: Video is less fluid in LMDE3 than in LMDE2

Posted: Sun Sep 16, 2018 1:54 pm
by Pio2001
New observation : the freeze occurs every 30 seconds exactly.

Re: Video is less fluid in LMDE3 than in LMDE2

Posted: Sun Sep 16, 2018 2:09 pm
by MrEen
I know that over on the Ubuntu side of Mint, regular freezes like that have been caused by applets/desktop extensions. An as yet unresolved example here: viewtopic.php?f=208&t=276690&p=1519966& ... t#p1519933 (see Midnighter's reply.)

No idea if that would apply here.

Good luck.

Re: Video is less fluid in LMDE3 than in LMDE2

Posted: Sun Sep 16, 2018 2:49 pm
by Pio2001
Solved !

The culprit was the Intel SpeedStep setting in the setup of the motherboard, that was enabled instead of disabled.

Of course it has nothing to do with the LMDE upgrade. It just turns out that it's been a while that my laptop has got no more battery inside, and the little permanent battery of the mobo died two days before I started the Mint upgrade ! Causing the motherboard to loose all its setup every time the laptop is disconnected from the mains.
I didn't play any video during these two days and only saw the problem once Mint was upgraded !

Besides, judder in Youtube videos is a bit more visible in LMDE3 because in LMDE2, it was concealed by the constant tearing of the picture. In LMDE3, Youtube videos has no more tearing at all, just a bit of micro-judder, which is a progress :idea: :wink:

Thanks to the people who have answered and gave me the idea to try a live session (thus separating the judder problem from the freezing problem), and who posted a link speaking about a "CPU monitor" applet (which made me think about a possible motherboard setting that would have been lost).

Re: Video glitch every 30 seconds

Posted: Thu Jan 24, 2019 6:19 pm
by Pio2001
Hi there.
In case the information could help anyone,

I was too optimistic in the message above. The picture glitch is still there. It disappeared not because the setting was updated, but because the the computer was restarted (or because the laptop screen was open, both make the glitch disappear).

Now, here is the situation :

Every day, after turning on the computer, when I go to Youtube to watch videos, the picture freezes for a quarter of a second every 30 seconds exactly.
It affects the whole display, not just Youtube or Firefox. I checked right now in gedit, keping my finger on a key of the keyboard. At 22:47:45, the scrolling of the characters froze for a short time. At 22:48:15 (30 seconds later), it froze again.

If I log off and log on the Cinnamon session, the problem disappears... until the next day, after the computer is shut off and turned on again.

Now I have found something new : it only happens on the external monitor through the HDMI output. It doesn't happen on the laptop screen itself.

And here's another very interesting info : it also disappears on the external monitor as long as the laptop screen is open. It reappears as soon as the laptop screen is closed on its keybord. Even when the laptop display is disabled !

Which leads to the workaround : leaving the laptop screen half open. The drawback : the laptop is a bit noisier than when it is completely closed.

This is not the only problem on the HDMI output : selecting 1920x1080 as desktop resolution gives an interlaced signal (1080i60 according to the monitor). If I switch to 1920x1200, accept the setting, then switch back to 1920x1080, the signal becomes progressive.
Then if I switch to 3840 x 2160, the signal is progressive. Then 1920x1080 -> interlaced. Then 1920x1200 -> progressive. Then 1920x1080 -> progressive.

But I don't think that these problems are related because the glitch appeared in LMDE3, while the interlaced scan problem has been present since LMDE1.

Code: Select all

System:    Host: msi Kernel: 4.9.0-8-amd64 x86_64 (64 bit gcc: 6.3.0)
           Desktop: Cinnamon 4.0.9 (Gtk 3.22.11-1) Distro: Linux Mint LMDE
Machine:   Device: desktop System: Micro-Star product: GS60 2PC Ghost v: REV:1.0
           Mobo: Micro-Star model: MS-16H2 v: REV:0.B
           BIOS: American Megatrends v: E16H2IMS.106 date: 05/13/2014
CPU:       Quad core Intel Core i7-4710HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19953
           clock speeds: max: 3500 MHz 1: 2587 MHz 2: 2500 MHz 3: 2662 MHz
           4: 2991 MHz 5: 2500 MHz 6: 3033 MHz 7: 3154 MHz 8: 2593 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Card-2: NVIDIA GK104M [GeForce GTX 860M] bus-ID: 01:00.0
           Display Server: X.Org 1.19.2 drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile
           GLX Version: 3.0 Mesa 13.0.6 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.9.0-8-amd64
Network:   Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx port: c000 bus-ID: 04:00.0
           IF: eth0 state: down mac: <filter>
           Card-2: Intel Wireless 7260 driver: iwlwifi bus-ID: 05:00.0
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 1128.2GB (44.8% used)
           ID-1: /dev/sda model: HFS128G38MNB size: 128.0GB
           ID-2: /dev/sdb model: HGST_HTS721010A9 size: 1000.2GB
Partition: ID-1: / size: 108G used: 27G (26%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 917G used: 436G (50%) fs: ext4 dev: /dev/sdb1
           ID-3: swap-1 size: 10.24GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 55.0C mobo: 27.8C gpu: 37.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 247 Uptime: 2:09 Memory: 2320.7/7907.6MB
           Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.121) inxi: 2.3.5 
Edit : the monitor is a Viewsonic VP3268 4K