[SOLVED] Brave Browser in LMDE 3

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Matanyah
Level 1
Level 1
Posts: 2
Joined: Mon Oct 29, 2018 4:22 am

[SOLVED] Brave Browser in LMDE 3

Post by Matanyah » Mon Oct 29, 2018 5:04 am

Is there a way to get the Brave Browser working in LMDE 3 without having to add --no sandbox?
Any help would be appreciated.
Last edited by Matanyah on Mon Oct 29, 2018 12:35 pm, edited 1 time in total.

User avatar
xenopeek
Level 24
Level 24
Posts: 23193
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Brave Browser in LMDE 3

Post by xenopeek » Mon Oct 29, 2018 8:40 am

Welcome to the Linux Mint forums.

From https://github.com/brave/browser-laptop/issues/7508 we learn they support Debian stretch (the package base for LMDE 3) but indeed they don't have instructions for Debian in their documentation https://brave-browser.readthedocs.io/en ... html#linux.

Here is how to install Brave specifically on LMDE 3 or Debian stretch (same instructions):

Code: Select all

curl https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key add -
echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stretch main" | sudo tee -a /etc/apt/sources.list.d/brave-browser-release-stretch.list
sudo apt update
sudo apt install brave-browser
Run these four commands one by one from the terminal (see the terminal's Edit menu for pasting copied commands there). You will be prompted for your password. Just type it and press enter; the terminal doesn't give visual feedback when typing passwords.

Further, Brave requires support in the Linux kernel for unprivileged processes to use user namespaces. The Debian kernels disable this by default so Brave won't run. You can either tell Brave not to use its security sandbox by running it as brave-browser --no-sandbox (bad idea obviously) or you must fiddle a bit to enable unprivileged process user namespaces in the Debian kernel. For that run these commands (adapted from https://github.com/brave/browser-laptop/issues/6902):

Code: Select all

echo 'kernel.unprivileged_userns_clone=1' | sudo tee /etc/sysctl.d/00-local-userns.conf
sudo systemctl restart procps
After that Brave should run fine.

If you decide to delete Brave in the future you can undo the above with:

Code: Select all

sudo rm /etc/sysctl.d/00-local-userns.conf
sudo systemctl restart procps
And uninstall brave-browser as per usual and remove Brave from the Additional repositories and Authentication keys tabs in Software Sources program.
Image

Matanyah
Level 1
Level 1
Posts: 2
Joined: Mon Oct 29, 2018 4:22 am

Re: Brave Browser in LMDE 3

Post by Matanyah » Mon Oct 29, 2018 12:34 pm

Thank you - SOLVED! Brave working!

Post Reply

Return to “Software & Applications”