Mind Mapping Applications

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
WAS580
Level 1
Level 1
Posts: 3
Joined: Wed Jan 30, 2019 6:02 pm

Mind Mapping Applications

Post by WAS580 » Thu Jan 31, 2019 12:37 pm

I apologize in advance for the length of this post and for my ignorance.

I’ve used FreeMind on OS/2 and wanted to use it on Linux Mint. I successfully installed the 0.9.0 version on my old desktop running LMDE 2 MATE 32-Bit. The Java version installed on it is 1.7.0_181. (Because of the older, and apparently limited, hardware, I wasn’t able to install LMDE 3 32-Bit on it.)

I have LMDE 3 64-Bit installed on my T540p ThinkPad. The Java version installed on the ThinkPad is 1.8.0_201. Using the GDebi Package Installer, I’ve tried to install each of FreeMind versions 0.8.0-1, 0.8.1-2 and 0.9.0 on it, all w/out success.

Doing some research it seemed that FreePlane might be a good alternative since I better be able to exchange files between them. Using the Software Manager I tried to install FreePlane version 1.5.18, but it returned an error message that the package was broken. Thinking that perhaps uninstallation and reinstallation might do the trick, I RMB the icon, clicked uninstall and received the following message:
“The package system is broken

Check if you are using third party repositories. If so disable them, since they are a common source of problems.
Furthermore run the following command in a Terminal: apt-get install -f The package system is broken

Check if you are using third party repositories. If so disable them, since they are a common source of problems.
Furthermore run the following command in a Terminal: apt-get install -f

Details
The following packages have unmet dependencies:

freeplane: Depends: libcommons-lang-java (>= 2.6) but 2.6-6 is installed
Depends: libjgoodies-forms-java (>= 1.9.0) but it is not installed
Depends: libknopflerfish-osgi-framework-java (>= 5.1.0) but 5.2.0-2 is installed
Depends: libcommons-codec-java (>= 1.7) but 1.10-1 is installed
Depends: jmapviewer (>= 1.11) but 2.0+dfsg-2 is installed”

The 1st and 3rd through 5th lines are confusing since it seems I have at least the minimum versions required.

For curiosity I tried to install FreePlane 1.3.12 under LMDE 2 on the desktop and it installed w/out problem.

So, while both FreeMind and FreePlane work under LMDE 2, I have been unable to install either under LMDE 3. I did locate and download FreePlane versions 1.7.2 and 1.7.3 that are apparently Debian versions, but am a bit loath to try them considering the previous problem.

Research indicated that VYM might be a good alternative, and so I installed version 2.5.0 and it opens fine. It also recommended the <vym-2.6.0-0.x86_64.rpm> update but I haven’t played w/ it yet.

Any recommendations for LMDE 3 between FreeMind, FreePlane and VYM?

User avatar
ChrisMW
Level 1
Level 1
Posts: 37
Joined: Sun May 17, 2015 6:02 am

Re: Mind Mapping Applications

Post by ChrisMW » Mon Feb 18, 2019 10:39 am

Freemind works fine, I run 1.0.1 and OpenJDK 1.8. No problems. just go to their website, download the all binaries version (second from the bottom, 38Mb) and unpack it somewhere you prefer (let's say /home/<you>/FreeMind) and run the

Code: Select all

freemind.sh
you'll find in /home/<you>/FreeMind.

But Freeplane is also an option.

deepakdeshp
Level 15
Level 15
Posts: 5663
Joined: Sun Aug 09, 2015 10:00 am

Re: Mind Mapping Applications

Post by deepakdeshp » Mon Feb 18, 2019 3:08 pm

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Software & Applications”