Firefox DRM problem had and solved

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Tom-
Level 1
Level 1
Posts: 2
Joined: Tue Jan 08, 2019 1:38 pm

Firefox DRM problem had and solved

Post by Tom- » Mon Feb 04, 2019 7:51 am

This is for any LMDE 3 users out there who can't play Netflix or other Google Widevine CDM DRM-restricted content. Thanks to help on IRC I was able to make a temporary fix. He found the bug report https://bugs.debian.org/cgi-bin/bugrepo ... bug=921022 where the original submitter found that downgrading Firefox from 60.5esr to 60.4esr temporarily fixed the problem. You can head to http://ftp.mozilla.org/pub/firefox/releases/60.4.0esr/ and download either the linux-i686/ (32 bit) or linux-x86_64/ (64 bit) version in your language. Then you can decompress it in your home directory and cd into firefox/ and run ./firefox . That's what I'm doing now. I guess I'll check back later to see if it's fixed in Firefox.

So if you get the error message "Firefox is installing components needed to play the audio or video on this page. Please try again later." and you know the DRM plugin is already installed, and you keep getting the error message, maybe try downloading the slightly older version.

I tried the latest version of Firefox, 65.0, from http://www.getfirefox.com/ and I had the same problem, so I guess a downgrade is necessary at the time of this writing.

Thanks to orcus who found the Debian bug, gave me the Firefox download URL, and recommended to me that I make this post to help others or get more info.

snowmusicman
Level 1
Level 1
Posts: 1
Joined: Thu Jan 17, 2019 1:46 pm

Re: Firefox DRM problem had and solved

Post by snowmusicman » Sat Feb 09, 2019 12:38 pm

Thank you, I should have come here first instead of losing a few hours trying to solve the issue reinstalling, searching, etc. Your solution works for me where nothing else on the net did.

Tom-
Level 1
Level 1
Posts: 2
Joined: Tue Jan 08, 2019 1:38 pm

Re: Firefox DRM problem had and solved

Post by Tom- » Thu Feb 21, 2019 10:52 pm

snowmusicman wrote:
Sat Feb 09, 2019 12:38 pm
Thank you, I should have come here first instead of losing a few hours trying to solve the issue reinstalling, searching, etc. Your solution works for me where nothing else on the net did.
Well, it's not my solution, orcus on #linuxmint-help found the Debian bug report for me. But thanks for letting me know that my post helped a person!

For snowmusicman and everyone else, I think I have since upgraded to Firefox 60.5esr, the one that comes with LMDE 3, and Netflix and CTV.ca are working again. I guess we can all go about our business again.

Post Reply

Return to “Software & Applications”