Need Terminal to initially set at Zoom In

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
AZgl1500
Level 13
Level 13
Posts: 4821
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Need Terminal to initially set at Zoom In

Post by AZgl1500 »

I have a 17 inch screen on my laptop, with Hi-Def resolution.

when I start Terminal, the fonts are so small that I can barely see them.
I have already increased the font size as far as it can go w/o forcing the lines to go past the right edge of the screen.

I have looked in Preferences, and there isn't any mention of "Startup at Zoom level x "

Anyone know a way to open at Zoom In once?

Zoon.png
Linux Mint 19.3 Cinnamon

User avatar
smurphos
Level 17
Level 17
Posts: 7056
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Need Terminal to initially set at Zoom In

Post by smurphos »

You should be able to adapt this answer to gnome-terminal.

viewtopic.php?p=1795790#p1795790
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
AZgl1500
Level 13
Level 13
Posts: 4821
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Need Terminal to initially set at Zoom In

Post by AZgl1500 »

smurphos wrote:
Sun Apr 19, 2020 8:13 am
You should be able to adapt this answer to gnome-terminal.

viewtopic.php?p=1795790#p1795790
Thanks for where to go, I tried both of these settings and both were ignored by Terminal

Code: Select all

#!/bin/sh
/usr/bin/gnome-terminal --zoom=1.5 --geometry=120x35+200+150

Code: Select all

#!/bin/sh
/usr/bin/gnome-terminal --zoom=2.0

bin.png
Linux Mint 19.3 Cinnamon

User avatar
smurphos
Level 17
Level 17
Posts: 7056
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Need Terminal to initially set at Zoom In

Post by smurphos »

Hi, to check what you have done please run the commands below and report the output.

Code: Select all

stat /usr/local/bin/gnome-terminal
&

Code: Select all

cat /usr/local/bin/gnome-terminal
From a working mod - note the Access permissions are (0755/-rwxr-xr-x)
Also note the extra parameter I've put in after some testing to make sure other arguments passed are used.

Code: Select all

steve@steve-Inspiron-5580:~$ stat /usr/local/bin/gnome-terminal
  File: /usr/local/bin/gnome-terminal
  Size: 45        	Blocks: 8          IO Block: 4096   regular file
Device: 10302h/66306d	Inode: 657080      Links: 1
Access: (0755/-rwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2020-04-20 07:42:24.446562452 +0100
Modify: 2020-04-20 07:42:24.330567390 +0100
Change: 2020-04-20 07:42:24.330567390 +0100
 Birth: -
steve@steve-Inspiron-5580:~$ cat /usr/local/bin/gnome-terminal
#!/bin/sh
/usr/bin/gnome-terminal --zoom=1.5 "$@"
Last edited by smurphos on Mon Apr 20, 2020 3:22 am, edited 1 time in total.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

JosephM
Level 6
Level 6
Posts: 1169
Joined: Sun May 26, 2013 6:25 pm

Re: Need Terminal to initially set at Zoom In

Post by JosephM »

Running

Code: Select all

gnome-terminal --zoom=2.0
works fine. But the screenshot you are showing is nemo-terminal. That is not the same as running the gnome-terminal application. So I'm not sure any of this is relevant if that is what you are trying to do.
When I give opinions, they are my own. Not necessarily those of any other Linux Mint developer or the Linux Mint project as a whole.

User avatar
AZgl1500
Level 13
Level 13
Posts: 4821
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Need Terminal to initially set at Zoom In

Post by AZgl1500 »

smurphos wrote:
Mon Apr 20, 2020 2:43 am
Hi, to check what you have done please run the commands below and report the output.

Code: Select all

stat /usr/local/bin/gnome-terminal
&

Code: Select all

cat /usr/local/bin/gnome-terminal
From a working mod - note the Access permissions are (0755/-rwxr-xr-x)
Also note the extra parameter I've put in after some testing to make sure other arguments passed are used.

Code: Select all

steve@steve-Inspiron-5580:~$ stat /usr/local/bin/gnome-terminal
  File: /usr/local/bin/gnome-terminal
  Size: 45        	Blocks: 8          IO Block: 4096   regular file
Device: 10302h/66306d	Inode: 657080      Links: 1
Access: (0755/-rwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2020-04-20 07:42:24.446562452 +0100
Modify: 2020-04-20 07:42:24.330567390 +0100
Change: 2020-04-20 07:42:24.330567390 +0100
 Birth: -
steve@steve-Inspiron-5580:~$ cat /usr/local/bin/gnome-terminal
#!/bin/sh
/usr/bin/gnome-terminal --zoom=1.5 "$@"

this is what I got:

Code: Select all

~$ stat /usr/local/bin/gnome-terminal
  File: /usr/local/bin/gnome-terminal
  Size: 45        	Blocks: 8          IO Block: 4096   regular file
Device: 802h/2050d	Inode: 797714      Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2020-04-19 07:57:32.872301881 -0500
Modify: 2020-04-19 07:54:07.566952052 -0500
Change: 2020-04-19 07:54:07.570951993 -0500
 Birth: -

And, I am using Terminal from the Panel, and I always Zoom In once before I use it.

Code: Select all

$ cat /usr/local/bin/gnome-terminal
#!/bin/sh
/usr/bin/gnome-terminal --zoom=2.0
-------------------
From your next post:
Running

Code: Select all

gnome-terminal --zoom=2.0
works fine. But the screenshot you are showing is nemo-terminal. That is not the same as running the gnome-terminal application. So I'm not sure any of this is relevant if that is what you are trying to do.
=====================

It is the same Terminal app that I get if I use Control-Alt-T


I am not a coder/programmer.... I keep a lot of notes and refer back to previous " lessons learned "
Linux Mint 19.3 Cinnamon

User avatar
smurphos
Level 17
Level 17
Posts: 7056
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Need Terminal to initially set at Zoom In

Post by smurphos »

AZgl1500 wrote:
Mon Apr 20, 2020 4:34 am

Code: Select all

Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
You need to make the file executable.

To fix via terminal

Code: Select all

sudo chmod 755 /usr/local/bin/gnome-terminal
Also do revise the command in the script from

Code: Select all

#!/bin/sh
/usr/bin/gnome-terminal --zoom=2.0
to

Code: Select all

#!/bin/sh
/usr/bin/gnome-terminal --zoom=2.0 "$@"
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

Post Reply

Return to “Software & Applications”