How to get Firefox (non ESR) on LMDE4?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
FabriciusFab
Level 1
Level 1
Posts: 7
Joined: Sun Aug 26, 2018 10:28 pm

How to get Firefox (non ESR) on LMDE4?

Post by FabriciusFab »

Hi everyone, I just switched from LM 19.3 to LMDE4. I can see there's a lot of things that changed from having an Ubuntu base to a Debian base system.

My one question right now would be on how to properly get Firefox non ESR via the command line.

I've added the testing and unstable repositories of Debian to my /etc/apt/sources.list but when I execute

Code: Select all

sudo apt install -t unstable firefox
I'm met with

Code: Select all

The following packages have unmet dependencies:
 libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Any way to solve this? Thanks!

axisofevil
Level 3
Level 3
Posts: 154
Joined: Mon Nov 14, 2011 12:22 pm

Re: How to get Firefox (non ESR) on LMDE4?

Post by axisofevil »

If you add the unstable repository - you must expect LMDE to become ............ unstable!

You will get the non-ESR firefox in a few months time anyway (unless it gets horribly broken) as an update on the ESR line, if you just stick with the stable repositories - isn't that why you chose LMDE?

FabriciusFab
Level 1
Level 1
Posts: 7
Joined: Sun Aug 26, 2018 10:28 pm

Re: How to get Firefox (non ESR) on LMDE4?

Post by FabriciusFab »

axisofevil wrote:
Thu May 28, 2020 4:28 pm
If you add the unstable repository - you must expect LMDE to become ............ unstable!

You will get the non-ESR firefox in a few months time anyway (unless it gets horribly broken) as an update on the ESR line, if you just stick with the stable repositories - isn't that why you chose LMDE?
Actually no, I chose LMDE cause regular Linux Mint was being too heavy for my 12 year old laptop so I thought that if I stripped away the Ubuntu base it would perform somewhat better.
It's strange, cause last time it ran Windows 10 it had no problem whatsoever but with Mint both regular and LMDE everytime I play video I get horrible framerates, video gets choppy, sometime it freezes, etc.
I guess it may be just the Linux Mint base or the Cinnamon desktop, or the Muffin window manager, cause LMDE did not solve the issue.
That's why I'd chose it

axisofevil
Level 3
Level 3
Posts: 154
Joined: Mon Nov 14, 2011 12:22 pm

Re: How to get Firefox (non ESR) on LMDE4?

Post by axisofevil »

On a 12 year old laptop you probably need a lightweight distro - such as AntiX.
A lightweight browser might be necessary too!

Post Reply

Return to “Software & Applications”