LMDE 4 E: Sub-process /usr/bin/dpkg returned an error code (2)

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
MatzeKS
Level 1
Level 1
Posts: 2
Joined: Thu Jun 18, 2020 2:01 am

LMDE 4 E: Sub-process /usr/bin/dpkg returned an error code (2)

Post by MatzeKS »

Hello Forum,

investigating that issue does not gave helpful hints via Google & Co. - therefor I'll try to get that issue fixed with your help.

Starting the command "sudo apt-get upgrade" returned in error message:

E: Sub-process /usr/bin/dpkg returned an error code (2)

Here are hopefully all of requested information's:

Code: Select all

user0001@lm20-vm-01:~$ sudo LC_ALL=C apt-get upgrade
[sudo] Passwort für user0001:         
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  libvlc-bin libvlc5 libvlccore9 vlc vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba
  vlc-plugin-skins2 vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization
15 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/12.9 MB of archives.
After this operation, 29.7 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
dpkg: unrecoverable fatal error, aborting:
 files list file for package 'traceroute' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)

Code: Select all

root@lm20-vm-01:~# inxi -Fxxxrz
System:    Host: lm20-vm-01 Kernel: 4.19.0-9-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0 Console: tty 0 dm: LightDM 1.26.0 
           Distro: LMDE 4 Debbie base: Debian 10.2 buster 
Machine:   Type: Vmware System: VMware product: VMware Virtual Platform v: N/A serial: <filter> Chassis: No Enclosure type: 1 
           serial: N/A 
           Mobo: Intel model: 440BX Desktop Reference Platform serial: N/A BIOS: Phoenix v: 6.00 date: 02/27/2020 
CPU:       Topology: 2x Dual Core model: Intel Core i7-9850H bits: 64 type: SMP arch: Kaby Lake rev: D L1 cache: 2048 KiB 
           L2 cache: 24.0 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 20736 
           Speed: 2592 MHz min/max: N/A Core speeds (MHz): 1: 2592 2: 2592 3: 2592 4: 2592 
Graphics:  Device-1: VMware SVGA II Adapter driver: vmwgfx v: 2.15.0.0 bus ID: 00:0f.0 chip ID: 15ad:0405 
           Display: server: X.org 1.20.4 driver: vmware unloaded: fbdev,modesetting,vesa tty: 130x33 
           Message: Advanced graphics data unavailable in console for root. 
Audio:     Device-1: Ensoniq ES1371/ES1373 / Creative Labs CT2518 driver: snd_ens1371 v: kernel bus ID: 02:02.0 
           chip ID: 1274:1371 
           Sound Server: ALSA v: k4.19.0-9-amd64 
Network:   Device-1: Intel 82371AB/EB/MB PIIX4 ACPI vendor: VMware Virtual Machine type: network bridge driver: N/A port: 1060 
           bus ID: 00:07.3 chip ID: 8086:7113 
           Device-2: Intel 82545EM Gigabit Ethernet vendor: VMware PRO/1000 MT Single Port driver: e1000 v: 7.3.21-k8-NAPI 
           port: 2000 bus ID: 02:01.0 chip ID: 8086:100f 
           IF: ens33 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-3: Intel 82545EM Gigabit Ethernet vendor: VMware PRO/1000 MT Single Port driver: e1000 v: 7.3.21-k8-NAPI 
           port: 2080 bus ID: 02:05.0 chip ID: 8086:100f 
           IF: ens37 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-4: Intel 82545EM Gigabit Ethernet vendor: VMware PRO/1000 MT Single Port driver: e1000 v: 7.3.21-k8-NAPI 
           port: 20c0 bus ID: 02:06.0 chip ID: 8086:100f 
           IF: ens38 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 20.00 GiB used: 14.73 GiB (73.7%) 
           ID-1: /dev/sda vendor: VMware model: Virtual S size: 20.00 GiB serial: N/A rev: 1.0 scheme: MBR 
Partition: ID-1: / size: 15.68 GiB used: 7.37 GiB (47.0%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda1 
Sensors:   Message: No sensors data was found. Is sensors configured? 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http://ftp.fau.de/mint/packages debbie main upstream import backport
           2: deb http://debian.intergenia.de/debian/ buster main contrib non-free
           3: deb http://debian.intergenia.de/debian/ buster-updates main contrib non-free
           4: deb http://security.debian.org/ buster/updates main contrib non-free
           5: deb http://debian.intergenia.de/debian/ buster-backports main contrib non-free
Info:      Processes: 220 Uptime: 25m Memory: 3.83 GiB used: 1.48 GiB (38.7%) Init: systemd v: 241 runlevel: 5 Compilers: 
           gcc: 8.3.0 alt: 8 Shell: bash v: 5.0.3 running in: tty 0 inxi: 3.0.32 
Any help is really appreciated.

Thanx - Matthias
Last edited by xenopeek on Thu Jun 18, 2020 2:18 am, edited 1 time in total.
Reason: moved to LMDE forums
sleeper12
Level 11
Level 11
Posts: 3625
Joined: Thu May 25, 2017 3:22 pm

Re: LMDE 4 E: Sub-process /usr/bin/dpkg returned an error code (2)

Post by sleeper12 »

I'm not sure, but try:

Code: Select all

 sudo rm /var/lib/dpkg/info/traceroute 

Code: Select all

 sudo apt install traceroute --reinstall 
MatzeKS
Level 1
Level 1
Posts: 2
Joined: Thu Jun 18, 2020 2:01 am

Re: LMDE 4 E: Sub-process /usr/bin/dpkg returned an error code (2)

Post by MatzeKS »

I checked the related path "/var/lib/dpkg/info/" for any parts of traceroute

Code: Select all

ls -al /var/lib/dpkg/info/traceroute*

-rw-r--r-- 1 root root     787 Jun 15 11:14 traceroute.list
-rw-r--r-- 1 root root     874 Aug 29  2016 traceroute.md5sums
-rwxr-xr-x 1 root root    1073 Aug 29  2016 traceroute.postinst
-rwxr-xr-x 1 root root     511 Aug 29  2016 traceroute.prerm
I removed all parts of "traceroute" in that path and then I was able to "purge" the traceroute package.

After that all works as expected.

Thanx 4 ur help - Matthias


== SOLVED ==
Post Reply

Return to “Software & Applications”