[Solved] MATE instead of Cinnamon in LMDE4

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Sydney
Level 3
Level 3
Posts: 105
Joined: Mon Oct 28, 2013 8:31 am

[Solved] MATE instead of Cinnamon in LMDE4

Post by Sydney »

Clean install of LMDE4. Unable to boot into Mate.

I found another post that explains that in order to boot into Mate as the default desktop environment, one has to do the following:
1) To install Mate:

Code: Select all

sudo apt install mate-desktop-environment -y
2) To purge Cinnamon:

Code: Select all

sudo apt autoremove --purge cinnamon nemo cinnamon-screensaver cinnamon-control-center -y

1) is no problem, but after 2) I can't boot but get the following message:
Xsession: unable to lauch "cinnamon-session-cinnamon" X session --- "cinnamon-session-cinnamon" not found; falling back to default session
But nothing happens and the "okay" button does not work.
Removing Cinnamon-session in the software manager has the same effect.

When I start over, keep Cinnamon, do

Code: Select all

sudo update-alternatives --config x-session-manager
and chose "mate session in manual mode"
nothing happens, I just keep booting into Cinnamon.
I don't have a login screen as I login automatically. And I tried installing GDM3 which did not help either.
I check my desktop environment by typing:

Code: Select all

$DESKTOP-SESSION
How can I get Debbie to use Mate, please ? Thank you.
Last edited by Sydney on Sat Aug 29, 2020 11:39 am, edited 2 times in total.
User avatar
cpedretti
Level 2
Level 2
Posts: 89
Joined: Tue Mar 10, 2020 12:06 am

Re: MATE instead of Cinnamon in LMDE4

Post by cpedretti »

Hi, boot on rescue mode and enter this:

Code: Select all

sudo nano ~/.dmrc

Code: Select all

[Desktop]
Session=mate
Hope this resolve your issue.
AMD Ryzen 7 3700X - 32GB DDR4 - Sapphire RX570 8GB - SSD SAMSUNG EVO 860/HDD Toshiba - Mobo Gygabyte AORUS ELITE B450 - PSU Gigabyte 750W Gold - Case Zalman X3 White

LMDE4 Kernel 5.9
Sydney
Level 3
Level 3
Posts: 105
Joined: Mon Oct 28, 2013 8:31 am

Re: MATE instead of Cinnamon in LMDE4

Post by Sydney »

Thank you, yes it did, it just needed some fiddling. I think this had to do with my login-settings, but my .dmrc file was not executable and I was unable to change it. So I had to - very unelegantly - create it manually, make it executable, then purge Cinnamon, and then restart. Which did the trick.

I also subsequently deleted cinnamon-session and cinnamon-settings via software manager but was surprised to see that I was still getting Cinnamon-updates from the LMDE repo.

Just in case someone else is trying to replace Cinnamon with Mate and is unsure if it successful and wonders what desktop they are currently running: hover your mouse over the terminal-icon. Cinnamon will come up with "terminal", wheras Mate will say "Mate terminal".
Post Reply

Return to “Software & Applications”