whatsapp-desktop - why the Linux Mint package isn't in LMDE?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Mia
Level 1
Level 1
Posts: 48
Joined: Tue Feb 06, 2018 10:53 am
Location: Ukraine

whatsapp-desktop - why the Linux Mint package isn't in LMDE?

Post by Mia »

Linux Mint has an unofficial Whatsapp client - the whatsapp-desktop package. I've installed this package to LMDE - and it works perfectly, with all its dependencies installed from LMDE. So, why the LMDE repo doesn't have it?
User avatar
Kadaitcha Man
Level 11
Level 11
Posts: 3605
Joined: Mon Aug 27, 2012 10:17 pm

Re: whatsapp-desktop - why the Linux Mint package isn't in LMDE?

Post by Kadaitcha Man »

Mia wrote:
Thu Oct 15, 2020 6:03 am
So, why the LMDE repo doesn't have it?
Probably because there's no need for it. The unofficial client is available as a snap in Debian.

Edit: Or because the authors haven't asked for it to be included in the Debian repos.
Coming to a thread near you: Lots of bragging about my AMD 5950X. Currently delayed due to high demand.
It's pronounced kad-eye-cha, not kada-itcha.
User avatar
Mia
Level 1
Level 1
Posts: 48
Joined: Tue Feb 06, 2018 10:53 am
Location: Ukraine

Re: whatsapp-desktop - why the Linux Mint package isn't in LMDE?

Post by Mia »

But I'm asking about LMDE - not about Debian. This package is in Mint repo - not in Ubuntu. And not only in the last version - but starting from Sylvia. So I'm curious - why to add it to Mint, but not to LMDE, if the same package perfectly fits both?
jwiz
Level 3
Level 3
Posts: 151
Joined: Tue Dec 20, 2016 6:59 am

Re: whatsapp-desktop - why the Linux Mint package isn't in LMDE?

Post by jwiz »

Mainly because LMDE is Debian based and Debian adheres to the free software principle and avoids to package unsavoury pieces of junk software such as Whatsapp, Twitter, Facebook, Instagram et al.
But feel free to create your own FrankenDebian, if you intend to do so, but what's the point?
You might just as well run Windows or MacOs.
User avatar
Mia
Level 1
Level 1
Posts: 48
Joined: Tue Feb 06, 2018 10:53 am
Location: Ukraine

Re: whatsapp-desktop - why the Linux Mint package isn't in LMDE?

Post by Mia »

jwiz wrote:
Thu Oct 15, 2020 6:53 am
Mainly because LMDE is Debian based and Debian adheres to the free software principle and avoids to package unsavoury pieces of junk software such as Whatsapp, Twitter, Facebook, Instagram et al.
Sounds reasonable. For example, now I see that LMDE doesn't have the Skype client available, but Mint does. So with the Whatsapp, it's the same. Now I've got it.

Your sarcasm about "Windows or MacOs" is irrelevant. I might as well run Linux Mint. )
User avatar
Mia
Level 1
Level 1
Posts: 48
Joined: Tue Feb 06, 2018 10:53 am
Location: Ukraine

Re: whatsapp-desktop - why the Linux Mint package isn't in LMDE?

Post by Mia »

Ok, more seriously. I understand now LMDE is closer to Debian's policy about FOSS than to Linux Mint's. But for real FOSS purist, it's still not good enough. For example, it automatically adds contrib and non-free sections, while original Debian doesn't (as far as I remember). Even more - it proposes to auto-install non-free codecs. And I don't see why using non-free codecs is better than non-free user software. Quite the opposite - in the latter case, I can run non-free software from a separate user with minimal rights, or even in chroot. With codecs, plugins, or drivers, it would be at least more difficult.

Hope you understand me. I try to use free software when it's possible. But sometimes it's not. In the country where I live now, Whatsapp is used by everyone for everything. Job seeking, apt rent, even a salesman in the nearest food shop needed my Whatsapp contact to let me know when my order would be delivered to him.
Last edited by Mia on Thu Oct 15, 2020 6:55 pm, edited 1 time in total.
User avatar
Kadaitcha Man
Level 11
Level 11
Posts: 3605
Joined: Mon Aug 27, 2012 10:17 pm

Re: whatsapp-desktop - why the Linux Mint package isn't in LMDE?

Post by Kadaitcha Man »

Mia wrote:
Thu Oct 15, 2020 6:14 am
But I'm asking about LMDE - not about Debian. This package is in Mint repo - not in Ubuntu. And not only in the last version - but starting from Sylvia. So I'm curious - why to add it to Mint, but not to LMDE, if the same package perfectly fits both?
The Mint repository is for Mint software only.
Coming to a thread near you: Lots of bragging about my AMD 5950X. Currently delayed due to high demand.
It's pronounced kad-eye-cha, not kada-itcha.
User avatar
MrEen
Level 22
Level 22
Posts: 15285
Joined: Mon Jun 12, 2017 8:39 pm

Re: whatsapp-desktop - why the Linux Mint package isn't in LMDE?

Post by MrEen »

Kadaitcha Man wrote:
Thu Oct 15, 2020 5:29 pm
Mia wrote:
Thu Oct 15, 2020 6:14 am
But I'm asking about LMDE - not about Debian. This package is in Mint repo - not in Ubuntu. And not only in the last version - but starting from Sylvia. So I'm curious - why to add it to Mint, but not to LMDE, if the same package perfectly fits both?
The Mint repository is for Mint software only.
With some exceptions:

Code: Select all

scott@scott-HP ~ $ apt policy whatsapp-desktop
whatsapp-desktop:
  Installed: (none)
  Candidate: 0.6.1
  Version table:
     0.6.1 500
        500 http://mirror.jmu.edu/pub/linuxmint/packages sylvia/import amd64 Packages
scott@scott-HP ~ $ 
When 19.3 brought the new Xfce, all of that was via Mint's repo as well. I don't have a 20 install to see if that's still the case.
User avatar
Kadaitcha Man
Level 11
Level 11
Posts: 3605
Joined: Mon Aug 27, 2012 10:17 pm

Re: whatsapp-desktop - why the Linux Mint package isn't in LMDE?

Post by Kadaitcha Man »

MrEen wrote:
Thu Oct 15, 2020 5:35 pm
Kadaitcha Man wrote:
Thu Oct 15, 2020 5:29 pm
Mia wrote:
Thu Oct 15, 2020 6:14 am
But I'm asking about LMDE - not about Debian. This package is in Mint repo - not in Ubuntu. And not only in the last version - but starting from Sylvia. So I'm curious - why to add it to Mint, but not to LMDE, if the same package perfectly fits both?
The Mint repository is for Mint software only.
With some exceptions:
lol - ok, thanks.
Coming to a thread near you: Lots of bragging about my AMD 5950X. Currently delayed due to high demand.
It's pronounced kad-eye-cha, not kada-itcha.
User avatar
Mia
Level 1
Level 1
Posts: 48
Joined: Tue Feb 06, 2018 10:53 am
Location: Ukraine

Re: whatsapp-desktop - why the Linux Mint package isn't in LMDE?

Post by Mia »

MrEen wrote:
Thu Oct 15, 2020 5:35 pm
I don't have a 20 install to see if that's still the case.
It's there for all versions 18.3-20.1:
http://packages.linuxmint.com/search.ph ... d=whatsapp
Post Reply

Return to “Software & Applications”