Installed Joplin on LMDE4 - will not start

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
LarsG
Level 1
Level 1
Posts: 25
Joined: Wed Sep 02, 2020 2:41 am

Installed Joplin on LMDE4 - will not start

Post by LarsG »

Have just installed Joplin using their download script below,

Code: Select all

wget -O - https://raw.githubusercontent.com/laurent22/joplin/dev/Joplin_install_and_update.sh | bash
The problem is that it will not start. The /var/log/syslog will show the below,

Code: Select all

Nov  3 13:37:51 my-computer systemd-coredump[4426]: Process 4416 (joplin) of user 1000 dumped core.#012#012Stack trace of thread 4416:#012#0
  0x0000564ac83c2993 n/a (/tmp/.mount_JoplinbbmVuE/joplin)#012#1  0x0000564ac9939938 n/a (/tmp/.mount_JoplinbbmVuE/joplin)#012#2  
  0x0000564ac9938dbd n/a (/tmp/.mount_JoplinbbmVuE/joplin)#012#3  0x0000564ac7c0c9a8 n/a (/tmp/.mount_JoplinbbmVuE/joplin)#012#4  
  0x0000564ac993814e n/a (/tmp/.mount_JoplinbbmVuE/joplin)#012#5  0x0000564ac993ded1 n/a (/tmp/.mount_JoplinbbmVuE/joplin)#012#6  
  0x0000564ac7c0c2c3 n/a (/tmp/.mount_JoplinbbmVuE/joplin)#012#7  0x0000564ac993e91c n/a (/tmp/.mount_JoplinbbmVuE/joplin)#012#8  
  0x0000564ac6fc0141 n/a (/tmp/.mount_JoplinbbmVuE/joplin)#012#9  0x0000564ac6542d3b n/a (/tmp/.mount_JoplinbbmVuE/joplin)#012#10 
  0x00007f36cabb409b __libc_start_main (libc.so.6)#012#11 0x0000564ac6542aea n/a (/tmp/.mount_JoplinbbmVuE/joplin)
Nov  3 13:37:51 my-computer systemd[1]: systemd-coredump@2-4425-0.service: Succeeded.
I would appreciate any comment on this.

Thanks
Last edited by karlchen on Tue Nov 03, 2020 8:53 am, edited 2 times in total.
Reason: changed [quote] tags to [code] tags: preserve screen output formatting.
User avatar
Kadaitcha Man
Level 12
Level 12
Posts: 4154
Joined: Mon Aug 27, 2012 10:17 pm

Re: Installed Joplin on LMDE4 - will not start

Post by Kadaitcha Man »

LarsG wrote:
Tue Nov 03, 2020 8:47 am
I would appreciate any comment on this.
The first port of call is the joplin site and the documentation overview on the front page. When you do that, you read this:
If it works with your distribution (it has been tested on Ubuntu, Fedora, and Mint; the desktop environments supported are GNOME, KDE, Xfce, MATE, LXQT, LXDE, Unity, Cinnamon, Deepin and Pantheon),
Emphasis added. It does not mention Debian or LMDE4, and Mint is likely to only refer to Linux Mint itself, not LMDE4. It also says, "If it works with your distribution", which means that it might not work with your distribution. Consequently, one would expect that one needs to first verify that it actually runs on Debian Buster or LMDE4 before installing it.

The second port of call is to continue reading the front page. When you do that, you read this:
Support

Joplin Forum
That's your third port of call.
All kadaitcha men are liars

(It's pronounced kad-eye-cha, not kada-itcha)
User avatar
MrEen
Level 23
Level 23
Posts: 17635
Joined: Mon Jun 12, 2017 8:39 pm

Re: Installed Joplin on LMDE4 - will not start

Post by MrEen »

There are Debian users successfully using the AppImage version of Joplin.

I lost the link before creating this post, but I searched on "Debian" at the github issues page where I saw that. One user (at least) needed to use joplin --no-sandbox to get it to run.
LarsG
Level 1
Level 1
Posts: 25
Joined: Wed Sep 02, 2020 2:41 am

Re: Installed Joplin on LMDE4 - will not start

Post by LarsG »

Kadaitcha Man wrote:
Wed Nov 04, 2020 12:27 am
LarsG wrote:
Tue Nov 03, 2020 8:47 am
I would appreciate any comment on this.
The first port of call is the joplin site and the documentation overview on the front page. When you do that, you read this:
If it works with your distribution (it has been tested on Ubuntu, Fedora, and Mint; the desktop environments supported are GNOME, KDE, Xfce, MATE, LXQT, LXDE, Unity, Cinnamon, Deepin and Pantheon),
Emphasis added. It does not mention Debian or LMDE4, and Mint is likely to only refer to Linux Mint itself, not LMDE4. It also says, "If it works with your distribution", which means that it might not work with your distribution. Consequently, one would expect that one needs to first verify that it actually runs on Debian Buster or LMDE4 before installing it.

The second port of call is to continue reading the front page. When you do that, you read this:
Support

Joplin Forum
That's your third port of call.
Thanks a lot. I was maybe to naive thinking that it should work directly..
User avatar
Kadaitcha Man
Level 12
Level 12
Posts: 4154
Joined: Mon Aug 27, 2012 10:17 pm

Re: Installed Joplin on LMDE4 - will not start

Post by Kadaitcha Man »

LarsG wrote:
Wed Nov 04, 2020 2:11 am
Thanks a lot. I was maybe to naive thinking that it should work directly..
Well, I wouldn't say that. Slightly misguided perhaps, but not naive. At least now you have somewhere where you might get better assistance, and you have learned to verify some things before starting, so it's good outcome.

Good luck.
All kadaitcha men are liars

(It's pronounced kad-eye-cha, not kada-itcha)
User avatar
i18nde
Level 1
Level 1
Posts: 1
Joined: Sun May 03, 2020 8:10 pm
Location: Gadebusch, Nordwest-Mecklenburg

[Solved] Installed Joplin on LMDE4 - will not start

Post by i18nde »

It is the same problem with Debian 10, but here is the solution: :idea:

What worked for me is running the following command:

Code: Select all

sudo sysctl kernel.unprivileged_userns_clone=1
you will need to do it every time you restart your computer. And yes, it is userns with the letter r and not users!

For avoid doing it every time you restart the computer you may added it to your sysctl.conf file by doing the follow: in the terminal

Code: Select all

sudo nano /etc/sysctl.conf
and in any empty line just add

Code: Select all

kernel.unprivileged_userns_clone=1
then Ctrl + O > Enter > Ctrl + X and you will have save the file.
Strawberry fields forever ...
Post Reply

Return to “Software & Applications”