Vulkan Not Working with nvidia-driver Package

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
Post Reply
Titan91
Level 1
Level 1
Posts: 45
Joined: Mon May 23, 2016 8:30 am

Vulkan Not Working with nvidia-driver Package

Post by Titan91 » Sat Aug 10, 2019 5:30 pm

I'm running LMDE3 64-bit with a GeForce GTX 1050 Ti card. I've installed nvidia-driver=418.74-1~bpo9+1 from the stretch-backports repository. Nvidia states this development driver supports Vulkan 1.1. I also installed libvulkan1 and vulkan-utils from the same repo. Vulkaninfo is telling me I have an incompatible driver. This is after rebooting and allowing the kernel to utilize the new driver:

Code: Select all

===========
VULKAN INFO
===========

Vulkan Instance Version: 1.1.70

Cannot create Vulkan instance.
/build/vulkan-IxfvhA/vulkan-1.1.70+dfsg1/demos/vulkaninfo.c:768: failed with VK_ERROR_INCOMPATIBLE_DRIVER
This thread shows a similar issue, which was resolved by recreating the initrd RAMdisk file. Should I try this? Do I also need nvidia-vulkan-common and/or nvidia-vulkan-icd?

https://bbs.archlinux.org/viewtopic.php?id=246293

Titan91
Level 1
Level 1
Posts: 45
Joined: Mon May 23, 2016 8:30 am

Re: Vulkan Not Working with nvidia-driver Package

Post by Titan91 » Mon Aug 12, 2019 8:36 pm

I looked in to recreating the RAMdisk image. /boot looks like this:

Code: Select all

ls /boot/
config-4.9.0-8-amd64          memtest86+.bin
config-4.9.0-9-amd64          memtest86+_multiboot.bin
efi                           System.map-4.9.0-8-amd64
grub                          System.map-4.9.0-9-amd64
initrd.img-4.9.0-8-amd64      vmlinuz-4.9.0-8-amd64
initrd.img-4.9.0-9-amd64      vmlinuz-4.9.0-9-amd64
Reading some guides, I tried making a backup copy and using mkinitrd but the command isn't found. I'm guessing I'm using initramfs which seems to be a newer standard, but I don't seem to have any initramfs images in /boot.
Last edited by Titan91 on Sun Aug 18, 2019 1:19 pm, edited 1 time in total.

Titan91
Level 1
Level 1
Posts: 45
Joined: Mon May 23, 2016 8:30 am

Re: Vulkan Not Working with nvidia-driver Package

Post by Titan91 » Sun Aug 18, 2019 1:19 pm

I did a kernel update to 4.9.0.9 which updated initramfs. I also installed nvidia-common and saw the same issue after both steps. Since the resolution isn't clear I will probably just get an AMD card and use the built-in open source drivers from AMD. Seems people have a lot better luck going that route.

Post Reply

Return to “Hardware Support”