No Speaker Sound LMDE 5 (Cinnamon)

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
Post Reply
D_Hallahan
Level 1
Level 1
Posts: 15
Joined: Mon Apr 20, 2020 1:21 am

No Speaker Sound LMDE 5 (Cinnamon)

Post by D_Hallahan »

Hey folks,
I hope this question hasn't been asked a million times:

Two fresh installs of LMDE 5 (Cinnamon) on two different machines. Headset works fine on both .. speaks don't work (on both).
Any ideas?

edit: I'm having a true Spongebob moment here. The speakers aren't working in Windows 10 either. However, I know they do work. Why? Because they work just fine on my Samsung laptop .. which is running LMDE 5.
User avatar
MiZoG
Level 5
Level 5
Posts: 567
Joined: Fri Jan 26, 2018 8:30 pm

Re: No Speaker Sound LMDE 5 (Cinnamon)

Post by MiZoG »

You have tried your luck with sound manager output options, have you not? How do your speakers and headset connect, with jacks or USB? Swap front/rare audio / USB ports.
D_Hallahan
Level 1
Level 1
Posts: 15
Joined: Mon Apr 20, 2020 1:21 am

Re: No Speaker Sound LMDE 5 (Cinnamon)

Post by D_Hallahan »

Hey and thank you for the response.
Well, I tried youtube's suggestions: pavcontrol and alsa. Nothing.
Tried the front and back audio jacks .. nothing.
The headset is usb and the speakers are usb (for power I suppose) and red and light green jacks. I switched them around every way I could think of .. nothing.
Was about to try this https://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/
Give me a few minutes and I'll post a report.
Folks, simple speakers have been around forever. Shouldn't we have this issue mastered by now?
D_Hallahan
Level 1
Level 1
Posts: 15
Joined: Mon Apr 20, 2020 1:21 am

Re: No Speaker Sound LMDE 5 (Cinnamon)

Post by D_Hallahan »

Amazing! None of the suggestions worked! lol
Well, I'll check back if anyone has any ideas. Thank you in advance.
jwiz
Level 4
Level 4
Posts: 270
Joined: Tue Dec 20, 2016 6:59 am

Re: No Speaker Sound LMDE 5 (Cinnamon)

Post by jwiz »

I would me most helpful if you just posted the 'inxi' output of your system, otw we're all just guesstimating.
What do you see in the sound control panel as sound output for your USB speakers? The "Dummy" profile?
Also when switching form the presumably working headphones to the USB speakers try a 'pulseaudio -k' to restart the sound system, this might help.
D_Hallahan
Level 1
Level 1
Posts: 15
Joined: Mon Apr 20, 2020 1:21 am

Re: No Speaker Sound LMDE 5 (Cinnamon)

Post by D_Hallahan »

$ inxi
CPU: Quad Core AMD Ryzen 3 2200G with Radeon Vega Graphics (-MCP-)
speed/min/max: 1531/1600/3500 MHz Kernel: 5.10.0-18-amd64 x86_64 Up: 4m
Mem: 1698.4/16014.6 MiB (10.6%) Storage: 465.76 GiB (4.4% used) Procs: 247
Shell: Bash inxi: 3.3.01
D_Hallahan
Level 1
Level 1
Posts: 15
Joined: Mon Apr 20, 2020 1:21 am

Re: No Speaker Sound LMDE 5 (Cinnamon)

Post by D_Hallahan »

I plugged in the speakers (two cheap but new Samsung speaks) andreboooted, left-click the speak icon on the bottom right, left-click "sound settings" and under output it says HDMI Baffin audio Raedeon RX 550 (this is after I unplug my usb headset). The headset is plug and play. I can get sound just by plugging it in. and I'm not using any audio from my monitor and nothing says "dummy." These speakers have a usb connector (for power) and a red and light green audio jacks. The speak system does, in fact, work. For some reason the speakers work just fine on my Samsung laptop (which is running LMDE 5).
jwiz
Level 4
Level 4
Posts: 270
Joined: Tue Dec 20, 2016 6:59 am

Re: No Speaker Sound LMDE 5 (Cinnamon)

Post by jwiz »

Hmm..., there are several reported issues with AMD baffin audio.

Can you please post the console outputs for:

a) /sbin/lspci -nnk | grep -A2 Audio
b) pactl list sinks
c) pacmd list-cards

P.S.:
if you know how to set a kernel parameter at boot, you might as well try to set 'amdgpu.dc=0' on the kernel command line, thus forcing the HDMI output by disabling the DDC (digital to digital converter) output and see if that solves the problem.
Post Reply

Return to “Hardware Support”