Page 1 of 1

LMDE 4 on mid 2007 24" iMac(4GB memory)

Posted: Tue Jun 30, 2020 3:57 am
by gordon
I've noticed three things(bugs?) since I've been using it.
1. Lots of popping with the sound. Particularly when using video websites like YouTube. I disabled power management in a 'monkey see, monkey do' manner, in the terminal, to solve the issue.
2. When returning from Suspend, the screen is a washed-out, distorted pink. Though it still responds to input if you know where to click to Restart. Hibernate seems to work okay.
3. I have a full-size USB, UK-layout, Macintosh keyboard that came with the iMac. The section key(between the Escape and Tab keys) and the grave key(between the left-shift and z keys) are transposed. i.e. Pressing the ยง key gives a `, and vis-a-versa. The same applies to their shifted characters. I presume this is some kind of mixed up scancode issue? This is using the English (UK, Macintosh) layout. Using other Macintosh layouts makes matters worse. When showing the layout in the Keyboard app, pressing one of these keys highlights the other. As an aside, the Macintosh keyboard layout in the Keyboard app looks like a slightly modified PC layout. Shouldn't it look like the keyboard I have in front of me?
Other than that, LMDE 4 works great to revitalise this old machine. I have more powerful machines, but I find myself using this one most of the time!

Re: LMDE 4 on mid 2007 24" iMac(4GB memory)

Posted: Tue Jul 21, 2020 5:42 am
by gordon
I use an old Wacom Graphire3 4x5 tablet with this iMac. It has a mouse that can be used instead of the pen. The tablet then acts as a mouse mat. The Reverse scrolling direction in the Mouse General settings doesn't appear to work in this configuration. There is a separate Graphics Tablet setting screen, but this only has settings for the tablet and pen.
Still loving the experience of using this. Particularly since Warpinator is now available for LMDE. I just have to switch mental gears when I use my other computers, as they scroll the other way.