Laptop internal keyboard and touchpad mouse issues

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
Post Reply
isquras
Level 1
Level 1
Posts: 4
Joined: Sat Oct 03, 2020 12:19 pm

Laptop internal keyboard and touchpad mouse issues

Post by isquras »

I'm VERY new to Linux (but am SO happy to be DONE with Windows and all their recurring glitches, outages, etc.!!!).

I was once proficient with MS DOS, so a terminal doesn't scare me, and I LOVE the stability. Frankly, now that I know I can play games on Linux, I'm all in!

That said, I'm having a WEIRD issue with my laptop internal keyboard and touchscreen mouse. Comp/inxii details pasted at the bottom.

When I first boot up, my internal keyboard and touchpad mouse don't work. I often have my laptop connected to an external mouse and keyboard anyway, so it doesn't normally effect me, but this is where it gets weird.

Both work in BIOS ... AND they both "turn on," so to speak, if I tilt the computer on it's side and/or upside down after the system is booted. After I do that once, they work until I reboot.

It doesn't bother me very terribly, but there's got to be a fix for this, right?

Looking forward to your thoughts. And, please remember, I'm an above-average computer user but still VERY new to Linux, so bear with me and please use BASIC and detailed descriptions. Thanks!!!

I have a Dell XPS 15 9575 2-in-1.

I'm running LMDE 4, Debbie with the Cinnamon display (? style?).


Code: Select all

System:
  Host: dsk Kernel: 4.19.0-11-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0 
  Desktop: Cinnamon 4.6.7 wm: muffin 4.6.3 dm: LightDM 1.26.0 
  Distro: LMDE 4 Debbie base: Debian 10.2 buster 
Machine:
  Type: Convertible System: Dell product: XPS 15 9575 v: N/A 
  serial: <filter> Chassis: type: 31 serial: <filter> 
  Mobo: Dell model: 0C32VW v: A00 serial: <filter> UEFI: Dell v: 1.12.1 
  date: 05/25/2020 
Battery:
  ID-1: BAT0 charge: 62.0 Wh condition: 62.0/75.0 Wh (83%) volts: 13.0/11.4 
  model: BYD DELL TMFYT9C type: Li-poly serial: <filter> status: Full 
CPU:
  Topology: Quad Core model: Intel Core i7-8705G bits: 64 type: MT MCP 
  arch: Kaby Lake rev: 9 L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 49536 
  Speed: 3718 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 3711 2: 3669 
  3: 3699 4: 3870 5: 3551 6: 3583 7: 3868 8: 3762 
Graphics:
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:591b 
  Device-2: AMD Polaris 22 XL [Radeon RX Vega M GL] vendor: Dell 
  driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:694e 
  Display: x11 server: X.Org 1.20.4 driver: amdgpu,ati,modesetting 
  unloaded: fbdev,vesa resolution: 3840x2160~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) 
  v: 4.5 Mesa 18.3.6 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 
  Sound Server: ALSA v: k4.19.0-11-amd64 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Bigfoot Networks driver: ath10k_pci v: kernel port: e000 
  bus ID: 02:00.0 chip ID: 168c:003e 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 1.86 TiB used: 255.28 GiB (13.4%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM981a NVMe 2048GB 
  size: 1.86 TiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 15300229 
  scheme: GPT 
Partition:
  ID-1: / size: 191.25 GiB used: 9.86 GiB (5.2%) fs: ext4 
  dev: /dev/nvme0n1p3 
  ID-2: /home size: 1.18 TiB used: 245.41 GiB (20.4%) fs: ext4 
  dev: /dev/nvme0n1p4 
  ID-3: swap-1 size: 80.0 MiB used: 1.5 MiB (1.9%) fs: swap 
  dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 82.0 C mobo: N/A gpu: amdgpu temp: 53 C 
  Fan Speeds (RPM): N/A 
Repos:
  Active apt repos in: /etc/apt/sources.list 
  1: deb http://deb.debian.org/debian/ buster main non-free contrib
  2: deb-src http://deb.debian.org/debian/ buster main non-free contrib
  3: deb http://security.debian.org/debian-security buster/updates main contrib non-free
  4: deb-src http://security.debian.org/debian-security buster/updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
  1: deb https://dl.winehq.org/wine-builds/debian/ buster main
  Active apt repos in: /etc/apt/sources.list.d/amdgpu-pro-local.list 
  1: deb [ trusted=yes ] file:/var/opt/amdgpu-pro-local/ ./
  Active apt repos in: /etc/apt/sources.list.d/brave-browser-release.list 
  1: deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
  Active apt repos in: /etc/apt/sources.list.d/liquorix.list 
  1: deb http://liquorix.net/debian buster main
  2: deb-src http://liquorix.net/debian buster main
  Active apt repos in: /etc/apt/sources.list.d/lutris.list 
  1: deb http://download.opensuse.org/repositories/home:/strycore/Debian_10/ ./
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com debbie main upstream import backport #id:linuxmint_main
  2: deb https://deb.debian.org/debian buster main contrib non-free
  3: deb https://deb.debian.org/debian buster-updates main contrib non-free
  4: deb http://security.debian.org buster/updates main contrib non-free
  5: deb https://deb.debian.org/debian buster-backports main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/wine-obs.list 
  1: deb http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10 ./
  Active apt repos in: /etc/apt/sources.list.d/xanmod-kernel.list 
  1: deb http://deb.xanmod.org releases main
Info:
  Processes: 302 Uptime: 53m Memory: 15.39 GiB used: 3.32 GiB (21.6%) 
  Init: systemd v: 241 runlevel: 5 Compilers: gcc: 8.3.0 alt: 8 Shell: bash 
  v: 5.0.3 running in: gnome-terminal inxi: 3.0.32
Last edited by Moem on Sun Oct 04, 2020 5:11 am, edited 1 time in total.
Reason: Moved into the LMDE support area.
isquras
Level 1
Level 1
Posts: 4
Joined: Sat Oct 03, 2020 12:19 pm

Re: Laptop internal keyboard and touchpad mouse issues

Post by isquras »

Forgot to mention, both the laptop internal keyboard and the the touchpad mouse DID work during the Live USB Boot session and installation without having to tilt the computer, and the issue began immediately on the first boot AFTER installation.
jwiz
Level 3
Level 3
Posts: 150
Joined: Tue Dec 20, 2016 6:59 am

Re: Laptop internal keyboard and touchpad mouse issues

Post by jwiz »

Upgrade to the latest 5.8 kernel and firmware from buster-backports and don't look back:

Code: Select all

sudo apt update && apt install -t buster-backports linux-image-amd64 -y && apt install -t buster-backports linux-headers-amd64 -y && apt install -t buster-backports firmware-linux firmware-linux-nonfree -y && reboot
isquras
Level 1
Level 1
Posts: 4
Joined: Sat Oct 03, 2020 12:19 pm

Re: Laptop internal keyboard and touchpad mouse issues

Post by isquras »

Thank you for the help. I tried this, but it still isn't working. Same problems persist. I have to tilt the computer to the left for a moment after loading before my internal mouse and keyboard work. Very strange, I know!

Any other thoughts? I'm amenable to fixing this, for sure! Thanks!
Post Reply

Return to “Hardware Support”