Internet occasionally stops working on Linux Mint LMDE 4

Questions about networking
Forum rules
Before you post please read this
champloo
Level 1
Level 1
Posts: 22
Joined: Sun Aug 23, 2020 6:16 am

Internet occasionally stops working on Linux Mint LMDE 4

Post by champloo »

I didn't really notice any patterns as to when it stops working.* It may stop once a day or a few times a day. Whenever it happens, I have to toggle 'Wired' connection button on and off from the taskbar icon and the Internet is back literally within a second. When the Internet stops working, icon from the taskbar remains the same, like I am still online. I noticed this because I can't browse and I can't send and receive messages over messaging apps.

While the Internet stops working in the manner I described above, here are some of the things I tried:

'ping 8.8.8.8' returns 'connect: Network is unreachable.'
'ping google.com' returns 'ping: google.com: Name or service not known'
'ip r s' returns nothing.

'ip r s' returns this while having an Internet connection:

Code: Select all

default via 192.168.0.1 dev enp4s0 proto dhcp metric 100 
169.254.0.0/16 dev enp4s0 scope link metric 1000 
192.168.0.0/24 dev enp4s0 proto kernel scope link src 192.168.0.15 metric 100
'lshw -c net' returns this while having an Internet connection:

Code: Select all

*-network                 
    description: Ethernet interface
    product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:04:00.0
    logical name: enp4s0
    version: 15
    serial: 10:7b:44:47:b0:91
    size: 1Gbit/s
    capacity: 1Gbit/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp aui bnc mii fibre 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.0.15 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
    resources: irq:19 ioport:d000(size=256) memory:f7204000-f7204fff memory:f7200000-f7203fff
This is really frustrating and I don't really know what to do, except for toggling the 'Wired' button over and over again.

* I'm still not sure, but this may certainly always happen about one hour after booting up.
Last edited by champloo on Sat Aug 29, 2020 11:08 am, edited 2 times in total.
axisofevil
Level 3
Level 3
Posts: 183
Joined: Mon Nov 14, 2011 12:22 pm

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by axisofevil »

I have virtually the same ethernet hardware - but its a totally stable connection - many months between drops.
Same driver - slightly different firmware.

I'd be tempted to blame the ISP - but do you have a flakey internet connection?
Do speedtests show poor results [when its working]
Also, what do you use for your DNS lookup - 1.1.1.1 or 8.8.8.8 are good.

Code: Select all

  *-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 09
       serial: 2c:4d:54:4f:a1:06
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8168f-1_0.0.5 06/18/12 ip=192.168.1.7 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:26 ioport:d000(size=256) memory:fa104000-fa104fff memory:fa100000-fa103fff
sleeper12
Level 13
Level 13
Posts: 4750
Joined: Thu May 25, 2017 3:22 pm

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by sleeper12 »

Have you tried the obvious: a different ethernet cable, restart the router?
champloo
Level 1
Level 1
Posts: 22
Joined: Sun Aug 23, 2020 6:16 am

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by champloo »

sleeper12 wrote:
Sun Aug 23, 2020 11:48 am
Have you tried the obvious: a different ethernet cable, restart the router?
This never happens with same equipment on Windows, so no. Besides, as I said in my original post, toggling 'Wired' connection button on and off from the taskbar icon brings the Internet back literally within a second, so I really doubt it's the equipment.
Last edited by champloo on Sat Aug 29, 2020 2:08 pm, edited 2 times in total.
champloo
Level 1
Level 1
Posts: 22
Joined: Sun Aug 23, 2020 6:16 am

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by champloo »

axisofevil wrote:
Sun Aug 23, 2020 11:42 am
I'd be tempted to blame the ISP - but do you have a flakey internet connection?
Do speedtests show poor results [when its working]
Also, what do you use for your DNS lookup - 1.1.1.1 or 8.8.8.8 are good.
On the same equipment, the Internet works flawlessly on Windows, with full speeds and no flakey connection. It also works at full speed and without flakey connection on LMDE, it's just that at some point the Internet is gone, even though taskbar icon indicates that I'm online. As I said, toggling 'Wired' connection button on and off from the taskbar icon brings the Internet back literally within a second, but it's really frustrating to do this from time to time.
Last edited by champloo on Sun Aug 23, 2020 12:07 pm, edited 1 time in total.
axisofevil
Level 3
Level 3
Posts: 183
Joined: Mon Nov 14, 2011 12:22 pm

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by axisofevil »

Routers are designed to be rebooted from time to time.
sleeper12
Level 13
Level 13
Posts: 4750
Joined: Thu May 25, 2017 3:22 pm

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by sleeper12 »

In addition to restarting the router, you can try:

Code: Select all

 sudo systemctl restart network-manager.service 
champloo
Level 1
Level 1
Posts: 22
Joined: Sun Aug 23, 2020 6:16 am

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by champloo »

sleeper12 wrote:
Sun Aug 23, 2020 12:03 pm
In addition to restarting the router, you can try:

Code: Select all

 sudo systemctl restart network-manager.service 
Sure, that would work, but why would I do that when I can just toggle 'Wired' connection button on and off from the taskbar icon, which brings the Internet back within a second? It's kinda easier like this.
sleeper12
Level 13
Level 13
Posts: 4750
Joined: Thu May 25, 2017 3:22 pm

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by sleeper12 »

champloo wrote:
Sun Aug 23, 2020 12:06 pm
sleeper12 wrote:
Sun Aug 23, 2020 12:03 pm
In addition to restarting the router, you can try:

Code: Select all

 sudo systemctl restart network-manager.service 
Sure, that would work, but why would I do that when I can just toggle 'Wired' connection button on and off from the taskbar icon, which brings the Internet back within a second? It's kinda easier like this.
Ummm...because it might fix whatever is causing the problem. If you don't want to do what we suggest, then why ask for help :?:
champloo
Level 1
Level 1
Posts: 22
Joined: Sun Aug 23, 2020 6:16 am

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by champloo »

sleeper12 wrote:
Sun Aug 23, 2020 12:12 pm
champloo wrote:
Sun Aug 23, 2020 12:06 pm
sleeper12 wrote:
Sun Aug 23, 2020 12:03 pm
In addition to restarting the router, you can try:

Code: Select all

 sudo systemctl restart network-manager.service 
Sure, that would work, but why would I do that when I can just toggle 'Wired' connection button on and off from the taskbar icon, which brings the Internet back within a second? It's kinda easier like this.
Ummm...because it might fix whatever is causing the problem. If you don't want to do what we suggest, then why ask for help :?:
I thought that would work as a one time solution only until I boot up again. Ok, I just entered it. Now I'll restart my computer and will let you guys know if it's still happening.

Thank you
Last edited by champloo on Sun Aug 23, 2020 12:20 pm, edited 2 times in total.
champloo
Level 1
Level 1
Posts: 22
Joined: Sun Aug 23, 2020 6:16 am

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by champloo »

axisofevil wrote:
Sun Aug 23, 2020 11:56 am
Routers are designed to be rebooted from time to time.
Why I never had to do that under Windows?
axisofevil
Level 3
Level 3
Posts: 183
Joined: Mon Nov 14, 2011 12:22 pm

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by axisofevil »

champloo wrote:
Sun Aug 23, 2020 12:20 pm
axisofevil wrote:
Sun Aug 23, 2020 11:56 am
Routers are designed to be rebooted from time to time.
Why I never had to do that under Windows?
Ask whoever wrote the driver for Microsoft [Realtek?]
sleeper12
Level 13
Level 13
Posts: 4750
Joined: Thu May 25, 2017 3:22 pm

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by sleeper12 »

Even if you have no problems, it's wise to restart the router every few months:
https://www.rd.com/article/when-to-reboot-router/
sleeper12
Level 13
Level 13
Posts: 4750
Joined: Thu May 25, 2017 3:22 pm

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by sleeper12 »

Did anything help or do you still have the problem?
champloo
Level 1
Level 1
Posts: 22
Joined: Sun Aug 23, 2020 6:16 am

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by champloo »

sleeper12 wrote:
Sun Aug 23, 2020 8:22 pm
Did anything help or do you still have the problem?
Since I entered the command you sent me, I rebooted and it's been working fine for now. I wanted to wait a few more days before coming back to confirm that the problem has been solved.

Thank you very much!
sleeper12
Level 13
Level 13
Posts: 4750
Joined: Thu May 25, 2017 3:22 pm

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by sleeper12 »

Ok, let's wait & see then. :wink:
champloo
Level 1
Level 1
Posts: 22
Joined: Sun Aug 23, 2020 6:16 am

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by champloo »

sleeper12 wrote:
Sun Aug 23, 2020 11:35 pm
Ok, let's wait & see then. :wink:
I logged into Linux today again and everything runs smoothly. This problem used to usually occur about one hour after boot, but now it's solid, just like two days ago. It seems to me like it's fixed for now, so I'll add [SOLVED] to my original post.

Thank you very much!
champloo
Level 1
Level 1
Posts: 22
Joined: Sun Aug 23, 2020 6:16 am

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by champloo »

It just happened again. :(
sleeper12
Level 13
Level 13
Posts: 4750
Joined: Thu May 25, 2017 3:22 pm

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by sleeper12 »

Did you ever try restarting the router? If not, try that, shut the machine down first.
champloo
Level 1
Level 1
Posts: 22
Joined: Sun Aug 23, 2020 6:16 am

Re: Internet occasionally stops working on Linux Mint LMDE 4

Post by champloo »

sleeper12 wrote:
Sat Aug 29, 2020 11:39 am
Did you ever try restarting the router? If not, try that, shut the machine down first.
I just shut down, restarted the router and booted up again. Will let you know if it still happens.

Btw, we recently had a blackout in my neighborhood. Does that count as shutting down and restarting the router as well? It's technically the same?
Post Reply

Return to “Networking”