Not liking the calamares installer - Am I the only one?

Questions about other topics & discussing non-support related topics related to LMDE 3.
Forum rules
Before you post please read how to get help
Post Reply
srq2625
Level 4
Level 4
Posts: 420
Joined: Tue Jan 08, 2013 11:35 am
Location: State: Constant Confusion, Country: D'oh

Not liking the calamares installer - Am I the only one?

Post by srq2625 » Fri Sep 14, 2018 1:13 pm

Some background: I've pretty much settled on LM 19 for my daily driver so my distro-hopping days are pretty much over. I have 3 computers (1 desktop, 1 laptop, and 1 i3-based tablet) and I have LM 19 installed on all of them. It's also installed on my lovely wife's laptop top as well.

But, I've always had a soft spot for Debian. I know it's crazy, but Debian has always just "felt better" with softer edges and better response, that kind of very subjective "feeling." It's for this reason I downloaded Cindy and installed it on a spare HDD.

Now that the background is out of the way, my thoughts about calamares: In short, though it seemed to do it's job well it is lacking something huge; feedback during the installation. Three times the installer seemed to just stall, at about 14% complete, 62% complete, and again at about 93% complete. The installer was a lot like that duck on the pond - not much visible above the surface but paddling like mad just under the waterline where one can't see it.

If I hadn't had system monitor running and been able to see that the CPU was not just sitting at idle, I would have given in to my urge to terminate the install and start over with the Mint installer.

Yeah, so not liking the calamares installer very much. Any other opinions?

User avatar
AZgl1500
Level 10
Level 10
Posts: 3486
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Not liking the calamares installer - Am I the only one?

Post by AZgl1500 » Fri Sep 14, 2018 2:07 pm

you just gave me a good idea for future installs,

I am going to invoke System Monitor on all installs in future....

I am really peeved at the Devs not giving us feedback during an install.

the screen goes black and nothing............................................... a quick flash of something went by
.................................... blackness abounds again.........................................................
oh, it is green now..............................................................................

and finally, it says " remove media and hit <enter>"

and right here, is where it all goes wrong.... I can't tell you how many times, I have pulled the media out "right now, and not waited until it actually means " Okay, I am done, please pull media".... pull it too early, and you have to start all over again.

Post Reply

Return to “Other Topics & Open Discussion”