Pulseaudio RTP multicast not working properly on 32-bit Cindy

Questions about other topics & discussing non-support related topics related to LMDE 3.
Forum rules
Before you post please read how to get help
Post Reply
User avatar
MLED4
Level 1
Level 1
Posts: 6
Joined: Thu Oct 25, 2018 12:31 am

Pulseaudio RTP multicast not working properly on 32-bit Cindy

Post by MLED4 » Mon Nov 19, 2018 12:30 pm

Hi, found a bug in Cindy32, not a problem with 64 bit.

Where do I report it please? I've done the troubleshooting and investigation.

User avatar
Moem
Level 19
Level 19
Posts: 9220
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Pulseaudio RTP multicast not working properly on 32-bit Cindy

Post by Moem » Mon Nov 19, 2018 12:32 pm

This document can probably point you in the right direction:
https://linuxmint-troubleshooting-guide ... index.html
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
MLED4
Level 1
Level 1
Posts: 6
Joined: Thu Oct 25, 2018 12:31 am

Re: Pulseaudio RTP multicast not working properly on 32-bit Cindy

Post by MLED4 » Sun Dec 02, 2018 8:03 am

Thank you for the guide, I can reproduce the bug but I'm struggling to pin down the component.
The bug happens with 32-bit Cindy with cinnamon or mate desktop
The bug does not happen with 64-bit Cindy.
Also the bug does not happen running 32 bit Cindy on a 64 bit machine.

I'm not sure how to proceed.
Support for my lmde 2 mate RPT multicast receiver boxes ends soon, the Cinnamon lmde 3 doesn't work without making popping sounds.

User avatar
MLED4
Level 1
Level 1
Posts: 6
Joined: Thu Oct 25, 2018 12:31 am

Re: Pulseaudio RTP multicast not working properly on 32-bit Cindy

Post by MLED4 » Mon Dec 03, 2018 2:31 pm

Update: Installed lmde 2 cinnamon on three RTP receiver boxes and there is no popping sound.

Next step is to upgrade these to lmde 3 Cindy and test.

User avatar
MrEen
Level 13
Level 13
Posts: 4655
Joined: Mon Jun 12, 2017 8:39 pm

Re: Pulseaudio RTP multicast not working properly on 32-bit Cindy

Post by MrEen » Mon Dec 03, 2018 5:34 pm

Are these popping sounds just at the beginning of audio, then normal until something new starts?

User avatar
MLED4
Level 1
Level 1
Posts: 6
Joined: Thu Oct 25, 2018 12:31 am

Re: Pulseaudio RTP multicast not working properly on 32-bit Cindy

Post by MLED4 » Tue Dec 04, 2018 2:36 am

The popping sounds occur throughout the audio and also continue if the media playing is stopped or paused.
There's also an additional pop when adjusting volume but that can be worked around easily.

I've discovered another bug while testing, an RTP node can accidentally (or maliciously?) send seriously hard gabba to other nodes, This is scary.

User avatar
MrEen
Level 13
Level 13
Posts: 4655
Joined: Mon Jun 12, 2017 8:39 pm

Re: Pulseaudio RTP multicast not working properly on 32-bit Cindy

Post by MrEen » Tue Dec 04, 2018 5:59 pm

I can't speak to the new issue, but the popping might be fixed by editing /etc/pulse/default.pa and changing the line that says load-module module-udev-detect to load-module module-udev-detect tsched=0

Follow that up with sudo alsa force-reload then test the sound.

Good luck.

User avatar
MLED4
Level 1
Level 1
Posts: 6
Joined: Thu Oct 25, 2018 12:31 am

Re: Pulseaudio RTP multicast not working properly on 32-bit Cindy

Post by MLED4 » Wed Dec 05, 2018 8:09 am

That makes sense. Upgraded from lmde 2 to 3, the popping happened, rebooted with the old 3.16 kernel and the popping is gone.
The receiver boxes are all intel sound, the 64bit machine that was fine with lmde 3 cindy 32-bit doesn't have intel sound.

Will try the suggested fix and report back..

User avatar
MLED4
Level 1
Level 1
Posts: 6
Joined: Thu Oct 25, 2018 12:31 am

Re: Pulseaudio RTP multicast not working properly on 32-bit Cindy

Post by MLED4 » Wed Dec 05, 2018 9:03 am

Yes, that appears to work. Will try it on a clean install of Cindy and confirm. Thanks MrEen

User avatar
MrEen
Level 13
Level 13
Posts: 4655
Joined: Mon Jun 12, 2017 8:39 pm

Re: Pulseaudio RTP multicast not working properly on 32-bit Cindy

Post by MrEen » Wed Dec 05, 2018 9:32 am

You're quite welcome MLED4. Happy I could help. :)

Post Reply

Return to “Other Topics & Open Discussion”