Support for wireless

Write suggestions and new ideas in here
More ideas here http://community.linuxmint.com/idea/welcome
Forum rules
  • Only post ideas here that are specifically about the Linux Mint distribution or its websites.
  • So that developers and users from any distribution can discuss ideas in one place, post ideas about improving software to the collaboration website for that software instead.
User avatar
manishk
Level 3
Level 3
Posts: 178
Joined: Wed Nov 29, 2006 4:19 pm
Location: India

Support for wireless

Postby manishk » Sat Dec 02, 2006 5:13 pm

Hi,

Can you please consider providing better out-of-the-box support for wireless cards...like Broadcom 43xx series which had a known issue with Ubuntu 6.10 preinstalled drivers.

I heard that the latest Linux kernel will support these directly...but never understood what that means!

Thanks You!

User avatar
jett
Level 2
Level 2
Posts: 65
Joined: Tue Nov 28, 2006 8:43 pm

wireless

Postby jett » Sat Dec 02, 2006 11:52 pm

I also had issues getting my broadcom wireless driver to work with my laptop with ubuntu.

User avatar
clem
Level 15
Level 15
Posts: 5662
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Postby clem » Sun Dec 03, 2006 7:30 am

I don't think we will automate the wireless configuration in Bianca, but if it helps we could have ndiswrapper-utils installed by default. Maybe we could even include some INF files and a copy of the ndiswrapper wiki on the disc...

.. would that help ?

User avatar
manishk
Level 3
Level 3
Posts: 178
Joined: Wed Nov 29, 2006 4:19 pm
Location: India

Postby manishk » Mon Dec 04, 2006 8:26 am

Thats a great idea!

You can include the latest ndis-wrapper (1.30), ndis-utils and ndisgtk. The last one is a graphical frontend for installing the drivers. This will make it easier for newbies like me to get our wireless working, easily!

As for the .inf and wiki include them if its 'okay' because I dont think they are really necessary as ndisgtk makes the installation as simple as point and click!
:)

Thanks

User avatar
clem
Level 15
Level 15
Posts: 5662
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Postby clem » Mon Dec 04, 2006 9:03 am

Well... you mean ndisgtk automates the whole process so you don't have to fetch the right INF file yourself ? Also, how does ndisgtk fetch the INF file... via an Internet connection ? lol :)

We have to assume the user won't be connected at this stage.

Clem

User avatar
jonpackard
Level 1
Level 1
Posts: 44
Joined: Mon Nov 27, 2006 5:44 pm
Location: Bradenton, FL, USA

Postby jonpackard » Mon Dec 04, 2006 11:51 am

I think the best bet is to have a GUI setup utility that allows the user to select the driver files from a CD or other media. Most users will have a driver disc or will have them on their windows partition.

User avatar
manishk
Level 3
Level 3
Posts: 178
Joined: Wed Nov 29, 2006 4:19 pm
Location: India

Postby manishk » Mon Dec 04, 2006 3:34 pm

No, what I meant to say was exactly what jonpackard is asking for.

So like he said we have to just browse to the location where we have the .inf and say 'yes'!!

That means we can avoid the 'Terminal' which might be scary to some newbies (it was, for me).

I found a screenshot on the net

Image

User avatar
manishk
Level 3
Level 3
Posts: 178
Joined: Wed Nov 29, 2006 4:19 pm
Location: India

Postby manishk » Mon Dec 04, 2006 3:55 pm

I just read that Fiesty supports these Broadcom cards by default.

I read it in on a blog, who has been testing Fiesty.

May be you can just look into it, because I dint know what to make of it.

User avatar
clem
Level 15
Level 15
Posts: 5662
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Postby clem » Tue Dec 05, 2006 9:02 am

Ok I'll look into that and probably add those three packages to Bianca.

User avatar
manishk
Level 3
Level 3
Posts: 178
Joined: Wed Nov 29, 2006 4:19 pm
Location: India

Postby manishk » Wed Dec 06, 2006 2:46 pm

Thanks!

I was just wondering...how will you manage to get in so many things into Bianca and keep it at 700MB??

User avatar
clem
Level 15
Level 15
Posts: 5662
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Postby clem » Wed Dec 06, 2006 2:52 pm

Oh we'll find a way. The more we look at it the more we see things to remove and others to add :)

User avatar
jonpackard
Level 1
Level 1
Posts: 44
Joined: Mon Nov 27, 2006 5:44 pm
Location: Bradenton, FL, USA

Postby jonpackard » Thu Dec 07, 2006 9:42 am

manishk wrote:I just read that Fiesty supports these Broadcom cards by default.

I read it in on a blog, who has been testing Fiesty.

May be you can just look into it, because I dint know what to make of it.

I just ran the Fiesty Fawn Alpha 1 Live CD on my fiancee's laptop that uses a broadcom wireless card. It still gives the same errors Edgy gives about broadcom drivers during boot. Looks like ndiswrapper is still the way to go.
Jon Packard -- Linux Mint user since 11/14/2006

User avatar
clem
Level 15
Level 15
Posts: 5662
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Postby clem » Thu Dec 07, 2006 10:52 am

A Quick update on that: ndiswrapper 1.1 and ndisgtk will be there in Bea's stable release.

Clem

User avatar
jonpackard
Level 1
Level 1
Posts: 44
Joined: Mon Nov 27, 2006 5:44 pm
Location: Bradenton, FL, USA

Postby jonpackard » Thu Dec 07, 2006 11:16 am

Thanks Clem! Now I'll be able to run the Live CD on my fiancee's laptop.
Jon Packard -- Linux Mint user since 11/14/2006

User avatar
manishk
Level 3
Level 3
Posts: 178
Joined: Wed Nov 29, 2006 4:19 pm
Location: India

Postby manishk » Sat Dec 09, 2006 2:28 pm

Well...I guess the problem is with the 1.1 release (or whichever most distros are currently coming out with). I have tried the NDISwrapper 1.8 and it works (atleast my card did, BCM4311).

It DID NOT work with any earlier releases!

User avatar
clem
Level 15
Level 15
Posts: 5662
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Postby clem » Sat Dec 09, 2006 3:14 pm

Ok, I'm including ndiswrapper-utils-1.8 in Bea. I don't like to do that, especially after a code freeze, and I hope I'm not introducing a bug by doing that. I suppose in the worst case, people will be able to remove that package and default their ndiswrapper back to a 1.1 version by doing so.

Clem


Return to “Suggestions & New Ideas”

Who is online

Users browsing this forum: No registered users and 3 guests