XFWM4 tearing fix. 17.2 should use latest xfwm

Suggestions and feedback for Linux Mint and the forums
Forum rules
Not support questions here please. Before you post read: Where to post ideas & feature requests
Post Reply
User avatar
Yanpas
Level 1
Level 1
Posts: 31
Joined: Fri Apr 17, 2015 6:28 pm
Location: Russia

XFWM4 tearing fix. 17.2 should use latest xfwm

Post by Yanpas »

Several weeks ago tearing for NVidia graphic cards was fixed
https://bugzilla.xfce.org/show_bug.cgi?id=10439
So maybe 17.2 XFCE (or 17.3 XFCE) should use latest xfwm4. It works great with other xfce packages from trusty (mostly 4.11). And it should be built with libepoxy-dev and distro should contain one more package libepoxy0.
Yanpas: Linux Mint 17.3 64bit, Desktop: XFCE 4.12 Kernel 4.2
User avatar
richyrich
Level 19
Level 19
Posts: 9027
Joined: Mon May 04, 2009 8:31 pm

Re: XFWM4 tearing fix. 17.2 should use latest xfwm

Post by richyrich »

Read a while back, I think it was the roadmap at Segfault iirc. That the Mint Xfce devs were going to look at upgrading to Xfce 4.12 in Xfce edition 17.2. Just have to keep our fingers crossed. :)
User avatar
Yanpas
Level 1
Level 1
Posts: 31
Joined: Fri Apr 17, 2015 6:28 pm
Location: Russia

Re: XFWM4 tearing fix. 17.2 should use latest xfwm

Post by Yanpas »

I hope they won't just grab packages from Vivid, hope they build them from XFCE git. Moreover Xubuntu since 14.10 has problems with GTK themes in QT apps (clementine, qbittorerent work, but look like win95), nobody knows whether it is Xubuntu's fault or XFCE's. Manjaro doesn't have such problem, so probably Xubuntu's.

Ideally we will meet 4.12 in 17.2, QT apps will look nice and tearing will be fixed 8)
Yanpas: Linux Mint 17.3 64bit, Desktop: XFCE 4.12 Kernel 4.2
chrisonmint
Level 3
Level 3
Posts: 143
Joined: Sun May 03, 2015 10:49 am

Re: XFWM4 tearing fix. 17.2 should use latest xfwm

Post by chrisonmint »

richyrich wrote:Read a while back, I think it was the roadmap at Segfault iirc. That the Mint Xfce devs were going to look at upgrading to Xfce 4.12 in Xfce edition 17.2. Just have to keep our fingers crossed. :)
Xfce 4.12 is indeed included in the 17.2 version of Mint Xfce, so hopefully you will see an improvement after upgrading.

In my experience on 17.1, the only way to get rid of tearing on my Dell i5 with Intel graphics was to switch over to using Compiz for window management. This might be something for you to try if you still have problems, or dont want to go to the hassle of upgrading your system to 17.2.
User avatar
Yanpas
Level 1
Level 1
Posts: 31
Joined: Fri Apr 17, 2015 6:28 pm
Location: Russia

Re: XFWM4 tearing fix. 17.2 should use latest xfwm

Post by Yanpas »

http://blog.linuxmint.com/?p=2876
Edit #2 by Clem: Xfwm4 using epoxy instead of drm to vsync using openGL starts with https://github.com/xfce-mirror/xfwm4/co ... 4160f23d99.. but that commit isn’t part of Xfce 4.12. In fact it’s not even labeled afaik. If you look at the master branch, the devs are still ironing out GL aspects as far as June 2015. I’m reticent to jump to master. I wouldn’t want distros to use my muffin master branch or to jump further than our 2.6 labels. A simple bug fix can be cherry picked of course, but here we’re talking about a significant improvement. It doesn’t look like a bug fix planned for Xfwm4 4.12.4, more like a feature of an upcoming Xfwm4 4.14.x. It’s also not commit to take in isolation, there’s a trickle-down effect at play, so we wouldn’t cherry pick here, we’d basically jump onto master. I’d rather leave that decision to the Xfce devs. Let them decide how to label this and then we can consider upgrading to an eventual newer version.

We will see it in update or 17.3
Yanpas: Linux Mint 17.3 64bit, Desktop: XFCE 4.12 Kernel 4.2
chrisonmint
Level 3
Level 3
Posts: 143
Joined: Sun May 03, 2015 10:49 am

Re: XFWM4 tearing fix. 17.2 should use latest xfwm

Post by chrisonmint »

Yanpas wrote:We will see it in update or 17.3
In the meantime, switch to Compiz...
User avatar
Yanpas
Level 1
Level 1
Posts: 31
Joined: Fri Apr 17, 2015 6:28 pm
Location: Russia

Re: XFWM4 tearing fix. 17.2 should use latest xfwm

Post by Yanpas »

You may build xfwm4 from git, or I may upload my build somewhere if you need
Yanpas: Linux Mint 17.3 64bit, Desktop: XFCE 4.12 Kernel 4.2
Post Reply

Return to “Suggestions & Feedback”