PRIME Synchronisation

Write suggestions and new ideas in here
More ideas here http://community.linuxmint.com/idea/welcome
Forum rules
  • Only post ideas here that are specifically about the Linux Mint distribution or its websites.
  • So that developers and users from any distribution can discuss ideas in one place, post ideas about improving software to the collaboration website for that software instead.
vxgmichel
Level 1
Level 1
Posts: 1
Joined: Fri Oct 20, 2017 11:06 am

PRIME Synchronisation

Postby vxgmichel » Fri Oct 20, 2017 11:46 am

Hi all,

It's been a year since PRIME synchronization for optimus laptops is supported by nvidia:
offical thread on devtalk.nvidia.com

The requirements are:
- linux kernel 4.5 or higher
- an X server with ABI 23 or higher, i.e. Xorg server >= 1.19
- compatible nvidia drivers (370 or higher)

I got a working tear-free setup on my own laptop using:
- ubuntu 17.10
- xserver-xorg-core 1.19.5
- nvidia 384

I had to wrestle a bit with modeset (as documented here) but that's pretty much it.

So my question is, is PRIME synchronization going to be supported on Mint 18.3?

Thanks for the cool distro by the way :wink:

User avatar
karlchen
Level 18
Level 18
Posts: 8025
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: PRIME Synchronisation

Postby karlchen » Fri Oct 20, 2017 11:51 am

Considering PRIME support started working for you on Ubuntu 17.10 only and
considering that Linux Mint 18.3 will still be based on Ubuntu 16.04.x,
I dare not speculate on PRIME support on Linux Mint 18.3.
--
Maybe if Ubuntu make availabe the Ubuntu 17.10 kernel and hardware enablement stack on Ubuntu 16.04.x as well ...
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.


Return to “Suggestions & New Ideas”