Another Mintbackup problem...

Questions about applications and software
Forum rules
Before you post please read how to get help
Quirken
Level 1
Level 1
Posts: 14
Joined: Sat Nov 13, 2010 8:42 am

Another Mintbackup problem...

Postby Quirken » Mon Aug 08, 2011 5:20 pm

I've done some searching and found other people having problems with mintbackup, but nobody seems to have the same one as I have, so here goes:

Backed up my package selection with Mintbackup last night. Installed 64-bit LMDE (was using 32-bit LMDE before), did a full dist-upgrade, etc.

Mintbackup loads fine, I can go to "Restore software selection", find my backup no problem, but when I click forward, it gives an error (in terminal):

'Package' object has no attribute 'isInstalled'


Any ideas?

Edit: I restored the 32-bit LMDE (going to wait for the 64 bit respin)... out of curiosity, I went to see if Mintbackup could read the package list in the 32 bit install. No beans. Same error, slightly more verbose output:

dylan@tranquilinux ~ $ mintbackup
'Package' object has no attribute 'isInstalled'
The program 'mintBackup.py' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
(Details: serial 10132 error_code 1 request_code 0 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

Realheroaustralia
Level 1
Level 1
Posts: 4
Joined: Wed Aug 10, 2011 5:38 am

Re: Another Mintbackup problem...

Postby Realheroaustralia » Sat Aug 13, 2011 7:41 am

Backed up my package selection with Mintbackup last night. Installed 64-bit LMDE (was using 32-bit LMDE before), did a full dist-upgrade, etc. :mrgreen:

gorade
Level 2
Level 2
Posts: 66
Joined: Sat Feb 07, 2009 3:53 pm

Re: Another Mintbackup problem...

Postby gorade » Mon Aug 15, 2011 1:52 am

When installed from the disc MintBackup can restore programs (with the inevitable complaint on corrupt packages, of course), but after upgrade and update it can't. It stops and freezes. Some update seems to have gone wrong.
It neither can't make a backup nor restore one from before. It just locks up and has to be closed by force.

gorade
Level 2
Level 2
Posts: 66
Joined: Sat Feb 07, 2009 3:53 pm

Re: Another Mintbackup problem...

Postby gorade » Fri Aug 19, 2011 8:48 am

Still can't save program selection nor restore program selection with mintbackup. Not clever enough to find out what hangs it up. It starts working in LMDE The throbber appears but then it is locked and has to be closed by force. The version on the installation DVD though does what is expected. Some update wrecked it and I can't find a fix.

It works with Katya 64 bit.

gorade
Level 2
Level 2
Posts: 66
Joined: Sat Feb 07, 2009 3:53 pm

Re: Another Mintbackup problem...

Postby gorade » Fri Aug 19, 2011 9:18 am

gorade wrote:It works with Katya 64 bit.


No, it does NOT. Sorry

hozomean
Level 1
Level 1
Posts: 33
Joined: Mon Jun 06, 2011 2:06 pm

Re: Another Mintbackup problem...

Postby hozomean » Fri Aug 19, 2011 2:48 pm

this is related to the LMDE bugs after upgrading to python-apt-0.8.0. I've opened bug https://bugs.launchpad.net/linuxmint/+bug/829743 to track it and am working on a patch now.

Quirken
Level 1
Level 1
Posts: 14
Joined: Sat Nov 13, 2010 8:42 am

Re: Another Mintbackup problem...

Postby Quirken » Fri Aug 19, 2011 3:52 pm

I'm using the new LMDE update packs. But when I tested out the 64-bit LMDE, that was straight out of the box (and then after a dist-upgrade), not using the new repos.

output from the dpkg-qury:

Code: Select all

dylan@tranquilinux ~ $ dpkg-query -l python-apt
dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 38225 package 'pidgin-extended-blist':
 error in Version string 'sort-1': version number does not start with digit
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
ii  python-apt     0.8.0          Python interface to libapt-pkg


I notice you changed your post; should I not install that package?

edit: Looks like you changed it again (and figured it out). Thanks!

hozomean
Level 1
Level 1
Posts: 33
Joined: Mon Jun 06, 2011 2:06 pm

Re: Another Mintbackup problem...

Postby hozomean » Fri Aug 19, 2011 4:01 pm

yeah, sorry for the confusion. I responded without looking at the code (assuming it was something else). Should be a pretty simple fix.

hozomean
Level 1
Level 1
Posts: 33
Joined: Mon Jun 06, 2011 2:06 pm

Re: Another Mintbackup problem...

Postby hozomean » Fri Aug 19, 2011 4:53 pm

patch submitted. seems to work for package save and restore and satisfies all the api changes according to the python-apt migration tool.

Quirken
Level 1
Level 1
Posts: 14
Joined: Sat Nov 13, 2010 8:42 am

Re: Another Mintbackup problem...

Postby Quirken » Fri Aug 19, 2011 4:59 pm

hozomean wrote:patch submitted. seems to work for package save and restore and satisfies all the api changes according to the python-apt migration tool.


Awesome, thanks :D

hozomean
Level 1
Level 1
Posts: 33
Joined: Mon Jun 06, 2011 2:06 pm

Re: Another Mintbackup problem...

Postby hozomean » Fri Aug 19, 2011 6:07 pm

understand what's attached is NOT an approved mint package. use at your own risk (and please install the official package when it comes out). though this generally doesn't seem like good practice, backing up and restoring your files is so crucial that waiting for the changes to make it in might not be an option for some, so, this "unofficial" package should get you through in the meantime. If you choose to use it and have any problems, post here or message me privately.
Attachments
mintbackup.zip
USE AT YOUR OWN RISK! Do NOT post bug reports on this. Not an official mint package.
(74.12 KiB) Downloaded 95 times

Quirken
Level 1
Level 1
Posts: 14
Joined: Sat Nov 13, 2010 8:42 am

Re: Another Mintbackup problem...

Postby Quirken » Fri Aug 19, 2011 9:20 pm

hozomean wrote:understand what's attached is NOT an approved mint package. use at your own risk (and please install the official package when it comes out). though this generally doesn't seem like good practice, backing up and restoring your files is so crucial that waiting for the changes to make it in might not be an option for some, so, this "unofficial" package should get you through in the meantime. If you choose to use it and have any problems, post here or message me privately.


How long do you think it would take this patch to make into the repositories?

hozomean
Level 1
Level 1
Posts: 33
Joined: Mon Jun 06, 2011 2:06 pm

Re: Another Mintbackup problem...

Postby hozomean » Fri Aug 19, 2011 9:54 pm

the last patch i submitted took around a month, but i can't tell you anything for sure. the changes in the attached package amount to about 3 lines of total code, fwiw.

Quirken
Level 1
Level 1
Posts: 14
Joined: Sat Nov 13, 2010 8:42 am

Re: Another Mintbackup problem...

Postby Quirken » Fri Sep 16, 2011 2:51 pm

hozomean wrote:the last patch i submitted took around a month, but i can't tell you anything for sure. the changes in the attached package amount to about 3 lines of total code, fwiw.


Is there anything we can do to accelerate the process? This feels like a really really important patch that the lack of might turn some people off of Mint...

hozomean
Level 1
Level 1
Posts: 33
Joined: Mon Jun 06, 2011 2:06 pm

Re: Another Mintbackup problem...

Postby hozomean » Thu Sep 22, 2011 12:48 am

or just install my package. the diff is in the bugs db... you can know what you're installing very easily.

Quirken
Level 1
Level 1
Posts: 14
Joined: Sat Nov 13, 2010 8:42 am

Re: Another Mintbackup problem...

Postby Quirken » Thu Sep 22, 2011 3:02 am

kaney2021 wrote:Common sense is critical during a health crisis like the swine flu. It can help you sort out fact from fiction. Learn what you can do to help keep yourself safe.


lol

I'm fine with this patch. What I meant is that somebody who doesn't know about the existence of the patch could have their Mint experience tainted by this. In other words, it seems like it should be reasonably high priority for review - especially because the change is so small.

hozomean
Level 1
Level 1
Posts: 33
Joined: Mon Jun 06, 2011 2:06 pm

Re: Another Mintbackup problem...

Postby hozomean » Thu Sep 22, 2011 10:53 am

yeah, i thought it would be funnier to take the swine flu comment seriously. i did email clem and offer to submit to changes to git myself, but I gather they're pretty busy these days with the ubuntu exodus.

Quirken
Level 1
Level 1
Posts: 14
Joined: Sat Nov 13, 2010 8:42 am

Re: Another Mintbackup problem...

Postby Quirken » Tue Sep 27, 2011 1:20 pm

bug page says it's been fixed! looks like Clem got to it =]


Return to “Software & Applications”

Who is online

Users browsing this forum: tymeric and 5 guests