No longer necessary! Dummy Output after kernel update to 5.3.0-42

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

No longer necessary! Dummy Output after kernel update to 5.3.0-42

Post by MrEen »

I believe this fix is only necessary for laptop users with digital microphones installed. The audio driver is changing in the kernel and as of 5.3.0-41, the new driver is taking control, but the Ubuntu base Mint is based on doesn't have all the necessary components in place yet. This will most likely be rectified by the time Mint 20 comes out, but until then here's how to get your sound back.

There are now 2 confirmed approaches to this. As I already wrote out this long one first, it is still included:

Method #1

In the terminal enter xed admin:///etc/default/grub (or change xed for your preferred text editor) and when the file opens find this section:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Change it to this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"
Be aware that you may have already made changes to this line, so adjust accordingly.

Save and close the file, ignore the warnings from the terminal, then run sudo update-grub.

Reboot, and you should be back to working sound.

You may not have noticed, but your built-in microphone probably hasn't been working all this time. It still won't work with this fix, as we're forcing the use of the snd-hda-intel legacy driver. Assuming the Mint 20 release does have the necessary components, the new driver should fix that issue.

Method #2

Run this in the terminal then reboot:

Code: Select all

sudo tee /etc/modprobe.d/alsa-fix.conf <<<'options snd-hda-intel dmic_detect=0'
Yeah, I like #2 better as well!

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: No longer necessary! Dummy Output after kernel update to 5.3.0-42

Post by MrEen »

It appears Ubuntu finally got their stuff together and have fixed the issue.

Beyond that, the fix now enables the Digital Internal Mic Array! I've seen 2 cases so far that are able to use their internal mics to record now.

ultramanjones
Level 1
Level 1
Posts: 1
Joined: Fri May 22, 2020 1:49 pm

Re: No longer necessary! Dummy Output after kernel update to 5.3.0-42

Post by ultramanjones »

Thanks!!! You ROCK!
I've been looking for this solution for 2 months!

Method 2 instantly (after reboot) fixed both my Headphones and built-in speaker sound. Good times.

Just so Google might pick it up for the next guy, here is my info:

Code: Select all

System:
  Host: XXXXXXXX Kernel: 5.3.0-53-generic x86_64 bits: 64 
  Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia 
Machine:
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505GT_FX505GT v: 1.0 
  serial: <root required> 
  Mobo: ASUSTeK model: FX505GT v: 1.0 serial: <root required> 
  UEFI: American Megatrends v: FX505GT.302 date: 07/02/2019 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS driver: sof-audio-pci 
  Device-2: NVIDIA driver: snd_hda_intel 
  Sound Server: ALSA v: k5.3.0-53-generic

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: No longer necessary! Dummy Output after kernel update to 5.3.0-42

Post by MrEen »

Hi ultramanjones, and welcome to the forum.

I'm glad this worked for you. If you've applied all the updates in the Update Manager, this fix shouldn't be necessary anymore. There are still some users that can't get the Internal Mic working this way, but most I believe are now working.

Mint 20 is just weeks away, which will hopefully fully fix everything. The workaround might change at that time (I'm not certain which kernel makes the change) so if the above does't work at that time and you still need to do the same sort of this, changing the fix to this should do it:

Code: Select all

sudo tee /etc/modprobe.d/alsa-fix.conf <<<'options snd-intel-dspcfg dsp_driver=1'
I'm not 100% certain it should be 1 at the end. Might need to be 0 like the other fix.

Anyway, once again I'm glad the post helped you! :D

Post Reply

Return to “Tutorials”