Taking Root/Administrator permissions in Linux Mint (Gnome)

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Level 1
Level 1
Posts: 11
Joined: Tue Apr 24, 2012 4:08 am
Location: Ludhiana, Punjab, India

Taking Root/Administrator permissions in Linux Mint (Gnome)

Postby Thinker » Fri May 11, 2012 1:23 pm

1. Temporary Administrator Permissions in GUI

Open terminal and type:

gksudo nautilus

Press enter and enter password.

A new window will appear which will have administrative rights. Any administrator operations like copy-paste, changing file permissions, editing system files can be done within this window.

2. Administrator permissions for executing a command in terminal

Just type sudo in front of a command to execute it as administrator.

3. Login as Administrator

At login screen, type

user name: root

password: (root password)
Last edited by Thinker on Sun May 13, 2012 1:03 am, edited 1 time in total.
Whether you love or hate, you can't debate that Mint is far better than Ubuntu

User avatar
Level 17
Level 17
Posts: 7543
Joined: Wed Jun 17, 2009 8:20 pm

Re: Taking Root/Administrator permissions in Linux Mint

Postby DrHu » Fri May 11, 2012 2:02 pm

I thought the root account/user was a disabled account in Ubuntu/Mint (Gnome desktop or in general), as those distributions used the first user created as an almost root equivalent(root type user), part of the admin group..

Level 18
Level 18
Posts: 8820
Joined: Tue Feb 03, 2009 10:27 am

Re: Taking Root/Administrator permissions in Linux Mint

Postby altair4 » Fri May 11, 2012 2:38 pm

In addition to what DrHu said about a non existent root account you might also find the following somewhat amusing.
EDIT: I don't think that sentence had the correct syntax. I did not mean to imply that DrHu's statement was amusing - there is no root account.

If I were to edit a system file ... say fstab for example ... I would run the following command:

Code: Select all

gksu gedit /etc/fstab

What's been driving me crazy is that when gedit opens 2 tabs are automatically displayed - one with fstab and another with "Untitled Document 1". I don't remember that happening in Gnome2 so I started my search.

One thing I found was an Ubuntu bug report: https://bugs.launchpad.net/ubuntu/+sour ... bug/838404
Sean Fitzpatrick (sean-fitzpatrick) wrote on 2011-10-09: #3

I see. So does that make the official GNOME position "editing system files should be done with nano or similar" or "system files? why would a user want to edit a system file?"
Sam_ (and-sam) wrote on 2011-10-09: #4

Yep, from my understanding they don't agree with running graphical apps as root. Bug #805682

And a related Gnome bug report: https://bugzilla.gnome.org/show_bug.cgi?id=654184
Matthias Clasen [developer] 2011-07-08 20:10:17 UTC

You shouldn't run nautilus as root. Whats probably happening here is that not
only is nautilus getting started, but also a session bus for root, and diverse
session services, etc etc.

Comment 2 André Klapper [developer] 2011-07-12 11:50:53 UTC

No bug by design here...

nano :lol:

The key word in the Gnome response that I found interesting was the word "probably". Probably? Have all the Gnome2 developers left, retired, or been fired? Anyway "gksu leafpad /etc/fstab" eliminated the irritation since leafpad has no tabs :wink:
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Return to “Tutorials”