Page 1 of 1

Pinnacle Dazzle DVC 100 with sound

Posted: Wed Jan 16, 2013 8:03 pm
by Ertain
Getting the Pinnacle Dazzle DVC 100 to work with sound

Hello Minty users. I have a Pinnacle Dazzle DVC 100 and have been trying to get the thing to work. The video component seems to work, but the audio component does not. So after going through many tutorials and doing some experimentation I have finally figured out how to reasonably make the sound component of the DVC 100 work.

First off, here's my set-up. I have an HP computer with an i7 quad-core, 3.4 Gig processor. It has a GeForce GT 530 graphics card (or at least what I can tell from the read out on my Details in the Settings panel). This has inputs in the front and the rear for a 3.5 mm microphone jack. Also I have 8 Gigs of RAM and a terabyte hard drive. I am currently using Linux Mint Maya with a 3.2.0-29-generic kernel.

1. What I first did was plug in the Dazzle DVC 100 and saw that it was recognized by my computer. It uses the em28xx kernel module.

2. I looked in my alsamixer settings and saw the settings for my microphone jacks.
I set the inputs for the microphone sources to be front and rear. I also looked at the settings for the DVC100 and saw that it uses Line.

3. Just to be extra sure that nothing was messed up in the system Sound settings, I looked at that and made some changes.
I noticed how the Connector was "Line in" and how I had to boost the input level because it was recording at such a low level. Btw, when you're trying to record you'll know that the sound is being recorded from the Line-in of the DVC 100 if you see the Input Level moving.

4. After hooking up all of my component cables (and making sure I connected red to red, yellow to yellow, and white to white), I proceeded to test out if it captured. Here was the tricky part. I used the command

Code: Select all

mplayer -tv driver=v4l2:width=720:norm=NTSC:audiorate=48000:immediatemode=0:forceaudio:alsa:adevice=hw.2,0:device=/dev/video0:input=0 -vf pp=lb tv://
to capture the stream and see if it worked. I had to first use the command

Code: Select all

arecord -l
to get a listing of my available audio recording devices. Here's the results that I had:
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: ALC662 rev1 Analog [ALC662 rev1 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: DVC100 [DVC100], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
I knew that I had to use card 2, because that was the DVC 100. So I set the "adevice" setting in the above command to "adevice=hw.2,0". With this key option I was able to view and hear the stream from what I had hooked up.

5. I was able to also capture video with ffmpeg by using the command

Code: Select all

ffmpeg -f alsa -i hw:2 -f video4linux2 -video_size 768x576 -i /dev/video0 -framerate 60 -c:v mpeg2video -flags +ilme+ildct /tmp/tmp.mpg
In this instance, though, the video had no sound. The problem was that a setting in v4l2 muted audio. So to correct that I used the command:

Code: Select all

v4l2-ctl --set-standard=ntsc --set-input=0 --set-ctrl=mute=0
With this correction I was able to record the video as well as the audio.

This method seems to work, but be careful of a couple of pitfalls I had to maneuver. When you use the above mplayer command make sure to close the window that pops up either by pressing the "x" in the window or pressing escape. If you press ctrl-c you'll stop the application, but at the same time you'll tie up the audio channel that the DVC 100 is using. Also, when trying to capture the stream with VLC the video will be distorted:
All I did in VLC was go with the default settings for Capture Device (/dev/video0 for Video and hw:2,0 for Audio) and set NTSC for the Video Standard. This was the result. :?

What's more interesting was that Tvtime could stream it a nearly 60 FPS. What I did was set the Deinterlacer settings under Video Processing to "Television: fullscreen resolution". The picture's still not the best, but it looks pretty spiffy. :D

I still can't seem to capture audio with guvcview. TBH it doesn't seem to capture video either.
When using other applications like mtvcgui it doesn't capture the audio at all, no matter what I do to the audio.

Well in conclusion I hope this little tutorial has helped you in capturing video, and especially audio, with the Pinnacle Dazzle DVC 100. If you have any recommendations or amendments you would like to add please do so.

Re: Pinnacle Dazzle DVC 100 with sound

Posted: Mon Jan 09, 2017 11:29 pm
by jastombaugh
Sound Fix:

I tried routing the audio from the headphone jack of the camera to the mic jack on the PC and could clearly see audio was coming in. Levels were fluctuating with the action on camera. However, GUVCviewer was still unable to record the audio...
... then inspiration struck like lightning, and I tried a different audio codec. (Went from using VOBIS to MP3) and it captured the audio crisp and clear.

Now... if I could just figure out why all of my footage only comes in B/W and somehow capture the COLOR of these home movies, that'd be great!!!