How to enable login sound on Linux Mint Mate & Cinnamon

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
Brahim Salem

How to enable login sound on Linux Mint Mate & Cinnamon

Post by Brahim Salem »

On Linux Mint if you enable automatic login, you lose your login sound. Here's how you can restore it on both Cinnamon an Mate editions:

1- Enable login sound on Cinnamon:


Go to System>Preferences>Startup Applications and added "GNOME Login Sound" with the following description:

Name: GNOME Login Sound
Command: /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
Comment: Plays a sound whenever you log in

to test sound in terminal, run:

Code: Select all

/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"

2- Enable login sound on Mate:


Go to System>Preferences>Startup Applications and added "GNOME Login Sound" with the following description:

Name: GNOME Login Sound
Command: paplay /usr/share/sounds/LinuxMint/stereo/desktop-login.ogg
Comment: Plays a sound whenever you log in


to test sound in terminal, run:

Code: Select all

paplay /usr/share/sounds/LinuxMint/stereo/desktop-login.ogg
3- change login sound on Cinnamon and Mate:

To change login sound on Cinnamon simply convert your file to .ogg format and name it "desktop-login.ogg" then copy it, as root, to /usr/share/sounds/LinuxMint/stereo and replace the existing file. On Mate, you have to do the same but change the "desktop-login.ogg" file permissions,as root, by right-clicking on it and navigating to Properties > Permissions > Owner and change it from "root" to your username. Mine is "chupacabra" for instance.

that's it :D :D :D
Tim_Olaguna
Level 1
Level 1
Posts: 17
Joined: Mon Nov 03, 2008 2:58 pm
Location: Sacramento, California, USA

Re: How to enable login sound on Linux Mint Mate & Cinnamon

Post by Tim_Olaguna »

What fun! By continually pressing my up arrow while in terminal, followed immediately by hitting return, I drove my dog crazy.
Cheerily Yours,
Tim O'Laguna
not_Daniel

Re: How to enable login sound on Linux Mint Mate & Cinnamon

Post by not_Daniel »

Tim_Olaguna wrote:What fun! By continually pressing my up arrow while in terminal, followed immediately by hitting return, I drove my dog crazy.
/usr/share/sounds/mate/default/alerts/bark.ogg
This one is oddly satisfying.
not_Daniel

Re: How to enable login sound on Linux Mint Mate & Cinnamon

Post by not_Daniel »

not_Daniel wrote:
Tim_Olaguna wrote:What fun! By continually pressing my up arrow while in terminal, followed immediately by hitting return, I drove my dog crazy.
/usr/share/sounds/mate/default/alerts/bark.ogg
This one is oddly satisfying.
Hmm, this is odd -- if you set this to the default MATE sound theme, the audio is left-ear-only. Hate that.
#anotherBug
Post Reply

Return to “Tutorials”