Dell XPS 15z - Install Linux Mint 14 or 15

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
Brucey99
Level 1
Level 1
Posts: 27
Joined: Mon Oct 08, 2012 11:47 pm

Dell XPS 15z - Install Linux Mint 14 or 15

Post by Brucey99 »

I thought I would write a quick tutorial on how to get Linux Mint 14 running on the Dell XPS 15z as the other guides on the interent didn't work for me and I thought this might be helpful to others (UPDTAE: These also work for LM 15)

The instructions at https://wiki.ubuntu.com/HardwareSupport ... ll/XPS/15z need to be slightly changed in order for it to work (for me)

Boot your live CD, when it says 'automatic boot in X seconds', press any key to get to the additional options

With the top option selected ('Start Linux Mint'), press the TAB key to edit the option

Now according to the ubuntu wiki, we should be using the ' acpi_backlight=vendor dell_laptop.backlight=0 ' command as Linux mint 14 has the 3.5 kernel. However, this does not work for me.

Instead, add the following command before 'quiet spash --'

Code: Select all

acpi=noirq 
Then press enter to boot (sometimes it doesn't work and just goes back to the menu, but 9/10 times it works, just reboot and try again if not.)

It should then go to the desktop and you can install.

When you reboot for the first time, you must press the 'E' key at the GRUB menu for the install you just made (if the GRUB menu doesn't appear, I think you hold shift when booting?)

Here we need to use the original command, so before 'quiet spash', add

Code: Select all

acpi_backlight=vendor dell_laptop.backlight=0 
It should now boot perfectly 8)

To make this permanent, open terminal and enter this command

Code: Select all

sudo gedit /etc/default/grub
And modify the line :

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 
to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor dell_laptop.backlight=0 quiet splash" 
Save and close. The in terminal enter

Code: Select all

sudo update-grub
That's it!

I don't know if this will work for anyone else, but it's the only way I have found to do it.

Please comment if it does or doesn't work so we can help others
sal
Level 1
Level 1
Posts: 1
Joined: Mon Jul 01, 2013 4:19 pm

Re: Dell XPS 15z - Install Linux Mint 14 or 15

Post by sal »

Hi.

For me the install steps were similar on Dell XPS 15z to get Linux Mint 15 Olivia running:

1) add boot option

Code: Select all

acpi=noirq
and go through install process

2) on reboot edit GRUB bootl line and start with the same option again (1).

3) install bumblebee as described here: https://wiki.ubuntu.com/HardwareSupport ... ll/XPS/15z

4) Restart and edit GRUB again to be

Code: Select all

 acpi_backlight=vendor dell_laptop.backlight=0 
- inserted before

Code: Select all

quiet splash --
5) update the GRUB boot entry to read

Code: Select all

acpi_backlight=vendor dell_laptop.backlight=0
and don't forget to do

Code: Select all

sudo update-grub
.

Thats all. It works now perfecty! :D
stormrider711
Level 1
Level 1
Posts: 2
Joined: Tue Jul 23, 2013 7:26 pm

Re: Dell XPS 15z - Install Linux Mint 14 or 15

Post by stormrider711 »

I have followed the later of these two tutorials and had trouble with two things.

1. Neither of the acpi commands would allow me to boot when I edited the commands in the boot up grub. I used acpi=off and it worked.

2. I then installed bumblebee as instructed in https://wiki.ubuntu.com/HardwareSupport ... ll/XPS/15z and it does not work "out of the box". I get this error:

[ 257.619184] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[ 257.619210] [ERROR]Aborting because fallback start is disabled.

If you have any insight in regards to fixing these issues I would be much obliged.

Cheers, Storm.
stormrider711
Level 1
Level 1
Posts: 2
Joined: Tue Jul 23, 2013 7:26 pm

[FIXED] Re: Dell XPS 15z - Install Linux Mint 14 or 15

Post by stormrider711 »

I remedied the situation by updating my drivers using the following code:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade


Hope this helps others.

Cheers, Storm.
Post Reply

Return to “Tutorials”