Ultimate COMPIZ - Mate 1.6 - Compendium!

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
Dr. Octagon
Level 2
Level 2
Posts: 82
Joined: Mon Sep 16, 2013 4:43 pm
Location: Osnabrooklyn

Ultimate COMPIZ - Mate 1.6 - Compendium!

Post by Dr. Octagon » Sat Jan 04, 2014 5:01 pm

Hello,

I have to post this due to the long term I was searching for a functional Compiz-Workaround for Mate 1.6 (since it was not compatible with Compiz anymore)! THIS ONE actually works fine (only Original Debian Files, no FORKS):

First: You have to walk through this post of cmost... this will work, for sure and it's worth it! http://forums.linuxmint.com/viewtopic.p ... d6#p803329

Then, if you encounter some strange behaviour while scrolling in Firefox, you have to adjust/edit the following about:config entries in Firefox:

layout.frame_rate from -1 to 480 (if your screen refreshrate is 120 hz - if your screen refresh is different, you have to take another value... but the multiplicator is given here as 4)
layout.frame_rate.precise from false to true
I have the Firefox-Extension Smoothwheel installed, which does a good job, too (Framerate in this Extension 240 hz). about:config entry: extensions.smoothwheel.scrollMaxFPS 240

For all purposes (Desktop and so on):
Additionally you have to add these entries to this file /etc/environment (create it, if it doesn't exist!):
CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True

Forthermore you have to edit your /etc/X11/xorg.conf by adding these entries:

Section "Module"

Load "extmod"
Load "glx"

EndSection


Section "Screen"

DefaultDepth 24
Option "AddARGBGLXVisuals" "true"
Option "XAANoOffscreenPixmaps" "true"
Option "AllowGLXWithComposite" "true"
Option "TripleBuffer" "True"
Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }" (change or comment out #, if you encounter problems in games)

SubSection "Display"
Viewport 0 0
Depth 24
Modes "1680x1050" change to YOUR resolution!!!

EndSubSection

EndSection

Section "Extensions"

Option "Composite" "true"

EndSection

In Compiz itself I have changed the Refreshrate to 180 fps.

I know, you might be wondering why to choose so many different Refreshrates over all... -> I can only say, that this brings back the smoothest Desktop.... as it was standard in Gnome 2. Trust me... Touch the Screen! ;)

Overall RESULT:
No more tearing, best VSYNC (and by the way good Desktopeffects).

I hope, this is helpfull! :)

Cu
Dr. Octagon
A good stumbler doesn't fall...

Post Reply

Return to “Tutorials”