MEGA gnome performance boost

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
User avatar
hairy_Palms
Level 4
Level 4
Posts: 292
Joined: Mon Nov 27, 2006 10:46 am

MEGA gnome performance boost

Postby hairy_Palms » Tue Mar 20, 2007 3:42 pm

Hi,

For the past while I've been experiencing poor performance in GNOME; for example, opening a gnome terminal can take 5-10 seconds on a system that's been running for a while (and with another gnome terminal already open). Having done some research, I found this thread: http://forums.gentoo.org/viewtopic-t...ighlight-.html

Checking my /etc/hosts, I saw:

Code:

127.0.0.1 localhost
127.0.1.1 inspiron

...so I added my hostname to the first line:

Code:

127.0.0.1 localhost inspiron
127.0.1.1 inspiron

(Replace "inspiron" with your hostname)

you should notice a crazy performance boost


REASONS

Explanation why.

This is a fix for the new system that was started back in edgy where the host name was split off to 127.0.1.1, the problem is that some applications still look for the host name @ 127.0.0.1, so to keep those applications happy and running smoothly you simple need to add the host name where those applications expect it to be.

Hope that helps explain the reason understandably.

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Tue Mar 20, 2007 4:13 pm

Thanks!!
The boost is astounding!
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
clem
Level 15
Level 15
Posts: 5664
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Postby clem » Tue Mar 20, 2007 6:11 pm


User avatar
clem
Level 15
Level 15
Posts: 5664
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Postby clem » Tue Mar 20, 2007 6:14 pm

Hi,

Please publish a tutorial on this in the Community Portal.

http://www.linuxmint.com/wiki/index.php ... ity_Portal

Clem

User avatar
hairy_Palms
Level 4
Level 4
Posts: 292
Joined: Mon Nov 27, 2006 10:46 am

Postby hairy_Palms » Tue Mar 20, 2007 10:04 pm

i cant figure out how to add a new page on the wiki.... :(

User avatar
Flint
Level 1
Level 1
Posts: 20
Joined: Thu Mar 15, 2007 6:54 am
Location: Bulgaria
Contact:

Postby Flint » Wed Mar 21, 2007 4:21 am

That worked great :D

Thanks a lot :!:

User avatar
gabhla
Level 1
Level 1
Posts: 26
Joined: Sun Feb 25, 2007 6:36 pm

Postby gabhla » Wed Mar 21, 2007 4:37 am

Saw this yesterday in the Ubuntu forums and tried it out. While it's beyond me why, it does speed things up.

User avatar
clem
Level 15
Level 15
Posts: 5664
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Postby clem » Wed Mar 21, 2007 6:04 am


User avatar
hairy_Palms
Level 4
Level 4
Posts: 292
Joined: Mon Nov 27, 2006 10:46 am

Postby hairy_Palms » Wed Mar 21, 2007 7:16 am

thhanks husse for the pm and thanks clem for putting up the page :)


Return to “Tutorials”

Who is online

Users browsing this forum: No registered users and 6 guests