(almost) Git head Compiz-Fusion

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Level 6
Level 6
Posts: 1284
Joined: Fri Oct 03, 2008 11:25 am

(almost) Git head Compiz-Fusion

Postby FedoraRefugee » Fri Oct 24, 2008 9:40 am

First I want to note that I did not see anything related in this forum besides Merlwiz's tutorial on adding a new enough version to get cube reflection and deformation. But I have always ran real close to the Git releases using special RPMs provided by a FFo member. I was still missing many features and was considering just building Compiz-Fusion myself. But then I remembered using the Shame repo in etch. I tried it and it works the charm. I have had no problems and I have all the latest toys now such as the latest Atlantis 2, Rubik cube, maze, photowheel, cube 3D models (which rocks!) and all the rest.

EDIT: Before proceeding please read note at bottom!

NOTICE: This is NOT considered a stable version, it can mess up. Always be prepared to fix it or revert back! That said, it is in fact very stable and shouldn't cause any problems.

First, remove EVERYTHING Compiz related using Synaptic. Make sure you get everything including Emerald. Then clean all the hidden Compiz files out of /home. This is important. Any old Compiz stuff is going to cause problems.

Now, paste the debian lenny repo from here:


into your /etc/apt/sources.list. You can now

Code: Select all

apt-get install compiz-fusion-all

but I suggest going through Synaptic to make sure you only get Shame packages.

You can now use the latest Git packages also:


As long as you have git and the proper development tools installed.

EDIT: I come back with my tail between my legs! I installed this on my laptop with no problems whatsoever. Yet I tried these steps on TWO fresh installs of Mint Xfce Elyssa and ran into dependency hell. I managed to get both working but it was tricky. Best I can tell you will need to get libc6 and libc6 dev and also popt0 from here:

https://launchpad.net/ubuntu/intrepid/i ... pt0/1.14-4

Try to keep to the links so the packages all match, I am using the intrepid packages. I would also suggest using the Lenny repo instead of the etch as it has a higher version number to match python 2.5. Again, this is workable, but I did not realize these problems when I first posted. By rights, if you cannot solve these types of dependencies then you probably should just stay with the Mint packages or the nice upgrade Merlwiz provided. That is a really slick install and gets you to a pretty recent version. Again, this one may give you a headache, be warned!

Return to “Tutorials”