GPU-fan control [on start-up]

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Ph0z3
Level 3
Level 3
Posts: 151
Joined: Thu Nov 20, 2014 6:21 pm
Location: Kansas City, MO

GPU-fan control [on start-up]

Postby Ph0z3 » Thu Nov 20, 2014 6:46 pm

nVidia fan-control (on startup)

Assuming you already have the proprietary drivers installed and setup... let's go ahead and begin!

1 In terminal run: "sudo nvidia-xconfig"
2. In terminal run: "sudo nvidia-xconfig --cool-bits=12"
3. Navigate to ~/.config/autostart/ now create a document named "nvidia-fan-speed.desktop"
4. open the file with a text editor.
5. so there are no fowl-ups, copy and paste the text below into the file.

[Desktop Entry]
Type=Application
Exec=nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=XX"
X-GNOME-Autostart-enabled=true
Name=nvidia-fan-speed

6. replace XX with the fan speed you would like. 10-100, numerical value only, no percent sign needed.
7. save and exit the file.
8. log out of your system, then back in...
9. PROFIT!
-- If your thread is solved, please add [SOLVED] in caps at the beginning of the post, so others & admins know there is a solution!

Example: [SOLVED] Your_Thread_Name_Here

Direneed
Level 1
Level 1
Posts: 1
Joined: Fri Jan 01, 2016 9:55 am

Re: GPU-fan control [on start-up]

Postby Direneed » Fri Jan 01, 2016 10:00 am

Thank you very much. This has done what I need it to do in linux mint 17.2 KDE

Direneeds
Level 1
Level 1
Posts: 3
Joined: Sun Mar 03, 2013 10:11 am

Re: GPU-fan control [on start-up]

Postby Direneeds » Sun Oct 08, 2017 9:41 am

Again, I want to thank you for this tutorial. I was able to make this work in Mint 18 with the 387.12 drivers. I changed one thing in step #2
From
2. In terminal run: "sudo nvidia-xconfig --cool-bits=12"
To this
2. In terminal run: "sudo nvidia-xconfig --cool-bits=28"

I used 20 in place of xx and now have my GTX 970 running at 34C where it was at 55C and higher at times.


Return to “Tutorials”