How to get MIDI files to play

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
User avatar
xenopeek
Level 24
Level 24
Posts: 22763
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

How to get MIDI files to play

Post by xenopeek » Tue Dec 29, 2015 3:15 pm

As this has come up as a question somewhat frequently the last week I'm making a note of it here.

If you have a MIDI file you'll find by default you can't play it with anything on Linux Mint 17.x. There are two easy solutions.

1. If you are using Cinnamon, MATE, or Xfce you can just install the package fluid-soundfont-gm from Software Manager. It's a big download (110 MB or so). It installs a soundfont so that the MIDI software synthesizer has audio samples it needs to make music. Now you can just double-click a MIDI file in your file manager and it will play in Videos (totem).

Because KDE doesn't come with Videos (totem), this doesn't work in KDE.

2. You can also install the package vlc-plugin-fluidsynth from Software Manager. This will add the ability to play MIDI files to VLC.
Image

User avatar
all41
Level 13
Level 13
Posts: 4637
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: How to get MIDI files to play

Post by all41 » Tue Dec 29, 2015 8:02 pm

+1
Thank you for posting this.
I used to use timidity, but haven't even thought about my midis for a while.
This works a+ with vlc for me now I am enjoying my collection of midis
Proud to be a supporter and monthly contributor to Mint.

User avatar
xenopeek
Level 24
Level 24
Posts: 22763
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: How to get MIDI files to play

Post by xenopeek » Mon Jun 05, 2017 1:06 am

For Xplayer on Linux Mint 18 and above you need gstreamer1.0-plugins-bad and fluid-soundfont-gm to be able to play Midi files with it. You can install them in one go with the command:
apt update && apt install gstreamer1.0-plugins-bad fluid-soundfont-gm
Image

Skalman
Level 1
Level 1
Posts: 21
Joined: Sat Dec 17, 2016 12:28 pm

Re: How to get MIDI files to play

Post by Skalman » Sat Feb 03, 2018 12:16 pm

Same problem.The hint above solved it
Thank You!!!! :D

User avatar
kc1di
Level 13
Level 13
Posts: 4663
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: How to get MIDI files to play

Post by kc1di » Sat Feb 03, 2018 12:21 pm

Thank you for the tip xenopeek :)
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

User avatar
Flemur
Level 16
Level 16
Posts: 6061
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: How to get MIDI files to play

Post by Flemur » Sat Feb 03, 2018 12:25 pm

I play midi files in foobar (/wine).
Edit: to make them sound good - well, better, put this sound-font file somewhere
http://www.ntonyx.com/soft/32MbGMStereo.sf2
and point to it: File->Preferences...
foobar-midi.jpg

Code: Select all

apt update && apt install gstreamer1.0-plugins-bad fluid-soundfont-gm
...
The following NEW packages will be installed:
  fluid-soundfont-gm gstreamer1.0-plugins-bad gstreamer1.0-plugins-bad-faad
  gstreamer1.0-plugins-bad-videoparsers libde265-0 libgstreamer-plugins-bad1.0-0 libgtkglext1 libmimic0
  libmjpegutils-2.1-0 libmms0 libmpeg2encpp-2.1-0 libmplex2-2.1-0 libofa0 libopencv-calib3d2.4v5
  libopencv-contrib2.4v5 libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-highgui2.4v5
  libopencv-legacy2.4v5 libopencv-ml2.4v5 libopencv-objdetect2.4v5 libopencv-video2.4v5 libspandsp2 libsrtp0
  libvo-aacenc0 libvo-amrwbenc0 libwildmidi-config libwildmidi1 libzbar0
0 upgraded, 29 newly installed, 0 to remove and 1 not upgraded.
Need to get 123 MB of archives.
After this operation, 165 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.
Of course "abort". 123 MB of downloads and 165 Meg of disk space to play midi files is ludicrous.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Post Reply

Return to “Tutorials”