How to get Banshee working in Linux Mint 18

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
Total_Blue
Level 2
Level 2
Posts: 96
Joined: Wed Sep 07, 2011 5:01 pm

How to get Banshee working in Linux Mint 18

Post by Total_Blue » Sat Oct 15, 2016 6:43 pm

A number of people using Linux Mint 18 have been having issues getting Banshee to work. When I used Banshee 2.6.3, which is the version that comes with LM18, with just a few songs, it was quick to load, and use and worked great. Once I imported my music library of over 20000 songs, it would take 3 minutes and 16 seconds to load (I timed it). It also would occasionally freeze when using it. I have tried in on two separate Cinnamon installs and a Mate install with the same results.

My solution:

pkgs.org offers the Ubuntu Xenial (which Linux Mint 18 is based on) version of banshee_2.9.0+really2.6.2-7ubuntu2_amd64.deb for download at https://pkgs.org/ubuntu-16.04/ubuntu-un ... 4.deb.html.

I downloaded the deb file, uninstalled Banshee 2.6.3 from my system, and then using Package Installer, installed 2.9.0 (which is really just a modified 2.6.2). After installing it, I clicked to open it, and it opened right away. I didn't even have to import my media again, as it read the database I had created with 2.6.3. Also, all the Banshee extensions available in Synaptic for 2.6.3 that I tried, worked for 2.9.0.

I did run into one issue with it, in that it would freeze and hang when importing media or playlists. The fix is to go into extensions and make sure the Podcast and Emusic extensions are disabled. I have done that, and now have a working Banshee in LM 18.

Hope this is of help to others

Post Reply

Return to “Tutorials”