Dell Aurora R6 dual boot How-To and issues I ran into.

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
Freth
Level 1
Level 1
Posts: 6
Joined: Sun Aug 30, 2015 7:42 pm

Dell Aurora R6 dual boot How-To and issues I ran into.

Post by Freth » Mon Dec 11, 2017 3:55 am

I just recently purchased a Dell Aurora R6. I set about installing Linux Mint on the system, which wasn't that difficult once I found the correct BIOS settings. Then I noticed a shutdown bug that I would work on for several hours. I was about to give up when I found the answer. But first, installation.

Installation

The first thing I needed to do was shrink my SSD volume, so I could install Linux on the second half of my 256GB SSD. The problem is Windows 10 puts system files far on the end of the partition and you have to remove those first.

1. Run the Disk Cleanup Wizard, making sure to remove the hibernation file and all restore points.
2. Disable System Restore
3. Disable the pagefile - Open up System in Control Panel, then Advanced System Settings \ Advanced \ Performance \ Advanced \ Change \ No Paging File.
4. Disable kernel memory dump. In the same Advanced Settings, go to Startup and Recovery \ Settings and then change the Write debugging information drop-down to “None” to disable the kernel memory dump.
5. Disable Hibernation mode in your power options \ advanced power options screen.
Reboot the machine, and then delete your c:\pagefile.sys file (if it exists).

Then use Disk Management to shrink the volume in half. Leave the remaining unallocated.

F2 on boot splash screen to enter BIOS. Change the following settings:

BIOS changes for installing Linux.
Advanced - SATA Operation - Set it to AHCI, not RAID
Boot - Secure Boot - Disabled (ignore warnings, Windows will be just fine)
Boot - Boot List Option - UEFI
Load Legacy Option ROM - Disabled
Attempt Legacy Boot - Disabled

Load up your Linux Mint Live USB or DVD and run the installer.
When you get to the drive window (Erase, etc.) select Something Else.
Find the unallocated space of the second half of the SSD. Add a swap partition the size of your memory. Add an ext4 partition and designate / in the dropdown.
Continue with the install.

Everything should work fine, EXCEPT...


Shutdown Bug

Linux Mint wouldn't shut down properly on my R6. It would hang with a kernel panic. I was able to get it to work using kernel 4.4.0.21, but on other kernels it would hang. After further investigation, I found the issue to be i2c-designware-core. If you blacklist it, the system shuts down normally. This seems to be a common issue with Dell systems, but I only found the answer in one place (http://helloworldproject.blogspot.com/2 ... nware.html).

Create a new file in order to deactivate (blacklist) the module:

$ sudo nano /etc/modprobe.d/blacklist-i2c-designware-core.conf

and copy the following line in the conf file: install i2c-designware-core /bin/false

Reboot the machine once, and then try shutting down again, now the computer should shutdown ok.

You can delete /etc/modprobe.d/blacklist-i2c-designware-core.conf if this fix does not work for you.

Post Reply

Return to “Tutorials”