Asus Eee Pc X101ch and Intel Atom: Fix The Speaker And Microphone!

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
User avatar
sebastjava
Level 2
Level 2
Posts: 59
Joined: Wed Jun 28, 2017 8:01 pm
Location: Montréal
Contact:

Asus Eee Pc X101ch and Intel Atom: Fix The Speaker And Microphone!

Post by sebastjava » Thu Feb 22, 2018 1:47 am

This is just a part of a group of short tutorials:

Asus Eee Pc X101ch and Intel Atom: Start With Linux Mint Mate!

Asus Eee Pc X101ch and Intel Atom: Fix The Speaker And Microphone!

Asus Eee Pc X101ch and Intel Atom: Get A Suitable Video Playback!

Asus Eee Pc X101ch and Intel Atom: Get A Precise Brightness Control!

Asus Eee Pc X101ch and Intel Atom: Get Those Missing Blue Function Keys!

Remember: I strongly recommend you Start With Linux Mint Mate! Some of the things described here will only work with Linux Mint Mate. But some others could also be useful on other systems.


Fix The Speaker

I had this problem with the other Linux distributions as well: the headphones are OK but the internal speaker is not working. Alsamixer is responsible for that. We can fix that.

By looking at alsamixer in the terminal i got this information:
ASUS EeePC X101CH = Card: HDA Intel, Chip: Realtek ALC269VB
Then i went through the pages listed at the bottom of this tutorial.

Follow these steps:
  1. Add this line of text:
    options snd-hda-intel model=headset-mic
  2. At the end of this file:
    /etc/modprobe.d/alsa-base.conf
    To do this you need root access, so right-click on this file to open it in your text editor (Xed) as "administrator" or "super-user". Add the text line at the end and save the file.
  3. You must restart your computer to see (and ear!) the change.

Fix The Microphone

If you want to record something, like when using Cheese, the sound input from the internal microphone is just noise. You could temporarily fix this by opening alsamixer in the terminal and turn down Mic Boost to zero. But you would have to do this again and again after each shutdown/restart. Try if you want.

To get the right Mic Boost setting once and for all, you need to make small changes in 2 files in .../pulseaudio/alsa-mixer/. That's because PulseAudio and Alsa-mixer interact with each other. So just do what follows:

Disable Mic Boost:
  • Edit as root: /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf
  • Edit as root: /usr/share/pulseaudio/alsa-mixer/paths/analog-input-mic.conf
  1. Under "[Element Internal Mic Boost]" set "volume" to "zero". (if set at "off", leave it there)
  2. Under "[Element Int Mic Boost]" set "volume" to "zero". (if set at "off", leave it there)
  3. Under "[Element Mic Boost]" set "volume" to "zero". (if set at "off", leave it there)
Search all 3 "[Element..." in both files to make sure that the required changes are all done. There aren't many, it takes 2 minutes. Save the changes and restart your computer to see (and ear!) the results when you record something with the microphone.

Note: Once in a while, there is a PulseAudio or AlsaMixer update from your MintUpdate. When that occurs, you have to re-edit those two files...

Sources:

Changing alsa-base.conf to fix the speaker:
https://doc.ubuntu-fr.org/audio_intel_hda (in french...)
https://www.alsa-project.org/main/index ... _Intel_HDA
http://git.alsa-project.org/?p=alsa-ker ... xt;hb=HEAD

Fixing the microphone:
https://askubuntu.com/questions/279407/ ... put-volume

Alsamixer, in the terminal, after following this tutorial:
Speaker level is up while headphones are off. You get the opposite when you plug in headphones: headphones up and speaker down. That's how it works, that's how it should be after following this tutorial. Also, note the Mic Boost at zero, even after restart: that's good.
Attachments
Capture du 2018-03-17 09-45-30.png

Post Reply

Return to “Tutorials”