[SOLVED] Install shutter with edit button on LM 19 XFCE

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
flyingrhino
Level 3
Level 3
Posts: 137
Joined: Sat Apr 04, 2015 8:55 pm

[SOLVED] Install shutter with edit button on LM 19 XFCE

Post by flyingrhino » Tue Aug 28, 2018 12:43 am

Probably works for all LM 19 but I use XFCE so it's tested and working on XFCE.

To use the edit button in Shutter requires some dependencies that are missing on LM 19 repo. If they are not met, shutter will still run, but the dependencies are greyed out.

I did the process manually, but there are two guides here:
https://www.linuxuprising.com/2018/04/f ... ut-in.html
http://ubuntuhandbook.org/index.php/201 ... ntu-18-04/

Here's how I did it:
apt-get install libextutils-depends-perl
apt-get install libextutils-pkgconfig-perl

Search for these packages:
96 -rw-rw-r-- 1 ken ken 94150 Aug 28 16:28 libgoocanvas3_1.0.0-1_amd64.deb
20 -rw-rw-r-- 1 ken ken 12962 Aug 28 16:27 libgoocanvas-common_1.0.0-1_all.deb
172 -rw-rw-r-- 1 ken ken 171412 Aug 28 16:26 libgoo-canvas-perl_0.06-2ubuntu3_amd64.deb

Here: https://ubuntu.pkgs.org/
And chose ubuntu 17.10 64 bit.
Then installed them manually by clicking on the files.

Make sure to kill shutter if it's running or ran in the past since reboot:
ps auxfww | grep shutter
kill <SHUTTER_PID>

It should give you the EDIT button now.

Post Reply

Return to “Tutorials”