[SOLVED] Claws open with - file association under XFCE

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
flyingrhino
Level 3
Level 3
Posts: 145
Joined: Sat Apr 04, 2015 8:55 pm

[SOLVED] Claws open with - file association under XFCE

Post by flyingrhino » Sun Nov 11, 2018 7:42 pm

Using LM19 XFCE.

Most of the time claws mail opens a file with the correct program when you hit the 'L' button.
However sometimes it gets it wrong - such as choosing gimp to open pdf files instead of xreader.

When you open Menu -> Mime type editor , it shows xreader first, followed by gimp and libreoffice, and the same appears under File manager -> right click PDF file -> Properties . But claws still gets it wrong.

Solution - Use 'O' button in claws to select the correct program (in my case xreader), then select 'Remember this' . Next time it will open correctly.

BTW, I've not figured out how to remove stupid setting of gimp opening PDF file from Mime type editor GUI program (you can add custom programs but not remove any). There is probably a config file somewhere, if someone cares please post the answer.

Enjoy...

Post Reply

Return to “Tutorials”